Calibration and now software woes

I have tried to calibrate the M4 several time over the last few days. The first time seemed to be the best one. On the first time the M4 went through all way points then started to count up by 100s up to 30700 at .53xxxxxxx fitness then I had to leave while it was still running. I was using my phone at the time so when I left. I am guessing it never finished because when I came back and connected again I could not see anything else counting up or have any fitness score anywhere I found. The next ones seems to fail due to losing connectivity. It just finishes and then nothing for over two hours. Now I don’t even let the machine complete the waypoints if I see it is losing connection to the machine. Which is part of the issue. When I try to run the calibration it usually fails after a random amount of waypoints. It is a bit disheartening.

Onto the software woe. When I first uploaded the firmware it was easy. I started with .67. I noticed when I went to .68 it took me about three power cycles to see any update to the software. After the 3rd attempt I see that it now shows me having version .68. In the middle of the week on Wednesday the 17 of April I tried to use the latest version of .69. I have power cycled the machine and the FluidNC several times. I never see the version number change. I do not know if the version number of the software was accidently was left as .68 or my machine will no longer take updates. I have tried the firmware update about 4 times now. When I look at the info, it still shows .68. I didn’t have as many network failures when I was on .67, Maybe I should go back to that one.

I am sort of at a loss. if I cannot update the software, I won’t be able to fix any bugs that may be causing this. If I get more time, I will start going through the code to see what I can do. I used to program about 8 years ago. Maybe I will find something that will help.

thanks in advance

Calibration is an issue right now for many users. Bar is actively working on improving the process and getting it dialed in but it’s complex to say the least.

It’s also important that whatever device you are using to connect to the Maslow does not lose connectivity or go to sleep, otherwise you lose access to any feedback the machine is trying to send. I would recommend trying to connect with something you can keep in the room with the Maslow while it’s running. It’s probably not a good idea to leave the Maslow unattended while it’s running anyway. Things can go wrong quickly.

In terms of the firmware, if you’re trying to run a version that hasn’t had an actual release yet, it will most likely not show the correct version in the UI. There was a similar thread from earlier today: Double check Maslow version number

1 Like

I appreciate the response. After my first issue with the phone i have a dedicated laptop that I use. I just didn’t have it ready for the calibration. All of my subsequent tries were on the stationary laptop that does not go to sleep.

As far as leaving the maslow in the calaulation point of the routine, i am guessimg nothong else happens or am i wrong. I figured it would be happy calcualting for hours if it needed.

Is there a giestimate on how long a 8 x 10 wooden frame would take to calculate the calibration? I waited over an hour the first time and it just kept going. Should i expect 2 or three hours for this? Or is this an all day thing i have to dedicate on the weekend for it to churn and churn. That is if i can keep the maslow communicating with my network. I can see my laptop is still able to look up stuff on the net after i see the no communication message so i think it is not the laptop.

When i downloaded the .69 on Wednesday it was umder Bars .69 post. So i was hoping that was the corrcect location. I guess the link could be going back to the older one as well.


have you had success since? I know the newest firmware has had better results. Not sure what todays FW is going to do. It goes through a 9x9 point calibration (81 point reads… 82 with the rehome after its done )
I have found when doing calibrations If I have it on my laptop and on my phone at the same time I tend to have issues with the connection.

Please let me know if you have had any success with this.

1 Like

I completed a calibration with v.70 a few days ago. However, when I went to jog it around, it only moved about 10% of the 100 mm movement I tried. Maslow only moved about 10 to 15 mm in any direction even though I set it for 100 mm. I thought it best to install the .71 firmware however I am still unable to complete a calibration again. I am still getting loss of communication at various times. I will not be able to use the cnc if it cannot go a few minutes without losing its network communication to the laptop.

I went back to just using the Maslow as an AP and I am only connecting my laptop to the Maslow WiFi. It still varies when it loses communication. Is there any way to run a debug log that might let me know why the device loses communication either in 5 minutes or 20 minutes? I will continue to try different things to try to see if it improves.

Any ideas would be very appreciated.

1 Like

That is annoying. Without a reliable connection it’s hard to use.

The first thing that comes to mind is maybe using a wifi repeater which could make the wifi connection stronger in the area where the machine is. I agree that until we figure out the connection issues it’s tough to move on.

The rig is now setup with a laptop that is dedicated to the Maslow AP for connection. I pulled it off my normal house Wi-Fi.

I ran into a snag yesterday, the top left and bottom left would not extract during the extract all. I restarted the device from the Fluid section, then powered down the Maslow. It still would not extract those two. I re-uploaded the latest firmware and still no go. I then found that if I moved the belt a little back the motors would turn about an 1/2 in. So I spent some time getting the belts pulled out passed where I knew the usual length for my frame. I then retracted them with the hope that it would see the distance and reset itself. In the end I decided to turn the device off for a few hours to see if that would do something. Happily, yes that did it.

So now I can extend and retract today. I went to run the calibration a few minutes ago and by the time I walked back over to my laptop (about 8 feet away, connected to Maslow AP directly) from extending all the belts and attaching them to my frame, the laptop and the Maslow lost connection. I might need to purchase a new maslow board to see if the Wi-Fi chip is malfunctioning.

Is it possible to use the Maslow directly from the USB port on the board and bypass the Wi-Fi? Not as convenient for sure, but I might be able to move on.

Would the sleep and/or powersave functions of a computer cause this? I know it would on the classic maslow with USB connection.

Great idea to check. I have the power not to go off and sleep not come on for 4 hours if plugged into the outlet. The difficult part is the when I only 5 minutes before it losses connection. Then I have to start the process again.

Not at this time. The calibration process requires the web application, which only works over wifi.

Once calibrated there might be options for using usb (the GRBL interface is exposed on USB) without the UI and another gcode program like universal-gcode sender or openbuilds control or … But I could not get the current version to work on openbuilds control, so this may not yet be an option.

During my many calibration attempts, I would just make sure I moved my mouse or clicked in the serial area with my finger on the tablet every minute or so so it would not go to sleep. Also if something fails, if you can copy the serial messages out of the browser it sometimes helps to debug things. Just don’t “refresh/reload” the window.

1 Like

Ron Lawrence wrote:

Not at this time. The calibration process requires the web application, which only works over wifi.

It may be possible to carefully measure the anchor points and put them into this
manual calculator and get good results. In theory it can work, nobody has tested
it yet.

David Lang

I can send you a new one to test when the next batch arrives to test.

You can operate the machine entirely over USB, but we haven’t worked out the software to be a smooth user experience yet, especially during Calibration

Some computers will automatically disconnect from a wifi network if it doesn’t have internet access. My phone used to do that prior to 0.71 but then that update fixed it (for iphones). I think that the connection dropping is more likely the computer disconnecting than the ESP32, but both are possible

I am hoping I found the culprit for the losing connection. I did add a windows registry that supposedly stops the network card from searching for a new connection if it does not have internet connection. I will need more time to keep checking. The connection had enough time to complete the calibration.
Add a registry value to the following key: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator:

Name: NoActiveProbe
Type: DWORD (32bit)
Value: 1

I have not tried the Z access since first putting it together. The Z access is not moving. It sounds like the Z access motors are always trying to move. They get real hot. I did not noticed this until it was really quiet in my shop. When they are plugged in they sound like they are constantly trying to move in one direction or the other. I am not sure now long this has been doing this. I hope they are not ruined. Last night I loosened up the bolts all around the Z access to see if there is something that is stopping they still make like a fan type noise of sound. If I unplug them the sound stops. I am going to try to take the Maslow apart and see if the motors will run without having anything from holding them back. I will keep my fingers crossed. Any ideas would be very helpful.


1 Like

I think that this sounds like a smart move.

Do they make that noise always or just sometimes?

If the data in the Maslow.yaml file gets corrupted the machine doesn’t know which pins the motors are connected to so they will always be on but not move which sounds like what you might be seeing

Firstly, I tip my hat to bar for the possible reason my connection might have been dropping when I was on the Maslow local AP and the Z axis diagnoses. The Z axis issues were the .yaml file. Once I uploaded the file again, it started to work. On the connection front I put the registry key I mentioned above, I have not seen random connection losses.

I still get connection issues if I take the Z axis all the way down where the motors bottom out then I try to move the X and Y. The connection is instantly lost. At this point the Maslow console won’t respond due to the connection loss. The only thing to do is turn off the Maslow at the power source. Once back up I then do the retract, extent. Sometimes it’s ok, but many others I am over my 15 mm from dead center so I have to run the calibration again. Sometimes one or more of the belts won’t retract all the way and I wind up trying to extend and retract and try rebooting and refreshing the web page, then power off and on. For some reason if I leave it overnight, all the belts start retracting again. Then I start over and repeat. I am still unable to start a cut.

After doing this as many times as I have the last few weeks I decided to put the power on a remote control so I can turn it off without wearing out a plug.

Any guidance would be greatly appreciated.

1 Like

The only thing that I can think is that it’s a power issue and when the machine draws too much power it’s restarting.

Is it possible to try on a different outlet in a different location?

I pulled the power off of the remote and plugged it directly i to the 20 amp circuit. It moves around in X,X and Z. I might have found out what seems to be happening. I noticed that a belt is very loose so I tried Apply Tension in setup. I recieved “Emergency stop! Stoping all motors”. Then I recieved the warning “The machine will not respond until turned off and back on again”

I have to do as directed. I am going to do some more analyzing of my steps to make sure i get this right. Mayne I can release first then apply tension.

1 Like

The motors were constantly running. I believe this was why they were very hot

1 Like

Apply tension is something that you should just do once at the beginning after attaching the belts to the frame instead of running calibration. I’m not 100% sure what it will do if you press it at other times, but I think it’s reasonable that the machine would trigger an estop.

Check out 0.72.1 in the interstitial firmware releases thread to increase the tension in the belts, that’s something I noticed too and it’s quite a bit better with that update for me.