Left Motor test fails

Yes, I know. If you read through the thread, you will see the problem, I know that if I do those things I need to re-calibrate.

Hmm. I see. Try pushing down lightly on the heatsink that drives the left motor. I seem to recall that some of the boards had bad solder joints and eventually the driver fell off the maslow shield entirely. If your motor runs properly with the driver pressed down, then it’s probably a cold solder joint. This could be fixed it you have soldering skills, or you could get a new shield. I think there are a couple of people selling them currently.

1 Like

Heat sink that drives the left motor? What exactly are you referring too?

Your shield and heatsinks may look slightly different, this is the original version, but you should have attached the included heat sinks to your drivers during the building of your kit. Whichever side is giving you troubles, try pressing down on it and then running your test.

1 Like

Okay, I will give that a try

This is the thread where people reported their chips falling off, possibly due to a bad solder joint, or overheating of the driver.

1 Like

Thank you!

Alright, so I looked into that thread, I did buy my machine in the batch after the one with the chip falling off problem, but I still took a look at mine. The chip was still very secure. I did glue the heat-sinks onto the chip pretty soon after I got my machine because they kept falling off of the chip. could this be causing the problem? I would be surprised because of how long my machine ran with the glue I used, but I don’t know all that much about the board itself. Should I have used a different glue? Could the glue be interfering with something? @Jatt @Gero

I can’t diagnose remote, but have fried 3 shields. Where this post is now, i would not exclude the left chip to be burnt. Is there a history of a chain wrapped around the sprocket or are you using a heavy sled (what’s the weight)?

Between the heat sink and the chip there are 2 kinds of ‘thermal paste’ you can apply.

  • ‘thermal paste’
  • ‘thermal paste glue’

Using anything else will isolate the chip from giving it’s heat off to the heat sink.

1 Like

My sled is of normal weight, no extras added, and the chain has not been wrapped around the sprocket.
thank you for your quick response! I guess I probably need a new shield then?

1 Like

You seem to have excluded everything else. What glue did you use?

1 Like

A dab of superglue, it must have worked for a period of time because I used my Maslow a lot since I glued the heat-sink on. It must have been dispersing some heat, but not enough heat.

A new shield is worth a try if the budget allows and if it was not the issue, to have one spare is never a bad idea.

1 Like

Yes, I was just looking and it seems that the Maslow Surplus Shields are out of stock, and MakerMadeCNC does not sell them separatly.

Price is :-/ but it survives more currents :wink:

Okay, thank you!

im not sure if this is exactly the issue being discussed but i have a left motor issue.

my left motor fails test 1 out of 2 100% of the time. i have replaced

  • the left motor
  • the left motor wire
  • the shield and arduino

at this point i do not understand what it could possibly be. it seems to operate correctly when cutting or when moving the sled around on the board manually but i have never gotten it to pass all the tests.

It’s a puzzle, but it sounds like you’ve got all the right parts on hand. Here are some questions:

Does the failing motor run at full speed during the portion of the test that fails, and turn in the direction opposite during the portion that passes? If yes, the encoder on the motor or the Arduino itself might be where to look, or electrical interference if that motor cable is routed near a power cable.

Does it still fail ‘tests motors’ if you remove the chains?

If you swap the MP1 and MP3 cables on the shield, does the right motor fail instead of the left? If yes, the motor or the cable are suspect. If no, the shield is suspect.

Is the “Settings/Advanced/PWM frequency for motor control” set to “490Hz”? The TLE5206 boards lose torque at higher settings. The stock Maslow boards v1.3 aren’t affected that way.

i dont know why or how but i changed computers. i got one just to run mazlow and after switching over to the other computer that issue never happend again. all the tests pass every time. is there any reason this would happen?

1 Like

I can’t think of a way that a computer could directly cause the problem with the left motor, but something in the process of changing over might. Did you disconnect the Arduino form the motor cables during the swap? I made a pretty good living in a previous lifetime fixing mysterious problems by doing things like re-seating connectors…

1 Like