Makercam doesn't load some SVG files

Thanks Adam will try and thank you very much.

Hi Gero

I have just taken a picture of the item I want to generate an *.nc file and after using the bit trace I end with two line around the edge of the part. I have tried several things to remove but cannot, any suggestions?

When in makercam and want to profile this (outside) it comes with a double path one for the inside line and one for the outside of the outside of the outter most line which is not what I want.

Hi Marty,

Are you using Inkscape to trace the picture?
Also, are you able to upload images yet? If so, it will be easier for us to help you by trying it out ourselves. If you have a link to the image, that would work too.

If you are using Inkscape, depending on the image, you might be able to use “stroke to path” to get rid of the double lines. Again, being able to see the image will help; the original, any conversions you made before getting to the svg, and the resulting svg. At the very least, a narration of your work flow (including the file types and programs used) will help us try to troubleshoot.

This may be the long way around so if anybody else has a better way to delete something from makercam please let me know! However, this is how I do it:
I select the unwanted items in makercam, then I go up to edit and resize the selection to 1% by 1%. I then repeat this process as I see a small speck on the screen usually and then the spec must be small enough that it doesn’t register because I’ve never seen a trace of them again (after I resize it twice to 1% by 1%) to confuse me!
To me, this is very annoying and I just wish there was a delete selected option but have not yet found it. I hope this helps.

Thanks for helping, after the geometry is brought into makercam and I deleted all the specs I still have a double line around the outside of this. I click on either inside line or the outside line and both highlight and all I’m trying to d is delete the inside line. I can’t seem to do it.

1 Like

There is some solution in inkscape to the double lines, let me search.


It’s still called that and indeed misleading. Some old relict that was never changed i guess.

Good to know. I will be testing it out asap

Yes. Sometimes it is extremely difficult to select only one! I have actually just worked at it until I got it each time I had this problem.
The solutions @Gero & @Keith have for you here will probably be great. I, however (at least for the time being) will stick to deleting by reducing because I have no time to learn a new path right now! :smiley:

Has anyone figured out to convert an image to a svg file and makercam doesn’t show two line around the edging Tried numerous programs and can’t seem to do it. How does everyone load their files into makercam?

Did you try the thread that @Gero posted?

Here is one more from Giggle: shrinking path or average between 2 paths
Not sure if this helps in your case. Upload the .svg, preferred as a .zip an we will see what we can do.

Edit: Or the image that you want traced.

this wouldn’t work for me. The geometry after the trace comes up with a very heavy outline and I think this is the problem. Makercam see’s this as two lines and not one big wide line so it give’s it a double path.

The one with the double line road? Inkscape after tracing my design gives me a very heavy outline and when Makercam see this it assigns an inner line and an outter line which I cannot break apart. I still have no answer on how to do this, but will keep pugging along.

I believe you will need to break this apart in your svg editor and not Makercam. I suggest using Inkscape if you are not already. If you are, that thread @gerolinked to has a link to a plugin which should put a midline between the two lines. This may not be what you want, though, and Inkscape will offer the best options to change the lines before importing into Makercam. here is the link for my svg file

1 Like

Ok. Clear now why makercam will not load it.
The .svg makercam is expecting is a ‘vector graphic’. Your .svg is a very large image embedded in a .svg. Makercam can not process that.
With that image lighting a ‘trace bitmap’ in inkscape will also not create a usable trace.
Try to reduce the size in inkscape to the size to be cut and then draw around the shape. Delete the image once you’ve drawn and save that .svg for makercam.


it might be easier to manually trace that.
here’s my attempt, took about 3 minutes. note: this is a bit rough, it was hard to tell where the foreground edge was exactly, but it should be close enough to get you started.

1 Like

I tried to trace this out, but I not sure how you drew this but all I get is all kinds of wavey lines.

Well, it’s a vector path, so if you want to edit it you’ll need to open it in an app that can edit vector files like inkscape or illustrator. Here’s a screenshot of it in inkscape, after resizing to 16 inches wide and 9.137 inches high

Each one of those squares defines the curve of the line, and you can edit them with the “edit paths by nodes” tool in inkscape. If you click on one of the squares with that tool, it shows the point that is selected in black, as well as the handles for that point and the points around it.By dragging the handles, you can adjust the curve, and by dragging the point, you can adjust the location of the center of the curve.

if this is your first experience with bezier curves, you’ll probably get a better experience by watching some youtube instructional videos, this one looked decent for teaching the basic use of the bezier tool in inkscape: