Maslow Home Maslow Community Garden Newsletter

Makerverse appears to work with Mega and firmware ver 1.28

I was having some issues with Makerverse and Holey so I decided to try GC and flash ver 1.28. Once I did the initial setup everything worked great. I still wanted to use Makerverse because of the callibration which seems easier.
Once I had used GC and determined it was fine and if I continued to have issues with Makerverse I would go back to GC.
Here is what happened. While I was loading GC ver 1.26 I noticed a message that I didn’t have the latest issue of GC ver 1.28 which I ignored.
I shut GC down and instead of flashing the Holey firmware I just opened Makerverse. Now this comes to the reason for this post. Everything appears to me to be working properly. I did an edge callibration which was out more compared to my first callibration with Holey and Makerverse but went smoothly and definately improved the accuracy.
I have’t tried loading or executing any G-code yet as I am waiting for a new Z-axis motor.
Am I missing something? I understood that Makerverse would not work on the mega without the Holey firmware.
I don’t want to assume this is fine and continue to use it and cause myself grief because of my ignorance.