Maslow Home Maslow Community Garden Newsletter

Makerverse Login

@zaneclaes

There is one user I know of who plans to use makerverse on an older windows version. Once they get it loaded (I assume via USB stick), it will have no internet access. Is there a process to get it to log in to makerverse without phoning home?

Simply put: login, then stay offline = stay logged in.

So, FWIW, right now the way it works is:

  • If the Makerverse computer is offline, it will not phone home.
  • It will assume any previously validated login is still valid.
  • If it comes online, it will try checking any new logins.
  • Logins only expire every 30 days now.
  • If you come online within 30 days, your login will be extended 30 days.
  • If you stay offline more than 30 days, then online, you’ll be forced thru login prompt.

Finally, I am working on the account-less “guest mode” system. It requires turning on the setting, as discussed in the thread, to disable account login requirements. It will also display a prominent warning screen in place of a login screen, which must be accepted by each browser which accesses Makerverse.

1 Like

PLEASE, make this a priority. Needing an external site that seems to be unreliable to utilize a local machine is not acceptable. Yes, it is opensource and one could go ahead and change the source code, but that takes time and is not what OSS is about.

There are way too many examples in the past of sites going belly up, leaving users with an unusable piece of hardware.

Thank you.
marie.o

A note: I tried adding my account. Seems it did add the account, but I received the confirm account email a couple of minutes later. Clicking the URL told me my link is bad :frowning: - That’s a confirmation of my reasoning against using an external site.

Try logging in again and pressing the “re-send email” button.

It was done 5 days ago. You’ll find the instructions in the link on the Makerverse login page.

I understand that this can be a frustrating situation, and I’m working hard to make sure this Beta works well for everybody. But I’m a single person trying to appease a lot of different cases, and your tone is not conducive to a healthy conversation.

Zane,

the last thing I want to do is being unhelpful (or ungrateful). If I did come around like that, rest assure I am not. And no, I will not use the fact that English is not my mother tongue as an excuse, but will simply state, that we Germans are known for being to the point. More often than not, too blunt.

You state I should try logging in again and pressing re-send email. I can’t login. If I try, it tells me, my Username or Password not found (no matter if I try the username or email address). If I try to re-create an account with the same account name, it says: Account exist.

Would you mind detailing, where exactly the instructions can be found? I can’t find them when I click for the explanation on why it was done, nor anywhere else.

Ah, I suspected a cultural barrier here, which is why I re-wrote my post as well :slight_smile: I’ve traveled enough to know how that goes.

You can use the “forgot your password?” link at the bottom of the OWS login screen.

btw, it should be username (not email) that you use to login. However, the “forgot your password?” link lets you reset your password by providing your email (not username).

You’ve inspired me to make a few changes:

  • Allow login with username or email
  • Specify if it was the username/email or the password which was wrong (instead of just saying “one of these two was wrong”).

The very last line of the “explanation why it was done” says:

If you still want to enable guest mode, despite the potential hazards, see the “advanced” features.

In case it’s not clear, my intention here was to make sure that users actually read the security page before disabling login.

Here is a direct link to the Advanced Features page.

Thank you for the very quick feedback.

I seem to have fallen into the category “Another woman that doesn’t read all the way through…” - Thank you for providing me with the direct link. Very much appreciated.

I never receive a Password Recovery eMail. Maybe it has to do with the fact that I decline the receiving of news?

To me, to use the username was obvious. I just wanted to make sure I tried both, just to be on the safe side. I’ll keep you posted as to my progress with getting things going.

And thank you for your time and energy bringing the project further.

Heh, I’m as guilty as anybody on that one.

Hmm, shouldn’t have an effect. I think that some email domains have problems. I’ve mentioned elsewhere that my @claes.biz email address can have problems (not just with OpenWorkShop; it seems to miss other emails from other login systems as well). Whereas my @gmail.com works perfectly, receiving all emails withins seconds for any site I use.

I think there are some settings I can tweak on the email-sending side that might help with this. FWIW, I’m using SendGrid to send the emails. I’m going to try tweaking some settings that may help ensure everyone receives the emails.

But I would also recommend checking your spam folder and/or any filters on your server. The @openwork.shop domain is still relatively new, and it can take some time to build up the reputation…

:slight_smile: Thanks for bearing with me. I definitely want to get to the bottom of the email issue. If you’re running in to it, I’m sure others are as well.

If you need me to check anything on the email side, let me know. And no, Junk and stuff are empty, and the email server is very welcoming to mail messages. The Confirm message did arrive after all. It just took longer than expected, which was the reason why I clicked on Forgot password.

With your change to the configuration file I was able to connect. Thank you.

However, trying to add the Maslow Due to the system shows it is currently, as you have written in github, still filled with a Grbl firmware. Running arduino ide 1.8.13 I tried to compile from https://github.com/makermadecnc/MaslowDue.git - however, it complains about a missing include: Arduino: 1.8.13 (Linux), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

In file included from ~/src/maslow/MaslowDue/MaslowDue/MaslowDue.ino:34:0:
grbl.h:70:10: fatal error: cstdint: No such file or directory
#include
^~~~~~~~
compilation terminated.
exit status 1
cstdint: No such file or directory

It was cstdint, I changed to stdint - and copied the new error. Sorry. Fixed it.

In order to use the Arduino IDE, you must first install the appropriate boards in the IDE. This is step #5 in the github README link you included, where it suggests reading this page.

edit assuming you’ve installed the board, perhaps you’ve not chosen it as the active board.

Thank you for being my white knight in shining reading abilities :smiley: - I’ll check the page and continue my quest.

2 Likes

makerverse runs, talks to the Maslow Due, and is able to calibrate it. Now I am awaiting delivery of a working holder for my Makita and shall progress further. The only thing that worked in WebControl that I currently can not get to work is the Asus EEE build-in webcam. But step-by-step, eventually everything will work.

Zane, thank you for taking your time, and helping me across the blocks I encounter. Should you have a need for help testing stuff, or else, let me know.

marie.o

1 Like