Maskow 4 arrived, Built, No Wifi connection?

HI I received my Maslow 4 and assembled it, some issues but it is together, powered it up green lights on allmotors, green yellow at all 4 ports at the controller on top of the router. I go to my wifi settings on my Apple Mackbook Air and cannot see any “maslo” in the network? Went to my Spectrum internet router site using, I access it using my password cannot see or link to the maslow? any help, I thought it was asimple plug and play? yes? Am I wrong, becuase I am not atech or engineer guru here, Please help Thanks

On a Mac you might need to click on ‘other networks’ in the wifi drop down to see Maslow

Sorry nothing there nor in bluetooth

Reply same goes if I try to hook up with a Windows machine no WIFI or Bletooth “Maslo”

It should be called “Maslow” but I don’t think that is likely to be the issue.

Do you see a blinking blue light on the board?

sorry Bar mispelled no there is no “Maslow” and no blinking blue light on board just solid greens

1 Like

:grimacing: It sounds like someone might have forgotten to install the firmware on the board. There’s no use pointing fingers and trying to figure out who it was…Just kidding, that is 100% without a doubt my fault.

If you have a windows computer and a USB cable you can install it like this:

If that doesn’t sound fun, or isn’t working smoothly DM me your address and I will get one with everything set up in the mail ASAP.

1 Like

Ill try it? but do you have afull install for Mac OS? the one you linked me to is a Win64?

1 Like

Unfortunately the installer only works on PC :confused:

I have a Mac too and I bought a cheap PC just to program all the boards. If you don’t have a PC, don’t worry I can program a new board and send it to you. Totally my fault.

SO my understanding is the Maslow 4 can only run from a Windows Lap? Not. Mac? or just to do the Upload you need a Windows? yes? My son has his let me try, by the way Bar this is Craig I. From Turlock CA :slight_smile:

So Bar Thank you that worked off my boys Windows…However I must apologize to you…IT was not your fault here and EVERYONE who reads this ans not “TECH” savy like me?? …heed my WARNING!!!

In all the forums I read on startup? I ran across what I believed an earlier response which said to download Arduino IO and I did upon opening this it asked to update firmware, …in ignorance on my part I felt it meant update the Maslow, so I believe it erased the firmware Bar installed. That is why I could not get it to see the iWIFI!! …SO lesson be learned ask someone on this forum Dlang? or Bar what or how to open and start your Maslow4…again Humble apologies to you Bar and LETS get building!! THanks so much for the support, Craig of Turlock CA


the automated firmware USB installer is windows.

if you know what you are doing, you can install it via platformio on mac or
linux as well.

Once the firmware is running, you can run the machine (including updating the
firmware) from anything with a browser.

David Lang


Well i am off to locate a cheap pc haha

I can’t seem to get the WiFi connected either. I have all green lights at the Ethernet ports and one on the board but also a blinking red light. No blue light. Am I missing the firmware too?

1 Like

No, the blinking red light should mean that the firmware is running.

This is going to sound silly, but let’s try unplugging it and plugging it back in and see if the red light goes off and the blue light turns on?

Still have red light and no blue

1 Like

I was able to connect to the machine via the maslow network and tried to change the ssid and password to match my home wifi network it would accept the ssid but it looked like it would not accept the password. The amount of dots did not match the length of the password. attempted to change it a couple of times. Not sure if any of this is related. Just trying to get it on my home network to make things easier

OK, I did some tests here and that’s totally normal. I’m seeing the same thing. The blue light won’t come on unless the red light is off…but I still see the “maslow” wifi network when the red light is blinking.

So you are able to connect to the maslow network now, or you were in the past but you can’t now?

I have been able to connect and am still able to connect directly via maslow network. Just cant seem to get it on my home wifi network.

1 Like

Does it really matter if I can’t connect to home WiFi network? I would really like to for ease of use but for now I’ll give it a go to get up and running.

1 Like