Maslow and Universal G-code Sender. Update for Bar

Hi Bar, As promised I am attempting to use USG instead of GC. and I find that I cannot connect to Maslow using USG. USG finds the port but will not connect. i also tried CamBam and got the same issue. It finds the port but won’t connect.

When I connect GC, all connects fine.
Is there anything else I can try to make UGS work?

1 Like

I will give USG a go and see what I can figure out

ok…let me know if I can help

This sounds like a silly issue, but were you able to download UGS OK? Every time I try to download it get’s to 100% but never finishes

Yup…it downloaded fine.
I’ll try again.

1 Like

yup…downloaded the zip and opened it ok

1 Like

Would you be willing to attach the zip here? I’ve tried in two browsers with no luck. If I try to unzip the file it does download it freezes here:


trying but says the file is too big to upload

This is the link I used.

1 Like

I think I figured out what was going on.

I was all geared up to start digging into the code and rewriting sections of code and then I discovered that the issue was that the machine starts out in the paused position as a safety precaution (it will never start moving when it powers up)…the solution is to send the unpause command which is ‘~’ you can put it in one of the macros.


I’m sure other issues will come up because nobody has tried any of this before, so let me know and we’ll get them worked out

1 Like

Hi Bar. I entered the info you suggested. This is what loads when i press connect. When I try to move any axis, I get a popup that says GRBL is still loading and that is as far as I can get. When I use UGS on my other CNC, I know when it connects as I get a line of text saying what version the GRBL is.

1 Like

Try changing the baud rate (under the COM port) to 57600. See my picture above for what I mean

Actually, that kinda worked. I can get Maslow to move now. One thing it does is it keeps repeatedly displaying a {PE:} over and over and never stops.
I also tried to run a file withing USG and because I used Cambam as my post processor it won’t run right…or at all. I don’t think that is the fault of Maslow or USG but I think it is in the way Cambam uses g-code. What software do you use to convert your files to .nc? I tried Easle but it won’t accept .stl or dxf files.

Another update. I used the mountain file you gave me and that seems to work fine with UGS. That PExx thing keeps scrolling but has no effect on the process. USG needs an emergency stop button! Anyway, that baud rate change seemed to work. Now lets see how much stuff I can make :slight_smile:


That’s saying the position error is zero on each axis and that there are 127 characters free in the buffer on the Arduino side. GC normally hides that information (or displays it as the red position on the screen)

Hey Bar. One thing I found today is that if you use UGS and don’t return the sled to the “0” position, and try to use GC again, GC has no idea where the sled is, so I had to calibrate the chain lengths again. I can now do this in my sleep.

Just thought you might want to know.