Maslow constantly being disconnected / unable to update firmware

Good Morning!
I woke up this morning and when booting up ground control I started getting the constant connect and then disconnect errors in ground control. I went to upgrade to firmware 1.10 but i’m getting the following error in the Arduino firmware updater. Is my Mega fried? Anyone else run into this and know how to resolve the issue?

Arduino: 1.8.5 (Windows 7), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Sketch uses 53666 bytes (21%) of program storage space. Maximum is 253952 bytes.
Global variables use 1867 bytes (22%) of dynamic memory, leaving 6325 bytes for local variables. Maximum is 8192 bytes.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Just found this thead ~_~ Arduino Timeout Issue with firmware update

Tried following things suggested in the other thread without any luck. Guess my board might be fried? Any ideas? I’ve tried using both Mac and Windows to update the Firmware but i’m unable to connect.

I’m going to go try and pickup a new board. Would this be compatible with the maslow board?

That one should be compatible!

I wouldn’t give up on that board quite yet tho! It seems like the board is having trouble connecting over USB but it might be worth just prodding it and trying things like unplugging the shield, unplugging the Arduino, restarting the computer and having a fresh go at it

The problem could be a damaged USB cable. Can you try replacing that?

1 Like

Good Morning!
I tried everything and finally replaced the Mega 2560 and i’m no longer having issues with connecting. However, i’m now having issues with calibration again. I switched up my setup to connect from the top of the sprocket to the sled and it’s not centering up in the middle of the plywood like it would before.

New setup:

It’s measuring out different distances when extending the chains:

Left Chain after extending:

Right Chain after extending:

When I extend the chains it lets out the chain length by rotating the sprocket counter-clockwise. (i believe that’s how it should work)

The sled is aligning off center to the right:

Anyone have any ideas? I’ve gone through calibration multiple times with the same results.

Woah! I have not seen the motors extend different distances before. What do you see when you run the Actions -> Test Motors/Encoders? A lose connection could cause that kind of thing

Thanks for the reply Bar! I got a direction 1 - Fail (attached screenshot). Do i just need to double check all my connections?


That’s where I would look!

Especially since the failure is just in one direction it seems like a loose connection to me

1 Like

Fixed! Thanks Bar! Really appreciate the help!


And double checked the secured-ness of your heat sinks while you are there.