Maslow Home Maslow Community Garden Newsletter

Message saying that the machine lost calibration due to usb disconnection

I cut out something for my wife, worked great. Then I started another one, about 1/2 way through it stops and I get a message that the machine lost calibration, probably because the USB was disconnected. It was not disconnected, it was not near any other power cables or anything. So I shut the router off and tell maslow to go to home, it does to some seemingly random place.

I don’t want to start this piece over again and I certainly don’t want to recalibrate. Is there any way to get this think to go to the original home and resume the cut?

Also what could be wrong? Seems like I can make about 2 cuts with this thing before it fails for one reason or another, does anyone have better results?

Blazman

You need to reset the chains to a known position. See this post for how to, in the future, save time if it happens again…

2 Likes

That’s a tough one to answer… I’ve never had a spontaneous disconnect happen to me… but you aren’t the only person that has. Some people have replaced their USB cable and seem to have fixed their problem (but for others it didn’t)

1 Like

As long as you haven’t changed the home position, once you reset the chains, you should be able to recut the piece right on top of where it was. You can also adjust your starting point in the gcode using the buttons on ground control… I think something like z> will move you to the next z axis move. You should always restart from a z axis move.

2 Likes

Fantastic. I put a little white dot of paint on the sprocket and the chain in the home position. So you are saying I can just tell it to go home and then align the white dots and I’m good to go? Thank you so much.

I was thinking about this. I think that this is the first time I told it to cut 30 IPM maybe it is cutting off more than it can chew.

No, you need to follow the procedure to reset the chains lengths. Align the sprockets vertically, put the white marked chain links on the sprockets, and then click to reset chain lengths (follow the wiki). At that point, the red reticle should match the position of the sled. You don’t have to move to ‘home’ at any point (i.e., home is not the same as the position where the sled is when you reset chain lengths… hope you follow me)

but home was not where the chain lengths terminate. I set it at the beginning of the cut so it will cut where I want it to cut.

With a maslow, when calibrating, the machine extends a length of the chain (1651 mm I think is now the default amount). You then attach the sled and the machine knows where the sled is because it knows how long the chains are… it’s here where you mark the chain link (and sprocket if you feel like, but not necessary). This position the sled is in doesn’t have a defined name. The home position is just wherever you set it to be (anywhere in the board)

1 Like

You need to mark the chains at that the extend chains position. If you didn’t, the. You need to set sprockets vertical, define zero, put the first link on the chain and tell maslow when to adjust the chains and it will let out the 1651 mm for you. Then mark the link that’s at the top.

yes that is what I did, I marked the chains after they were measured out.

Is there a way to just measure out the chains?

If you marked the chains after they were measured out, do the following:

Set both sprockets vertical using “Actions->Set Chain Lengths - Automatic” but DO NOT press “Set Zero” … instead press “Quit”. You’ll get a message about quitting calibration early and then be brought back to the Actions menu. Now, re-place the marked links of each chain back to the top teeth of the sprockets. If all is well, the sled will be in the same position as it was had you actually gone through the adjust chain process. Lastly, press “Actions->Advanced->Set Chain Lengths - Manual”. This will send a code to the controller to tell it that the chains have been extended. Voila… chains reset… the easy way.

You can then either restart the cut (which will recut areas that had already been cut, but that’s not going to harm anything… it will just waste some time) or you can advance the gcode using this method:

I have no experience with the above method of restarting, so I won’t be much help going forward with that. In webcontrol, I completely rewrote the code so it behave differently.

1 Like

@madgrizzle this all worked, and I continued the cut, It was off slightly, but nothing a little sand paper didn’t fix. Thanks for your help I appreciate it.

3 Likes