Maslow Home Maslow Community Garden Newsletter

Motor encoder question

Yes, but you don’t have to use a macro in webcontrol. Go to Gcode->Send Custom GCode and enter the command there and press Submit.

So just to confirm.
Encoder to be set to 600
Pitch to be set to 8
Send $18=96 command
This correct? I will test tonight.

Yes (this assumes you have the same setup as @redshift). If you would, just change the encoder steps and pitch first, do a z-axis move and confirm it runs slow. Then, send that manual command and do the same move and confirm it runs fast.

Yes, bought an upgraded Z-axis motor from @Metalmaslow as well. I found 101 pitched worked but I would rather have it set up with correct configurations. I will do some testing tonight and let you know.

Thanks for all your help.

1 Like

I have a question about the z-axis ratio. I would imagine it’s linear since the gear ratio remains the same. Why can’t you just measure the amount of travel you get and set it up as a ratio to the amount of travel you want and use that 8 As the numerator and one of the fractions? What am I missing?

It’s very hard to measure precisely. most of the time it doesn’t matter in
woodworking, but in theory the Z axis can be accurate to far less than a
thousanth of an inch (assuming suitable quality threaded rod)

David Lang


FWIW, I put painters tape on the upright underneath the z-axis carrier, used a fine point pencil and a micrometer. I know it is not ideal but it worked out for me.

Not missing anything. Im and engineer and like to solve problems, hence the reason trying to figure this one out. I also intend to add the zaxis pitch to the quick configure routine in webcontrol, so I wanted to solve this problem.

I opened up our Z axis motor to verify the gear ratio and if my calculations are correct it is 50:1 which is one of the ratios on etonms web site so hopefully more than a coincidence. but I’m not a gear expert so if anyone can please double check my work:

the encoder is 3 pulses per revolution so:
3ppr x 50 = 150
150 x 4 = 600 for encoder count settings
our C beam Z axis either has a pitch of 2mm or 8mm depending on what kit you got. 2mm threads look almost horizontal, while 8mm threads have a noticible tilt to them.

As @madgrizzle mentions above the firmware is coded for the original 12.6rpm of the orginal motor. so times both by 7 so:
4200 encoder and 14 pitch (assuming 2mm pitch, if 8mm then it would be 56pitch)
if you want it even faster then times by 8:
4800 encoder and 16 pitch or
Times by 9 = 5400 encoder and 18 pitch

The encoder count settings and pitch need to be entered here in the hidden advanced settings menu:

1 Like


Another novice user of the latest Metalmaslow z-axis here. Forgive me, but I’m still a bit confused on the correct settings to input into WC to get it to travel correctly. My current understanding is that the thread pitch and the z-axis encoder steps per revolution need to be changed from the default. Anything else? Your websites says to change the thread pitch to ±24, but the numbers above say ±14, 56, or 16 depending on the encoder steps. Can you clarify? The z-axis I have is an 8mm threaded rod, 60 and 20 tooth gears with the fast motor.


your screw pitch is 8mm and the encoder is 600
if you want it to go faster multiply both numbers above. for example 2.5x would yield
20 and 1500

Thanks for the quick reply. I’ve inputted the numbers you recommended, but I’m still getting roughly 3mm
of travel when I try to move the axis by 1mm in webcontrol. Any recommendations on how to adjust the settings to dial in the accuracy?

Quick update, did a little more digging in the forum which led me to the Meticulous Z-axis thread where I found @MeticulousMaynard’s z-axis calibration technique. I initially tried the calibration on the numbers provided by @Metalmaslow, but the z-axis motor would only oscillate back and forth before hardly moving (maybe someone smarter than me can explain what’s going on?). I then set the encoder steps back to the default and tried @MeticulousMaynard’s numbers from the calibration. This seemed to do the trick and the axis moved much more precisely. Not too sure why, but it allowed me to cut my first test piece (late) this evening. Looking forward to learning more about this awesome machine.


1 Like

I input the settings for the 100rpm z motor that @Metalmaslow gave me. I’m having the same issue as Dusty with the motor simply oscillating and clicking. The Board then gets very hot.

I replaced the Arduino Due with a brand new Arduino Due and updated the firmware. Now I’m trying to go through a fresh calibration. When I hit down Z, the X and Y start lowering the sled without stopping. I reset everything and started over with the same issue. Did the firmware mess something up? All the connections seem solid.

BTW, I’m using the original z axis motor again as a just in case measure and this is still happening.

No matter if I hit up or down Z with any measurment, both the X and Y motors lower the sled until I hit reset.

And the original Z motor is oscillating back and forth. The reset of the calibration did not reset the fields for the Z axis in settings.

So I deleted the Machine instance and started an entire new machine which reset all the settings. Lets see if this works.

nope. x and y motors are moving and z is oscillating. Actually anything I hit causes the left and right motors to lower and the Z to oscillate. I cant even calibrate. I’ll reflash the arduino and the raspberry pi that is controlling it…

Did you reset your memory?

No sense wiping the rpi. The issue is in the Arduino.

I’ve re-flashed the Arduino. I’ve re-flashed the Raspberry Pi. I’ve reconnected everything and double checked the connections. Completely new “machine” on makerverse. Still, the z oscillates and the left and right motors lower the sled with any jogging of the machine.

@Orob when I re-flashed the arduino, wouldn’t that reset the memory automatically?