Motors Unresponsive - MacBook Pro & new kit

Hello all,

About a week ago I received my kit and built a slightly modified basic frame. For days, I have not succeeded in getting the encoder/motor test to pass. I have effectively uploaded the latest Maslow firmware to the Arduino, selected the appropriate port in Groundcontrol, plugged the power into the shield (not the Arduino), checked and re-checked the hardware pin connections, verified the appropriate LEDs are on, checked and re-checked the cable connections to the encoders … I am finally at a dead end.

To start, I am rather technically proficient. I am running Groundcontrol on a 2018 MacBook Pro and connecting to the Arduino through an Apple USB-C to the Arduino USB Cable provided with the kit. I have attached an image displaying the results of the encoder test as well. Any help is much appreciated. I am super excited to be a part of the community and to explore the boundaries of the MaslowCNC. chain%20position

1 Like

Welcome @bessemer!
This may sound silly, but happened to all of us some point.
Is the power supply plugged into the motor shield on top? (and not in the arduino below)

Sure is. I have re-checked that many times hoping it was the issue! The green LED is on next to where it is plugged in as well. Thanks for checking.

When you are testing the motors, I assume you have not yet put the chains on?

It seems unlikely that all the motor drivers would be defective, but since all the motors fail, and the arduino is clearly connected, one has to wonder.

Could you send pictures once you have posted a bunch more (and maybe read and liked some posts)?
I’d like to see a close up of the motor board, with everything plugged in.

The USB-C to arduino shouldn’t be a problem, either, especially since the board is connecting.

I was hoping for a shortcut :-/
You also unplugged and restarted everything also.
The arduino is connecting and reporting the shield. Strange.

The one thing that just popped into my head is a problem with the power supply. Can you check the output with a multi meter?

1 Like

I do have the chains on … Should they not be?

Hello Keith. Here are some photos of my setup. Also, I have read lots and lots of posts in the forum.

Also, tried testing without the chains. Makes no difference. I never tried operating the motors with the chains locked up. Nor has the test ever passed.

Hi, the same happened to me and after 5 hours I realized the power supply was the problem, make sure the power supply converter is working properly, the rectangular box must have the small blue light on. When I was putting my set up together I assumed that because the arduino was lit, it was receiving power but I realized that it was the power from the USB port and not the actual 12v 5 amps power from the power supply. What I end up doing was testing the power supply cable from one of my computer monitors and it worked. I hope this helps!

Cool, I was just mentioning that as it is needed to post images.

As for the images, I can’t seem to open a “.heic” file. What is that file type?

Ah good that you figured it out. My last thought was that was the problem for @bessemer too.

I actually don’t think it matters, but figured I’d ask on the off chance that the chains were preventing the motors from moving, but you’ve take care of that contingency.

I think that if you can check to make sure that the power supply is working, that is my best hypothesis for you right now.

Oh sorry. Those image files are straight from my iPhone. I’ll convert and re upload them.

GIMP can open them :slight_smile:

1 Like

See pics…99% sure is the power supply your pic with one LED Vs my pic two LEDs.

1 Like

Yes! That was the issue. Actually, it turns out the outlet into which it was plugged is ineffective. I was misled by the power from the USB and the fact that the test recognized the Arduino and shield. The directions could definitely benefit from this information. I will investigate the best way to make recommendations for improving the setup directions.

Thank you all for the help. I look forward to further collaboration.


1 Like

I am glad it worked! I just cut the final sled, you have to keep an eye on the chains during your tests, and adjust accordingly specially the rope, my chains were skipping because the slack end of the chain wasn’t lining up with the motor sprocket, the solution if you can 3D print is: Now all seems working OK.

Oh man. That is a wonderful improvement. I don’t have a 3D printer but it shouldn’t be hard to find one.