MP3 port fails in Direction 1 only - next step?

Hello - I’m finally getting my maslow kit running, and excited to get going. The motors moved, but I have a failure with the MP3 port in Direction 1. I’ve tested MP1 on the board, both motors, and both cords by swapping connections. Both motors move in direction 1 & 2. Each cord can move each motor in Direction 1 & 2 when driven by port MP1. That leaves the unknown MP3 port on the board that consistently drives Direction 1, but not Direction 2.

I’m running Windows 10 and Ground Control 1.10. Apologies if I’ve missed advice. This sounds like it may need a board replacement.

Can anyone recommend any other options or diagnostic steps?

Thanks in advance!


1 Like

This might sound simple but have you closed ground control and re-launched it? I one time had mysterious anomalies and just tried that. It worked. :dart:


Looks like you did a in depth investigation already, so the board seems to be the clue.
It won’t harm to wipe the eeprom, upload Firmware 1.18 and try again with GroundControl 1.18.
If you see the same results with ‘test motor/encoders’ the board has fault.


I would try updating to 1.20, it’s possible that 1.10 isn’t detecting the PCB version correctly. If that doesn’t fix the issue I think you are right that:

Send me a PM with your address and I’ll get one shipped to you right away.


Thank you for the replies. I’ll upgrade software and update progress tonight.

1 Like

The Arduino Mega pins that control MP3 are D10, D11 and D12. I’m pretty sure that on your board, in Direction 2, D12 is the active one.

I’ve have an Arduino Mega with a damaged output pin which wouldn’t run one of the motors in one direction (my error, shouldn’t have plugged the Maslow board into it with power on). If you wanted to be extra thorough, and had the parts or a voltmeter handy, you could modify the Arduino blink sketch to test pins D11 and D12 by replacing LED_BUILTIN with D11 or D12 to turn the pin on and off at a 1 second rate (Maslow board not installed during this…).

That’s pretty much above and beyond though, and not everyone has the time, interest or materials to chase things like this. It’s very possible that the issue could be on the Maslow board and that having @bar send a replacement will fix it. Pretty stellar support, that! :100:


I updated the Arduino firmware to the latest and Ground Control from version 1.10 to version 1.20.
I clicked Test Motors – both Left and Right passed in both direction 1 & direction 2
Interestingly, I can’t move the sled with the directional buttons. An error message appears to let me know that the chain length has not been set (which is correct) and the motors stop moving. After this, motors may or may not work correctly in both directions in the Test Motors routine. Restarting Ground Control brings it back online.

I don’t have time to set the chain length tonight, but the software and firmware update was definitely part of the solution.

Regarding the error message, is it expected that the sled cannot be moved until the chain length is set and calibrated? It is a little difficult for me to adjust the sled by myself manually, so I need to call up a friend to help.


Great news!

It is; the sled needs to be disconnected until after the chains have been calibrated for length, which comes after several other steps of the calibration sequence. Look through the calibration sequence, you may want to schedule some time for your shop assistant to participate.