Maslow Home Maslow Community Garden Newsletter

New Computer. No Ground Control


#1

I have been trying to set up my new computer and am unable to install ground control.
Error Code 0x80010135: Path too long
This is when I’m trying to extract and it says that it’s copying the files.


#2

Error 0x80010135 : Path too long is reported. Usually this error is caused when you use Windows Explorer or WinZip to extract files and it encounters a file path that exceeds the maximum character limit. To resolve this problem, you may use a decompression utility such as 7-Zip, that can handle long file paths .Apr 4, 2018

cov-analysis-win64-2018.01 Install Path Too Long for Windows
https://community.synopsys.com/s/article/cov-analysis-win64-2018-01-Install-Path-Too-Long-for-Windows

i don’t really see to long paths in GC. Perhaps just a corrupt zip file. I would try to download again an see if it makes a difference.


#3

Where in your file structure are you extracting the files? It is is buried deep in a bunch of file folders, or in a folder with a long name, you might be able to get around the issue by extracting the files into a folder on the desktop then moving it deeper into the file structure where you want it.


#4

I tried downloading 7-Zip per @Gero 's suggestion and got this error again:


Is there some way I am supposed to activate 7-Zip or once it is installed is it operable?
@Keith - I don’t know if there is much depth to the files. I just got this computer from a refurb company that seems reputable so I can’t assume it’s as new but I would hope that it would be as much as they make it, reformatted and all.


#5

Where did you save the zipped file? I assume you are in Windows?? (judging from the screen grab), if so, if you are in windows 8 or 10 you should be able to right click on the file and choose “extract” or something similar, and not have to use win-zip.

Also, did you try skipping that one file? It is a picture of the chain running through the sled mounts.
If you continue to get path too long errors after skipping that file, then it is systemic and you may want to try:

moving it to your desktop before extracting it
or
deleting and downloading the zipped file again.

I don’t think this would be an issue. My main thinking is that if you have a path like C:/MY_MAIN_HARDRIVE/USER/YOUR_REALLY_LONG NAME_FOR_SOME_REASON/FILES/MYFILES/DOWNLOADS/Maslow.zip
then it might be causing that error. Moving the file to the desktop might reduce that somewhat. Or your could move it under the root directory of C:, though you shouldn’t need to go that far.


#6

Yes, Windows 10.
This error message came up during the extraction / copying process after I selected extraction.
I tried skipping to no avail.
I will try moving it to the desktop but I have already tried deleting it in re-downloading it several times.
Thanks for the desktop idea I’ll try to do that let you know. I appreciate all of this direction, everybody! :smiley:
Edit :
I copied the downloaded zip file to the desktop. I went to open that folder that it created and it was empty. I saw on my toolbar a file and opened it. It had the launch Ground Control folder in it. I clicked on it it began to lunch. I’m reminded I made it this far before and this is what happens:


It encourages me to upgrade my graphics drivers and / or graphics hardware.


#7

open powershell as an administrator, and run this:
[Environment]::SetEnvironmentVariable(“KIVY_GL_BACKEND”, “angle_sdl2”, “User”)

Otherwise, if for some reason you wanted to do it manually instead of using powershell, do this:

  1. right click on This PC then open Properties .
  2. go to Advanced system settings .
  3. click on Environment Variables .
  4. click on New in User variables for — .
  5. put KIVY_GL_BACKEND in Variable name .
  6. put angle_sdl2 in Variable value .

#8

I did all of this manually because it wouldn’t let me type in powershell. I didn’t know how to do it as an administrator anyway per se. The launch failed again and at the end very momentarily it said “unable to open window abort”. ¿???¿


#9

hmm. this usually means pygame isn’t installed, but groundcontrol should include that already.
Are you sure that you extracted the zip and aren’t trying to run it from within the zip?

If you’re sure it’s not still zipped, I’ve got 1 more idea that might fix the problem.

navigate to C:\users\%USERNAME%\.kivy\
and open config.ini

find the line
multisamples = 2
and change it to
multisamples = 0

Then save it and reboot your computer.


#10

I will extract it from where it sits in the downloads but this time I copied it to the desktop due to earlier advice from @Keith but that may be too many variables. I will (once I get back to the shop) remove a variable :wink:. I’ll try anything. I just don’t know why things don’t seem to “go through” for me the first time. I went through the same thing when setting my last computer up. I had enough issues with that computer that I attributed most of the problems to it. Maybe it’s me.:nerd_face:
Thanks!


#11

I tried extracting normally without copying file to desktop. I am reminded by circumstance that this doesn’t work in the first place or I would have Ground Control on my computer. I feel like I’m in a vicious cycle of “how to keep an idiot busy” game. But only because I’m the one who can’t remember what works and what doesn’t work. I thought I was on track because I had Arduino and downloaded the firmware. But now this and the firmware is missing and because of this new fangled App crap I can’t find Arduino unless I talk to a robot named Cortana. I may hate Windows 10. I thought I was replacing my computer because it wouldn’t work for me but I think the computers are replacing me because I don’t work for them. :rofl:
Seriously though, I’m frustrated and now to hear that MakerCam may go away. MakerCam was a victory for me. I actually got it. I thought I could do this. I’ve been doing this. Why can’t I do this?:no_mouth:


#12

If you think the issue is not the hardware but between the keyboard and the chair :wink: , consider a video call with screen-sharing or to let someone you’ve never seen before take over the PC with teamviewer or similar. That requires trust :slight_smile:
In any case a step by step approach and reporting back of each step is required and not the ‘all at once’ and mixed information, to succeed.
Firmware and upload to arduino first, then GC.

Regards, Gero

Edit: Made this for a user in need and it’s too detailed. Guess there is nothing new for you, but worth a try.


#13

Thanks so much for your help. I am grateful.


#14

Ok Friends, Jasra/Bahrain and Ohio/USA have bridged the time gap of 8 hours and we tried!
First we tired https://appear.in/maslow , for both of us it would have been better if support worked without installing something. It did not work, so we installed teamviewer and I connected.
This is what I’ve done:

  • I created a folder C:/user/{username}/Maslow
  • A link to the folder was placed in ‘Quick Access’
  • Went to git and downloaded FW.zip 1.25 from release and GC-win-portable 1.25 (1.26 portable missing)
  • Both files where extracted to their own folders still in C:/user/{username}/Maslow
  • Arduino IDE was started , port connection confirmed by asking the serial number of the board
  • Firmware was uploaded, no errors, confirmed by changing serial monitor to 57600 and seeing the firmware reporting.
  • GC was attempted to launch and a terminal window opened and closed, to fast to read the error. A quick look at the .bat file confirmed that it does nothing else than call the .exe, .exe was started from within a terminal and now the error could be copied. (at the end of the post)

was confirmed to be there

  • .kivy

was also confirmed.

Perhaps the penguin chip-monk is not the best guy to mess with reinstalling python 2.7 and kivy on a win10 system. The pygame mention in a post above deserves a look from the little I found on the net.

Please join in with any idea you have :pray:

Error:

INFO ] [Logger ] Record log in C:\Users\{username}.kivy\logs\kivy_19-02-25_2.txt
[INFO ] [Kivy ] v1.10.0
[INFO ] [Python ] v2.7.14 (v2.7.14:84471935ed, Sep 16 2017, 20:19:30) [MSC v.1500 32 bit (Intel)]
[INFO ] [Factory ] 194 symbols loaded
[INFO ] [Image ] Providers: img_tex, img_dds, img_sdl2, img_pil, img_gif (img_ffpyplayer ignored)
[INFO ] [OSC ] using for socket
[INFO ] [Window ] Provider: sdl2
[INFO ] [Window ] Activate GLES2/ANGLE context
[CRITICAL] [Window ] Unable to find any valuable Window provider.
sdl2 - RuntimeError: Could not initialize OpenGL / GLES library
File “C:\Python27\lib\site-packages\kivy\core_init_.py”, line 67, in core_select_lib
File “C:\Python27\lib\site-packages\kivy\core\window\window_sdl2.py”, line 140, in init
File “C:\Python27\lib\site-packages\kivy\core\window_init_.py”, line 899, in init
File “C:\Python27\lib\site-packages\kivy\core\window\window_sdl2.py”, line 269, in create_window
File “kivy\core\window_window_sdl2.pyx”, line 142, in kivy.core.window._window_sdl2._WindowSDL2Storage.setup_window (kivy\core/window_window_sdl2.c:2752)
File “kivy\core\window_window_sdl2.pyx”, line 57, in kivy.core.window._window_sdl2._WindowSDL2Storage.die (kivy\core/window_window_sdl2.c:1868)
[INFO ] [Text ] Provider: sdl2
[CRITICAL] [App ] Unable to get a Window, abort.

Is this -->(kivy\core/window_window_sdl2.c:1868)<-- a path???
Is that normal to have \ and / on win10 :man_shrugging:


#15

Just ‘Bumping’ for no reason, other then to share the completely off-topic knowledge on how to share a snippet of ~9 sec of a YT video (numbers in seconds):
https://www.youtube.com/embed/BMkbiAULxZM?start=61&end=68
in an effort not to bother too long with the music.


#16

Has anyone tried running Ground Control from the Window Linux subsystem?

I played around with it in Beta form and it looked encouraging. You can now install several flavors (Ubuntu, Debian, ,suse, kali) of Linux from the Windows App store.


#17

That’s a great idea maybe I will try it.:penguin:!


#18

I’d hate to lead you into a deadend. If you are having issues with Kivy using WSL may not be any easier. Also, you will need to get serial access working, which should be possible. I was able to run X11 gui apps with by running an X server in Windows with Mobaxterm. This doesn’t necessarily mean that kivy will play nice.

It maybe worth a shot to try @madgrizzle Webcontrol beta. I was able to get it to run on Windows laptop via git desktop running bash using virtualenv.

git clone https://github.com/madgrizzle/WebControl.git
py -m pip install --user virtualenv
py -m pip install --upgrade --user pip
py -m virtualenv env
source env/Scripts/activate
where python
cd WebControl/
pip install -r requirements.txt
python main.py
Then pointed my browser to http://localhost:5000/ and the WebControl interface came up with no problem

I verified the arduino was on COM3 with device manager. But was unable to select the serial port in Maslow settings, even though the COM ports are discovered and listed in Maslow settings. So serial port settings may need some troubleshooting…


#20

hmmm… i’m thinking it’s device drivers. can you screenshot and post your device manager screen?

(search “device manager”)

specifically any “display adapters” or “other devices”


#21

@Jatt I could talk to the arduino at any point, so driver was working.

I re-installed all the dependencies directly in Python also , and it still no luck
Finally, after I hardcoded the COM port into my groundcontrol.ini comport = COM3 and did a groundcontrol import directly from WebControl/Actions menu, I was able to connect and move the motors on the Maslow!

[Edit] The only way I was able to install the requirements was through Visual Studio, along with C++ libraries and build files. Which is a large download. THere may be a better way to build this,