No Chain Movement during Calibration

Capture

Tested Motors/Encoders They worked
Then tried to do Chain Calibration
Nothing Moves
Python shows the command being sent(in Pic)
V.83 being used

Have you been through the Actions/Calibrate Machine Dimensions process yet?

Tried the adjusting the sprocket left and right no movement

even switched out boards no difference

are you sure you have power plugged in to the motor controller board, not the
arduino?

Yes, because if you have it plugged into the wrong one the encoder test will fail.
Just tried to reverse it just encase encoder test failed,
Put it back the original way, and encoder test passed
sprocket rotation in calibration no movement

Have uploaded a pic

Looking at the python terminal screen, I don’t see any responses from the Mega board. This can happen if GroundControl doesn’t have sole posession of the serial connection. Make sure that the Arduino IDE isn’t running. If it was, quit both it and GC before re-starting GC.

1 Like

How’s it going, have you gotten past this sticking point :slight_smile:?

1 Like

I was just about to join in with no movements of the sprockets. Gave up yesterday. Today I might have discovered why they are moving now. If you get the pop-up that you need to calibrate, there are 2 buttons. I think I used ‘Hold’ yesterday, resulting in no movements. Today I clicked ‘Continue’, every time it popped up until it gave up. Then I tried to move the sprockets and “Bingo!”, they moved. I’ve finished calibrating N0. 347, so not trying right now, until the next “Los of position”. Can anyone confirm or reject that this is the behaviour? FW+CG 0.83, PCB 1.0

2 Likes

Yes finally did.
Wiped allinstalls out and reinstalled and about midnight it started to move. Chain cal done. Zaxis next
Thanks

2 Likes

I wonder if the ‘Hold’ is needed in that dialogue. I’ll go look for it.
FWIW, I seem to get that dialog if I’ve skipped through the auto calibration steps. Maybe I skip too quickly, but I mistrust going into that sequence unless I’m ready to redo the automatic chain length. :confused:

For those of you with Maslow’s up and running, the Wiki really could use a few detailed pages on Calibration Procedures

Please assist.

I’ve opened issue #383 on MaslowCNC/GroundControl on this.
I would suggest that we get rid of the confusing ‘Hold’ button in this dialog, which puts the machine into a state where the controls seem unresponsive.

3 Likes

PR#384 opened in GroundControl to address this by removing the ‘Hold’ button from the dialog.

1 Like