Maslow Home Maslow Community Garden Newsletter

Not Connected Ground Control

Hi all, I wonder if anyone can help!

I received my kit this weekend and got it all built, calibrated and working great. I switched off the power in the shed to close up for the night, returned a day later to turn it back on and found ground control stuck saying ‘Not Connected’.

I’ve tried new usb leads, power cycling the Mac and the boards but no joy. I also loaded the arduino software to see if it was available on port selection but nothing.

I’m running a 2011 Macbook Pro.

Has anyone else experienced anything like this? I would understand if it had never worked but it was working and now isn’t!

I don’t know anything about Macs… are you saying that the arduino doesn’t show up in the Arduino IDE?

Sorry yes, it didn’t show up in the Arduino IDE.

Macs around that vintage (sorry don’t remember what years) were known for USB issues, was a lot of discussion in 3D printer forums around that time

Don’t remember how the fruit OS numbers USB serial ports, but could it be as simple as the port being reassigned. Did you try another device and see if that worked, perhaps the port was blown out by powering up devices in the wrong order. Not supposed to happen, but flaky vintage Mac USB…

Thanks for replying, I’ll go and do some digging to see what I can find. Cheers

HTH, been a few years since I’ve sipped the apple juice but hope it’s a simple problem.

There is a just over $100US W10 fanless mini PC on (iirc) Gearbest hitting the deal sites lately, if you want to take the Oriental megastore risk, and hold your nose for the Gatesien environment. Were I back up north I’d buy one to try as an Echolink node

I have an update. Last night after hours of trying out different drivers, repairs and three different computers, I decided to plug in an Arduino which I brought home from work.

I plugged this in and my original old mac picked it up right away. So I removed the shield from the maslow cnc Arduino and tried to connect it again. Still no joy. So I know my serial ports work, I know the USB cables all work, this tells me the Arduino is faulty.

Maker Made have said they’ll source me another Arduino but I have ordered one from Amazon which should hopefully arrive today.

1 Like

Thanks for the update. It’s helpful to know how things like this resolve so we can keep an eye on which parts are the weak link

Update, the Arduino I ordered from Amazon arrived today. I’ve hooked it up and we’re back up and running!

My only issue now is the sizes of my circles are too big (363mm when they should be 353mm). I have calibrated the machine and it all looks good but I must be missing something!

1 Like

Are they too big, but still round?

Are you using MakerCAM to generate the gcode?

Yes, still round. I have another post which I submitted last night and I’ve just replied to you on that post. I’ll keep you posted over there.

1 Like