Maslow Home Maslow Community Garden Newsletter

Novice CNC, Need Help W/ Setup

Greetings,

Just got done setting up with frame and the electronics. I’ve been trying for two days to calibrate but I’m having a difficult time. Here are the issues that I’m experiencing:

1) Calibration:
I follow the calibration steps, but when I try to run through the test run I observe the attached. The graphic is off center with the actual board. Here is what I’m observing.

Also, when I click on test motors they all fail even though I can move them manually through the calibration process.

When I run the center sled command the left motor keeps running continuously to the point when the sled goes off the board.

2) Z-axis motor not working
I’ve connected the Z-axis motor to the second connection on the motor controller board. The left and the right motors are connected to the 1 and 3 connections. When I run the calibration process for the Z-axis motor, the left motor runs, I’ve tried swapping the connections and the z-axis motor never runs. I’ve disconnected and reconnected the z-motor cable but to no avail. What am I doing wrong? Could it be that I uploaded the wrong firmware and z-axis is non-existent.

1 Like

Welcome to the Forum @konecorp!

Can you say what Firmware and Groundcontrol version you are using?
How did the calibration go, specially the step where it shows all the parameters, like motor distance, motor height over the sheet and so on. Did those number look accurate?
On what OS are you running GroundControl?

Kind regards, Gero

P.S. In GC, if you cklick on --> setting --> Settings, is the Z-Axis turned on?

Thanks for the prompt response, this is great.

I am assuming the version is “1” based on the folder and file name? I uploaded “cnc_ctrl_v1” to the Arduino.

I have not paid close attention to the numbers, I just go through the process for calibrating, will do that next time.

What I do notice is that Ground Control complains about chain length and asks me to define it. I go through the setup and define the length. But then there is also the “Calibrate” option. It seems redundant, perhaps the chain measure should be eliminated and just a “Calibrate” option should be made available.

The z-axis button is turned on.

I figured maybe there is an issue with the Arduino code where the z-axis port isn’t defined… I’m not allowed to upload any other files other than pictures otherwise I would upload the firmware-master-2019.zip file that came with the USB.

1 Like

OK, this looks to me like it is the firmware for a Arduino DUE.
GroundControl will not run with it, as it is written for the Arduino Mega and a different motor shield.
So the first thing we need to figure out is what Arduino are you using.
Do you have a link to the kit that you bought?

Kind regards, Gero

1 Like

I have an Arduino Mega, the OS that I’m using is Windows 10.

This I believe is what I purchased:

https://makermade.com/product/malsow-jump-start-bundle-kit-sled-router-bit/?gclid=Cj0KCQjw7ZL6BRCmARIsAH6XFDKBaq_E-_G8QV4n0pX9J7uSAZtlGWYxN3ThblxIda9792gtKBNd38gaAhe1EALw_wcB

1 Like

Hi, I crossed out my comment above that your screenshot looks like the Due firmware. It looks like the Firmware for the Mega.
When you start GC new, on the right down corner, it will report the PCB, and the versions of GC and the Firmware. Can you post a screenshot of that?
Don’t worry about that mine looks different…

1 Like

I would suggest getting the firmware from here

2 Likes

Thanks, I downloaded v1.8 of the firmware and uploaded and downloaded the latest v1.6 build of GroundControl but I observe the same issues.

What’s interesting is that I’m seeing the attached message that the v1.8 of firmware does not match v1.6 of GroundControl. I was not able to find a more recent version of GroundControl on GitHub.

I went through calibration again, and everything was fine until I got to the Z-axis calibration portion. I enabled z-axis motor and tried to adjust it through the software but only the left motor runs, not the z-axis. I checked and the z-axis motor is connected to port #2 on the board. What’s interesting is that after attempting to run the z-axis motor the right and the left motors do not function property. What’s interesting is that when I attempt to run the z-axis motor through GroundControl’s calibration, the left motor runs. Sometimes it doesn’t even run it just hums.

So after the z-axis calibration failure I simply skip and continue through calibration. The next step is the run through the 1 through 5 test cuts. I manually enter the distances between the cuts and when I click on test cut the machine does not function properly, it continues to pull the sled to cut 1 (top left) and goes over the board.

I then skip out of the calibration and attempt to run the test cut that comes with GroundControl, same issue, the sled is nowhere close to center.

I ran it through anyway to see what would happen and all of the sudden the right motor seemed to no longer to hold and the sled went sliding across the board. Once this happens, the right motor no longer works, only the left motor until I upload the firmware again.

So, here are the issues:

  • GroundControl (v1.6) doesn’t seem to like the upgraded firmware (v1.8) - this may be the problem…

  • Calibration of z-axis throws off the motors

  • Right motor disengages and no longer works after z-axis calibration

I also noted this virus issue when I downloaded and ran GroundControl for Windows. Interestingly.

groundcontrol is no longer updated, but the firmware is still being maintained. Webcontrol is the groundcontrol replacement for now, but a newer program called makerverse will likely replace them both by the end of the year.

If the right motor is no longer holding, there is likely something mechanically damaged inside its gearbox. If it only does this during calibration, you may want to try webcontrol and see if the motor acts the same. Please verify your connections to the motors. Sometimes weird things happen when the cables come loose even just a little.

I’ve installed WebControl on a RaspberryPi and connected it to the CNC board. Everything works fine now except for Z-axis. I’m having the same issue, but instead of the right motor twitching when I try to change the z-axis the left does. It’s frustrating, this thing should work out of the box. Here are the logs, I started recording and initiated the motor test from the settings menu.

Any ideas? Is it a defective board? Thanks for your help.

cnc-logs.txt (1.1 KB)

what version of firmware on the mega are you running? What shield do you have (where did you get it)?

It could be one of the following (in no particular order):

  1. wrong shield selected in firmware
  2. your wire connection could be loose on shield or on motor
  3. your shield isn’t plugged in all the way

Hi,

WebControl tells me that the firmware version is 1.6. I tried upgrading through WebControl but it still shows 1.6 after restarting.

I’ve connected the motors to different sockets on the shield, no matter where I connect the z-axis, WebControl gives me a failed message when it comes to attempting to move the motor for wherever the z-axis motor is connected (connection 1, 2, or 3).

Based on this, it seems that there is something wrong with the motor or there is an issue with the firmware.

How else am I supposed to upgrade the firmware and why isn’t it upgrading through WebControl?

Do you think you could post a picture of the electronics? That would help us be sure that we are recommending the right thing for the board and arduino that you are using

Im new here. I had alot of frustrations getting started. I accidentally erased everything on the thumb drive that came with my kit while updating my windows 10 to 64 bit. I was told that support shifted to web control so thats where i started. It seem as far as i can tell to be far superior. I was getting an error message with my z axis. if you go to setting, maslow settings, there is an option to switch off or on the z axis motor, make sure its on. that solved my issue.

1 Like

This is really neat, thank you Ryan for sending these videos. I especially liked the part about being able to edit the GCode in WebControl, that’s amazing and very powerful.

1 Like

So I purchased my CNC package from makermade.com. I’ve tried contacting them through Amazon, their Website, etc. but no response. It looks like I need a replacement motor because whatever I do, I cannot get that motor to run.

Does anyone have a phone number for them?

Is there no email on their website? Here in the Forum maybe a mention of @MakerMadeCNC can trigger a response.

1 Like