Odd cut when cutting test shape

I am having an issue where the maslow cuts an odd pattern in an area instead of what is shown in makercam and GC. Everything is fully updated to the latest and I have calibrated the maslow multiple times with no luck. I have also tried making the file over and end up getting same result. I thought maybe it was an issue with lines sent in GC being to long so I turned on truncation at 3 and still same issue.I’ve also tried moving the test cut to different areas of the work area with repeated issue. I have cut other patterns out without issue but this has me stumped. Any suggestions or help?

Attached files include screenshot of GC, the NC file, log file, and photo of the messed up cut.

Help.rar (661.9 KB)

My first hunch around a little bump like that is for it to be something mechanical. Is there anything near by that the sled could be bumping into at that point? Do you see the same bump anywhere that the file is cut on the work space?

Any chance you could upload the files in a .zip file…I don’t have 7zip installed

Thanks for the quick response. No there is nothing mechanical for the sled to come into contact with there. And yes it has some sort of messed up cut in that area regardless of where it is cut. It is worth mentioning in GC when this happens it shows two illustrations of the sled while cutting like it’s out of sync then syncs back up.

Here they are in zip format
Help.zip (674.5 KB)

1 Like

I think GC/FW limits the feedrate, but you might try using 30 instead of 60 and see if there is a difference.

1 Like

Thanks will give that a go. Following the guide I seen on using makercam for maslow it didn’t say anything about feed rate so I left it default.

I don’t think it’s a feederate issue, @madgrizzle is right that it will be automatically limited if it is too fast.

Let me try to run the file and see what happens

Edit: I’m not seeing anything in the log file or gcode file which looks off. I’ll run it as soon as I get caught up on the forums and email

1 Like

Thanks Bar. I will hold off on trying to cut again with changed feed rate. Now that I am thinking about it when this happens and the two illustrations in GC seperate (un-sync) the sled almost doubles in speed until the illustrations sync back up.

To me, this looks like the left chain binds or ‘almost-jumps’. Something is tweaking that left chain then releasing it
Is this repeatable? If you run the file again (maybe with the router off) will it jog in the same location? If so, if you move the ‘Home’ two inches to the right does the jog happen in a different spot?

1 Like

My hunch is that this is a bug on my end with the way one particular line of gcode is run.

I would say give another file a quick run and see if its a quirk with that file only. Here’s a file from the “gcode or testing” folder which is known good

causeB.nc (10.6 KB)

It is repeatable yes as a matter of fact each pass does the same exact thing. It happens all over the work surface whether its middle, top left or right or bottom left or right.

1 Like

Will give it a go here in a minute bar.

1 Like

No issues with that pattern. Of course I am limited
On time so I only allowed two passes. This is is bottom left corner of maslow if that is important. Also notice the line with same miscut in same spot to the right of it as I tried that same test pattern again earlier.

1 Like


That Love looks really good!

Let’s operate under the assumption that there is absolutely nothing wrong on your end, and that there is a bug on our end with how that file cuts. Unless you see the issue again

I’ve opened an issue for the file here in issue #426

1 Like

Indeed the infinity love turned out great. Brownie points with the wife right there lol. Thanks bar.

1 Like

When you remade the file, did you redraw it in your CAD program? Or just reprocess the CAM?
I don’t mean that to be obnoxious or to offend you, just trying to see where the issue begins.

And yes, that Infinity Love is awsome. Any chance you would share that file?

Good news, sort of… I’ve peeled the gcode out of the log.txt you sent (here)0000troubleshoot.nc (1.2 KB), and I can see the issue happening. That gcode file is pretty strange, though. The straight lines of the sides of the squares are a series of arcs instead of straight lines. At the spot where the ‘funnies’ happen, somewhere in the area of line 43 or 44 in the file i uploaded, the gcode asks for an arc with a radius of 9563.856 inches (796 feet). Something is suboptimal here.
Consider choosing a different gcode processor to generate the .nc file. What was used?

I am new to the whole maslow thing so no doubt I will mistakes lol. I went from jpeg to svg using convertio then svg to nc using makercam. Perhaps I will go back and start from scratch with it.

1 Like

No offense taken as I am totally new to this. I went from jpeg to svg to nc using convertio then makercam. As for the infinity love it isn’t my design I found the SVG on net someplace. I will look for it later so credit is given to maker.


Did you redo this process when you remade the file?

There’s nothing wrong with your process, but for straight lines and calibration type shapes, or precision cutting, using conversion programs can, and often does, lead to unpredicatable results (as @blurfl indicated) . This is why I was curious if you redid the whole process, since those unpredictable results might be slightly different each time.

For a calibration square you might want to try drawing it directly in MakerCAM so that you can be certain of the shape that is being CAMed.

That might be interesting to look into. Can you put the jpg and the svg files up here?

1 Like