Maslow Home Maslow Community Garden Newsletter

Pauses in Gcode playback

I am trying to cut my first project. I took the folding chair DXF and scaled it down for my 3 year old. I loaded this into Estlcam and set the holes and parts.
I am cutting 3/4" plywood (20mm), 3mm a pass with a 1/8" bit
I exported the code as GRBL from Estlcam

When I loaded it up and pressed play Z raised, the sled moved up to cut the first large hole. It lowered the bit and then sat there spinning. It stopped executing after line 16

Thinking it got stuck on some command it didn’t know I saw line 17 started with G01 and suspected the speed may be at play. I edited all the G01 lines to be G00.

I ran the program again and it executed line 17 - cut across after lower z but stopped at the radius and just sat there spinning.

Clearly I have something in my gcode that Maslow doesn’t like. Any thoughts? Is there a better (23.0 KB)
machine configuration I can use from estlcam? (23.0 KB)

I read up a bit more. G00 is for faster moves outside cutting and G01 is for cutting. The spindle speeds and travel speeds on a Maslow seem set (or at least the router is manual) so I’m going to try to remove most of this code. I’ll just leave a G0 at the top and let the Maslow defaults reign and see if this gets me anywhere. I think it was stalling on the spindle commands which occurred around the line it stopped on. I looked at some GCODE other uploaded for their projects and they seem to be mostly X&Y commands. (19.3 KB)

I don’t have a solution for your pauses, but if specifying a speed caused problems pretty much the entire CNC industry would not work. I don’t have a way to look at your gcode right now, but will try later.

G0 is for rapid, i.e maximum speed non-cutting moves. No attempt to coordinate axes is made, cuts won’t follow the expect path. For example you want to move up 1 and over 10. Instead of being a diagonal line taking a 45 degree (full speed up and over) then the remainder over is totally legit. Weirder things can happen if the axes move at different max speeds. Of course up and over aren’t real axis names, but you get the idea.

3D printer firmware seems to have equivalenced G0 and G1 but that’s not legit, the early 3DP hobbyists had a poor understanding of gcode features

You don’t have any feed rates on your G1 commands, there should be an Fxxxx on at least the first G1 command. Iirc you specify feed rates, depth of cut, etc in estlcam when you define your tool table (list of available bits). Did you do that? Since you’re in metric (G21) mode something around 400 mm per minute or so would be a good starting point with your 1/8" bit. You might want to try and reduce the depth per pass to around 1.5mm, half the bit diameter is a good starting point.

What machine did you specify in estlcam, don’t remember if they explicitly call it a post processor or not. You want to pick grbl. Also never ever let estlcam update the firmware to it’s own unique proprietary version which will not work with a Maslow.

Discourse numbered the lines differently, your line 17 is their line 14. I used a numbered list.

  1. (Project Fold-Chair2)

  2. (Created by Estlcam version 11 build 11.241)

  3. (Machining time about 02:01:35 hours)

  4. (Required tools:)

  5. (End mill 1-8)

  6. G21

  7. G90

  8. G94

  9. M03 S24000

  10. G0

  11. Z5.0000

  12. (No. 1: TopHole)

  13. X-4.1862 Y58.8671

  14. G01

  15. Z0.5000

  16. Z0.0000

  17. Z-3.0000

  18. X-64.3180

  19. G02 X-103.9582 Y98.5073 I-0.0108 J39.6294

  20. Y140.1556

  21. Y146.3306

  22. Y232.7147

  23. X-4.1862

  24. X1.9888

  25. X101.7607

  26. Y146.3306

  27. Y140.1556

  28. Y98.5073

1 Like

I agree that this is the issue

G01 X10 F400 tells the machine to move to the position X10 at speed 400, G01 X10 tells the machine to move to position X10 at the speed it was already set to go, but if it was never set it defaults to 0 so at zero speed the project will take a long time :stuck_out_tongue:

Thanks everyone. I’ll try again. I did export GRBL from Estlcam and set the tool specification but I removed some of the code later. It looks like I went too far as I need at least one feed rate command. I’ll add it to the first G1, e.g. G1 F400

Estlcam did add a spindle speed as well which I am guessing is not needed but may not bother anything either.

1 Like

You can setup the controller to turn on your router automatically when it sees a spindle command, but unless you’ve done that you are right that it’s not needed.

Funny story. When I exported from Estlcam I messed up some math. It sets feeds at mm/s so I exported feeds of 8 and 2. These needed to be 400 and 200. My system wasn’t stuck it was going super slow! All is well now.

1 Like

Proof. I had to stop the project and reload new gcode a few times as I entered a depth for the plywood that I read rather than actually measure it (18.5mm vs 19.1mm). I also had ridiculously small tabs at first that didn’t hold up. At one point the bit came loose and it bogged down necessitating a restart. I’m happy though and ready to try some other projects. Thanks for the assistance!