Maslow Home Maslow Community Garden Newsletter

Problem defining home position

hi folks. just recalibrated after replacing the controller box and z motor and now running into an issue resetting my home position. not sure how, but makerverse has the z home position set at 5mm not 0. tried resetting home from the control settings and am receiving error 20. same for x and y home reset.
feeder> G28.2 Z0
error:20 (Unsupported command)

not sure where to go from here. limping along with workarounds but i miss the old homing process in the prior version of makerverse.

Not sure what G28.2 is Try G28

I’ll try it. This string is what is “auto filled” when i hit the home command in makerverse

Silly question perhaps, but have you tried using the MakerVerse menu option shown below once you’re at the z-axis position you want to define as your machine zero? This would also suggest that “G28.3 Z0” should work - but I haven’t ever tried that myself.

I’ve used the MakerVerse menu option successfully with v1.1.2 for both the x- and z-axes. It did not work for the y-axis (see Can't set machine to zero - #4 by bilzer046 for more)

image

1 Like

i sure have and the zero function works fine. when i try the home function is when i have problems with error 20. for whatever reason makerverse wants home to be at z=5

I just tried “G28.2 Z0” myself and got the same error. Looking at the config values, I’m wondering if it’s supported unless perhaps you also have limit switches installed.

“$22”: {
“name”: “$22”,
“value”: “1”,
“message”: “Homing cycle enable”,
“description”: “Enables homing cycle. Requires limit switches on all axes.”,
“units”: “boolean”
},

Back to your original problem statement. Have you already tried either of the two options highlighted below. Both will drive the z-axis to the calibrated zero position (surface of material) assuming the work position is equal to the machine position… but maybe I’m (again) misinterpreting what you’d like to achieve.

The 5mm you referred to doesn’t appear to be part of the editable config, so I suspect it’s hardcoded. When homing, I think it makes a lot of sense to raise the z-axis above the material before driving the x- and y-axes so I guess 5mm was chosen as the “holy” value.

ZeroZPosition

when you go to home the system will go to the x and y zero point and then offset the bit to the safe height, which is commonly set at 5 mm. Are you seeing all of your cuts 5 mm high?

1 Like