Z Axis not responding through mp2 input

I bought a basic Maslow Maker Made and am working on calibration. I can control my X and Y motors using the mp1 and mp3 inputs on my board, but the Z motor doesn’t respond when plugged into the mp2 input. It acts like the data that should be sent to the mp2 is sent to the mp1 (and inturn the wrong motor). I switched the cable from the mp2 to the mp1 and was able to control the motor by moving the x and y axis buttons. Any ideas?

I’m not familiar enough with Makerverse to help, sorry. Sounds like a settings issue to me.

If it’s a maker made classic try webcontrol to see if you can get it working. Z axis needs to be enabled in the settings.

Thank you. I will try going into the settings to see what I can find. I bought it used (never used) from someone and they started to hook it up but never got it all put together to try anything. They didn’t have any of the instructions so I have just been looking online for everything to hook up.

Mp2 is the z axis motor connection. I’m unclear if you have an M2 system or the basic makermade jumpstart kit with the mega controller. If an M2, I know some of the makermade controllers were bad and some had corrupted firmware. These were problems I worked with different users on when they were first coming out. Many times resetting the eeprom would help and there is a very specific command to do that if using makerverse. Have you reprogrammed the controller and then wiped the eeprom and tried to set it up from there? Can you post a picture of your controller shield (is it in a plastic case?). If in the plastic case, make sure the shield and the board are well seated together and the cables are securely in place. The newer control boards they used have fewer pins and separate easily. There were many weird behaviors that were observed that ended up occurring from electrical disconnects. These boards had to be reseated and the cables reconnected. Swap cables and test if you have that option or if you have the tiny connector z motor like most of us, you might get an ohm meter and test the cable’s connections pin to pin to verify continuity to ensure it isn’t the cable.

what firmware version are you running?

I have the basic makermade. I changed the cables out to see if it was a bad cable. I also ran the cable from the mp2 to a different motor to be sure the board wasn’t bad. Lastly, I ran a cable from mp1 and was able to get the motor moving by using the X or Y controls from Makerverse.

I think Orob is on to something. Could it be that you have the incorrect firmware, like the one for the DUE board?

So what firmware am I looking for? I’m not where I can check to see which one I’m running right now.

Does mp2 work at all? (like when you plug a different motor in)
If not, the issue may be with the motor shield.

When another motor is plugged into that input it does work.

It shows that I am using the Maslow Classic Firmware.

So, I read up on some other topics dealing with firmware and the z axis last night and found one that @Orob had helped someone with. It was a firmware issue. It lead me to a webpage ( Free Downloads ) with another link to download a different firmware. I was just able to download it, move to applications, and allow the permissions. I then reopened up makerverse and everything was good to go. Thanks again for your help.


Thanks for following up to post what worked. Hopefully it can help someone in the future.

Ok, so I thought I was good to go and decided to try my first cut with it yesterday and had some issues getting going. Opened it back up today, and it shows I need a new version of the firmware.
Screen Shot 2022-08-28 at 10.10.24 PM

The highlighted portion of how to install is what I’m struggling with. I opened the tab in the arduino that says MaslowDue.h and I see where it says v2 and I changed it. I go to upload after making sure all those other settings are correct, and it throws an error saying the file doesn’t exist. Any help?

Are you sure you have a due board? The Makermade Classic came with the Arduino 1.2 with a mega 2560. Unless it was upgraded. Can you post a picture of your setup?

If you have the Arduino/mega setup the easiest way to flash the firmware is through webcontrol.

file doesn’t exist is often because you are opening the file without having unzipped the archive first. It only sees the one file rather than all the dependencies that are required.

If you really have a “basic Maslow Maker Made” as you mentioned above, you likely have the mega. If that is the case, you won’t be able to flash it easily with the due firmware. It will send thousands of errors.

It is the classic. No upgrades have been made to it. How do I do that through webcontrol? I am completely lost.

once you have webcontrol operational, you use the actions menu… what version firmware are you using? 1.26?

Webcontrol .94 is located here:

Action tab will allow you to install the firmware, you want to install holey so you can do that calibration.

Use the help menu to guide you through setup.

I’m on Mountain time in the US, if you need help I can talk you through over the phone. I don’t get home until evening time though.