[Public Release Thread] Makerverse is a Universal Controller App for CNC & 3DP (and includes Maslow upgrades)

tl;dr: the Makerverse app seems to be ready for wider use in the Maslow community. Everything you need to use it should be in the docs / quickstart.

The original post got unwieldy, so I am starting this new post, as we are approaching the end of the Beta (and the beginning of the “official” release).

Why might you want to use the latest Makerverse?

  • Support for all computers, from Mac and Windows to Linux – even a pre-built Raspberry Pi image, and the ability to control to your machine from any other computer in the house!
  • Automatic configuration! Just pick from the list of parts and Makerverse will choose the correct baud rate, default Grbl settings, etc.
  • Easier calibration! Based upon lots of user feedback in the mega-thread (above), we’ve developed an easier-to-use calibration system, including a non-destructive approach.
  • For M2 (Arduino Due) users: All-new kinematics! The M2 now supports advanced Maslow kinematics, improving accuracy across the board, via new firmware.
  • Backwards compatibility! Makerverse now supports the original Maslow (JumpStart kits, etc.)
  • Over 100 people have tested it as of this post.

… that said, you might not want to upgrade if you’re in the middle of a sensitive project. As you will discover whilst reading the docs, you may need to re-flash firmware and re-calibrate (if you’re using an M2/Arduino Due). And if you’re comfortable with Web/GroundControl, there may be a slight learning curve with Makerverse.

As of this post, the current version is 1.1.2. To be clear: this version is not technically flagged as a “pre-release.” It is considered a “stable release.” However, you’ll want to turn on prereleases to keep up with the Beta progress.

If for any reason the docs are not clear to you, you get stuck, or you just want to share feedback – please do so here, on this thread. We will keep this thread alive until the “full, public” release.


Zane, is there a particular reason why you just didn’t join and work with CNCjs(https://github.com/cncjs/cncjs) instead of what looks like a fork? Competition is good but sometimes combining development efforts goes further than splitting efforts.

We tried, several times. That project has been abandoned. Note there have been no PRs and no releases since March, 2020. The maintainers are not responding to any requests.

If you refer to Cheton’s profile, he has flagged himself as “slow to respond.” I did eventually connect with him on LinkedIn, and we did eventually get his blessing to treat Makerverse as a succcessor to CNCjs.

edit I actually started down this journey by submitting a PR to CNCjs at the beginning of the year. It’s still sitting open with no comments or anything.

1 Like

That’s great to hear Zane. I’ve pinged Mitch Bradley on this because I use CNCjs and after I hear from him it’s likely I will move to Makerverse. I’ve got a few dozen owners of 3DP, lasers and CNCs who constantly bitch about the proprietary software they are “forced” to use for their machines and I’m trying to get them to consider alternatives. I have found CNCjs and Kiri:Moto great to work with so I expect Makerverse to fit in nicely.

That’s fantastic. This is exactly why I got obsessed (I think it’s fair to say at this point) with building this app. I’m now using it to drive a 3DP w/ MMU, a laser cutter, and two Maslows. I have so, so, so many ideas for ways to make Makerverse even better…

… but I’d love to hear others’ priorities, too :wink:


@zaneclaes I am a bit surprised there’s no attribution to CNCjs.

One of the primary developers of CNCjs and who posts regularly on the CNCjs facebook page sounds pretty shocked at not only having never heard of the fork but that even with Cheton’s blessing there’s no attribution to the the CNCjs project.

I would think that since there has been some development, March 2020 is still something, being inviting to all of the CNCjs developers would have been a high priority goal of Makerverse. I’m a bit surprised any of the CNCjs developers are surprised at what happened.

Possibly a better route would have been for you and your co-developers to have joined CNCjs, expressed your intentions and moved forward from there so that not only would all the CNCjs developers know what’s going on but also could have decided to join the fork along with posting notices on the CNCjs.org website and in the git repo.

I love your enthusiasm but lots of people have put years of effort into CNCjs and it appears they’ve all been alienated when that didn’t need to happen. There are also lots of existing users of CNCjs you could have leveraged to Makerverse if things were handled better. $0.02

I’m truly beyond saddened and hurt that you would assume that about me, especially given how hard I’ve tried to “do this right.” There are entire pages of the homepage on Makerverse.com
devoted to it… just click the About section. There is literally 10x more content in the about section about CNCjs than us… including all the pictures of the various contributors.

And in the About section of the app itself, it says:

Forked from the CNCjs project.

I even kept their donate button (and did not add one of my own).

1 Like

I’m not sure what you mean. As I said, we tried this. I submitted PRs. I sent emails. I found the owner on social media. They’re completely stalled. They’re not accepting PRs. I offered to maintain it, to review PRs, whatever he wanted and didn’t get a single reply over 6 months. Everything you said is something I’ve tried to do.

I literally spent months trying to make this happen… what else should I have done? Forking was not at all my desired outcome.

Edit: afaik, Cheton is the only maintainer. So in his absence, nothing can happen on the project.

Here is my last email to him:

I didn’t find anything on the About page but there’s another page, the history link on the About page where I did see you mentioned the CNCjs project. It’s there just a bit deeper down than I was expecting and apparently the one developer I’d contacted.

It does sound like you had gone to lots of effort to start a conversation with the CNCjs developers but you do see how strange it seems when I can just pop over to the one and only CNCjs developer I know and get a response in literally 5 minutes. I met him on both the facebook CNCjs users group page and on another forum. But I have no doubt you’d tried and love the effort you put in(pic of contact) to try to work with Cheton.

The picture is becoming more clear and I’m sorry if there was any annoyances from my comments. Things were not lining up but clearly efforts were made on your part even if the one CNCjs developer I know was left completely in the dark about all of it.

I’m 100% with you on what you stated in your message to Cheton so thanks for posting that.


My intention was to prevent them from getting support requests. I put my email at the top so I could field the questions. And indeed, I’m responding to an email a day or so at the address which is on the about page.

Putting the other contributors behind a second click was not intended as any sort of slight to them. I had hoped to signal my appreciation to them by keeping their pictures, etc. without adding my own.

Is he a maintainer? We need a Github maintainer (admin on the project) to help merge anything. AFAIK, Cheton is the only maintainer… which is why there have been no releases in over 6 months…

If he is a maintainer tho I’d love to get in touch!

I understand where you’re coming from. It’s just — I care deeply about open-source, and have been putting in easily 40+ hours a week on this project (I’m unemployed and have devoted 100% of my time to this).

1 Like

I’ve given Mitch your email address and he said he’d get in touch with you. Just remember he’s coming at this from being completely blindsided by learning Makerverse exists. :slight_smile:

Of course! I hate to have caught him off guard, and only wish I had found him earlier.

1 Like

I’m having more issues with 1.1.2 Raspberry Pi Image than I ever had with the 1.1.1. Is anyone else having problems with the desktop image? Makerverse does not appear to be running in the Task Manager, and bin/launch does nothing. I’ve been through the instructions many times trying to figure out if I’ve done something wrong. If I have, I can’t find it. With the lite version, I am able to connect to Makerverse from a desktop computer, but I can’t do the same from the Desktop version.

Is it me?

I’ve manually gone into the bin folder and executed “launch”, but still can’t seem to open makerverse

Not just you… same issue here with desktop image version. Also not showing up under task manager.

Manually go to the makerverse/bin/launch file and hit execute. After that wait 10 minutes and try logging into the ip address. I finally got mine working that way

That worked… thank you thank you!

1 Like

What do you mean by task manager? It would not show up there; it’s not how Makerverse runs.

Keep in mind, the first boot needs lots of time to start the app. It has to download the whole thing. It’s trying to do this 10 minute process in the background. Sometimes, I’ve had to also reboot my RPi, as well.

@Jon_Brohau @Mathew_Mulholland in the future, note that the Raspberry Pi instructions link you here for troubleshooting. Please use the documented commands to debug and let me know their output if you get stuck: http://www.makerverse.com/installation/web-server/linux-service/#troubleshooting

Zaneclaes Task Manager is an app on the desktop that shows you the running programs. I’ve run - sudo systemctl status makerverse - on an ssh and it come back “failed to start makerverse”. Attempting to activate kiosk mode ends up with a black screen. I’ve had to reflash after attempting the kiosk mode.

Status shows a failure:
pi@makerverse:~ $ sudo systemctl status makerverse
● makerverse.service - Makerverse Server
Loaded: loaded (/etc/systemd/system/makerverse.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2020-11-01 14:53:42 EST; 11s ago
Process: 6924 ExecStart=/sbin/runuser -l pi -c 80 && /home/pi/makerverse/bin/launch (code=exited, status=127)
Main PID: 6924 (code=exited, status=127)
Nov 01 14:53:42 makerverse systemd[1]: makerverse.service: Service RestartSec=100ms expired, scheduling restart.
Nov 01 14:53:42 makerverse systemd[1]: makerverse.service: Scheduled restart job, restart counter is at 5.
Nov 01 14:53:42 makerverse systemd[1]: Stopped Makerverse Server.
Nov 01 14:53:42 makerverse systemd[1]: makerverse.service: Start request repeated too quickly.
Nov 01 14:53:42 makerverse systemd[1]: makerverse.service: Failed with result ‘exit-code’.
Nov 01 14:53:42 makerverse systemd[1]: Failed to start Makerverse Server.

I get the same failed message after pi@makerverse:~ $ sudo systemctl restart makerverse

The logs show nothing:
pi@makerverse:~ $ docker logs makerverse
Error: No such container: makerverse

Full system logs show an error:
– The job identifier is 1304 and the job result is done.
Nov 01 14:39:09 makerverse systemd[1]: makerverse.service: Start request repeated too quickly.
Nov 01 14:39:09 makerverse systemd[1]: makerverse.service: Failed with result ‘exit-code’.
– Subject: Unit failed
– Defined-By: systemd
– Support: https://www.debian.org/support

– The unit makerverse.service has entered the ‘failed’ state with result ‘exit-code’.
Nov 01 14:39:09 makerverse systemd[1]: Failed to start Makerverse Server.
– Subject: A start job for unit makerverse.service has failed
– Defined-By: systemd
– Support: https://www.debian.org/support

The only thing that works is to manually access the bin launch app and click execute. Then open web browser and use the :8000
makerverse/local does nothing

Thanks for the details. Sounds like indeed there may be something wrong with the desktop image. I’ll take a look when I get back home. I think I know what’s wrong with it.

It’s unlikely it would show Makerverse when running normally. The Task Manager, when started the way you described, does not generally show system tasks (which is why I ask you to use the listed commands).

Note: that is not the correct URL.