Alternative to makerverse

Is there a reasonable alternative to makerverse right now? this software is a dumpster fire.
i cannot get it to calibrate - am always trying to calibrate, actually, probably an average of 10 hours calibrating to one hour working. Deleted my workspace because edge calibration was so far off that it cannot physically make it to all the locations, as top center was 760mm below the top edge. Now I can’t set up a new machine because this step requires login. I was using the ol’ stay offline while using makerverse trick but that doesn’t work in this instance.
I’m at my end with this software, this machine, and this company. None of it was ready to sell to the public.
Any ideas on an alternative to run the machine?

1 Like

which version of the maslow are you using?

David Lang

It’s an m2

You can jump back to the stone age with us using the mega controllers and get one of those and use webcontrol. But you would need to buy a new motor control shield along with the mega and those are somewhat pricey at $150 from Eastbay.

Ok, thanks.
Not likely, as I am closer to cutting my losses than I am to spending more. But good to know, thanks.

Is EastBay still in business? I thought they closed :confused:

metal maslow went offline. East bay just came out with the 1.5b shield and groundcontrol 2022 that works on the mac.

1 Like

Good to know, I’m not sure how I missed that.

Calibration sucked for me as well. I was thinking it was the bit to edge, but it’s actually sled to edge. I had to email tech support for confirmation on it because I was close to jumping off a bridge. I’ve got mine dialed in pretty well now but even most recently I did a few things to my frame to make the “bed” more rigid as I noticed after a year a few boards had started to bend. It was only impacting my z depth, but that’s enough when doing pockets to make you made.

Good luck dialing it in!

Currently my machine is stuck at 53mm accuracy and redoing edge calibration does not improve it and sometimes makes it worse. It has not done that in the past - it has always slowly improved. It’s like it’s not applying the calibration when you click the button.

I have gone so far as to delete and uninstall everything and completely start over. This did not help - on z axis calibration it moved 24 mm when it should move ten. When I clicked the button to apply the scaling and did it again, it tried to drive itself down through the sled and the spoilboard. Had to pull the power to keep it from breaking something. When I reconnected it continued to try and drive the z axis down for over a minute, like it was trying to move it several hundred mm on the z. Not the first time but the most extreme. The machine is not capable of making logical movements in line with what it says it will do or where it think it is. I am convinced that the Due is fried, somehow, again, without ever really producing anything. But of course they will not admit that.

Glad yours came around eventually.

If you are in the Midwest, I could try and give you a hand.

Thank you, very much appreciated . I’m nowhere near there but I appreciate the offer.

I was thinking about you Z axis going bonkers. That happened to me as well! Happened on a few occasions actually. Once it was because the cable come unplugged from the motor. The other time was because I had a bent pin on the motor that controls the z. Check the pins on both the motor and controller.

As for the wildly out of calibrated bed, not sure what to say there. It’s been awhile since I calibrated mine. I saved my details though! With my settings, I’ve got it pretty accurate within a few millimeters and it works really well. Here are my settings that I exported some time ago:

"chainLength": "4600.000",
"distBetweenMotors": "3712.000",
"motorOffsetY": "603.000",
"leftChainTolerance": "1.963",
"rightChainTolerance": "1.764",
"sledWeight": "111.200",
"chainOverSprocket": "2",
"rotationDiskRadius": "139.100",
"chainElongationFactor": "0.0000051685",
"machineHeight": "1253.000",
"machineWidth": "2477.000"

This is for an XL frame and I roll with 15 ft chains, but perhaps you can compare your settings with this and see if you have anything too far out of wack.

I’m out of town right now, but maybe we can do a video meet sometime and walk through your setup. I spent a long time getting my machine “pretty good” and had some similar problems initially.

I’ll drop this here since we’re about to re-brand Makerverse into a software program called “Makerhub.” Makerhub is continuing version 1.2.0, which completely removes all login issues. Because we are still internally testing it, we have not opened it up on the website yet, but I’ll go ahead and drop a link to it here for continued testing. We would like to get all feedback possible from M2 users to continue supporting them.

The core issue in Makerverse is the login issue plaguing many users. Sourcery has since hired a developer to fix this and remove the login and rebranding into Makerhub. More announcements will come soon, but I think this was a good place to drop a link to the renamed and login-removed Makerverse/Makerhub:

–t.j. weber


I’ll try it out. Thanks for sharing!

This is awesome! I’m guessing that this is version doesn’t have any feature improvements but instead simply removes the Auth requirement?

I love that there are app images! Will test this out as soon as I get home tomorrow!

Thank you for sharing this.

That is correct. There are not any feature improvements except removing the login issue. However, I highly encourage everyone to log the bugs in GitHub (preferred, if you have an account there) or submit a ticket to with a bug. This goes for anything you might experienced in 1.1.x. We do have some bugs listed in the older GitHub repo. However, we would like to tackle the worst bugs first.


1 Like

Filled a bug. I tried running the app image. From the UI, it looks like it attempts to connect to a new machine as soon as I select the sled size and just says connecting. Flipping back to the command line where I launched the appimage, it looks like it’s looking for an auth token so I don’t know if this version will work as is.

1 Like

Thanks! Any additional updates/bug reports are appreciated. I’ll see if the developer can provide a little more insight.