Maslow Home Maslow Community Garden Newsletter

Raspberry pi died and windows laptop wont connect

It has been at least six months since I was able to use the M2. When I tried turning on the Raspberry Pi it just boots to a black screen with a cursor. I tried to hook up my laptop however the new software won’t connect to the Arduino controller. I tried updating the firmware however all I get is:
Arduino: 1.8.15 (Windows Store 1.8.49.0) (Windows 10), Board: “Arduino Uno”
Board at null is not available
The board is plugged in and power is on. The usb cable is a working and an upgrade from what was sent with the system. When I first plugged it in the motors made the alarm noise. About 20 min the noise stopped.
I also can’t change it to Arduino due the option is not there.
Any help would be great.

Disclaimer, I am no expert, just trying to help, hopefully one of the more knowledgeable will be along.

Have you tried rebuilding the Pi?

If that is not possible I would try to go back to ground control at least temporarily to rule out a problem with the arduino. Or find a way to test the arduino.

Do you feel confident that you were able to select the correct com port in the arduino software? That would be my first guess. I would double check that step.

It is the only option. Here is a screen shot of what makervere says:

Also I cant find Arduino Duo in the Arduino software:

I flashed a new card and will try to load webcontrol on the pi.

I have the duo board but it still wont conect. When I open the serial monitor I get a blank screen.

to program the due, you need to install the 32 bit avr boards so you have the option of selecting the due programming port. There is a wiki post on it here.

1 Like

Thank you. I am conected now and makerverse on my laptop is running the M2. I will start the a new calibration.

2 Likes

Good call @Orob!

1 Like

Glad you got it sorted!

1 Like