Maslow Home Maslow Community Garden Newsletter

Shaft Coupler for Bosch 1617

#21

Yeah, I’ve gone down that route. I’m probably at 3/8" or less. I was curious if anyone using the Bosch base had any more out of the box ideas like ways to modify the base. I think my next step is to find thinner material for my sled.

#22

Or get a longer bit. I’ve used these to profile 2x4s. they’re 2 and a half inches long total with a 1 inch cutting area.

#23

I am facing some calibration issues on my Bosch 1617 router and hoping some members can help out - I used the steps outlined earlier and changed my pitch value to -1.5 because the rotation is opposite to the Ridgid that the sofware is based on.

Now, when i try to lower & raise by clicking the appropriate buttons - the movement is exactly how it is supposed to be. However, when i click the “plunge to -1”, the rotation is still opposite i.e. plunge causes the bit to rise. How am i supposed to resolve this?

attaching a screenshot of the dialog box

1 Like
#24

Welcome to the Forum!
This would be a bug if someone can replicate it.
What version of GroudControl and Firmware are you using?

#25

Thank You!
I am using Ground Control v 1.26 and Maslow Firmware v 1.26 (i downloaded these off the github page)
I am on Ubuntu 18.04.2 LTS
the python program is running on a separate conda environment that i created with all the dependencies installed

My thought was that maybe it says plunge to -1 (& the pitch has already been set as -1.5) that it interprets it as +1…if that makes sense. If there was a way to change plunge to absolute value, instead of a negative value, it might work as expected

1 Like
#26

Running on ubuntu 18 for Malsow simulation in my home office, in the workshop on the real machine i run Manjaro.
I noticed the ‘relative’ and ‘absolute’ (in gcode G90/G91) in your screen-shot and wondering if that could be a clue. Do you see the commands sent in the terminal (if not they are for sure in the log)?

Edit: How do the z-value displayed in GC change? Correct or reversed?

#27

Adding the screenshot from the terminal window
G91 G00 Z1.000 G90 <— this is the plunge command. I hit stop immediately because i did not want to break my 3rd shaft coupler.

G00 Z0 <— this is goto zero. Works as expected

G91 G00 Z-1.0 G90 <— this is the “Relative - Lower” button press command

Edit: it does look like the Z value changes orientation (-ve to +ve)

#28

Assuming that you set Z0 before correct, this is an interesting find. Will take me 2 days to attempt a replication. Hope someone is faster or gives an explanation.
Friday morning i can be in the workshop. Thanks for the detailed info!

Kind regards, Gero

#29

Edit: i did set Z0 and it was working as a shortcut

Thank you - i appreciate it.

I must add that i broke my previous shaft coupler as a result of the plunge issue as well. I had the same reults in the plunge test with the previous iteration and also tested to make sure that the Raise/Lower worked as expected. When i went to calibrate for the test cuts (next page in calibration), i pressed the home button & my Z-axis shaft coupler spun UP, going beyond the upper stop, and pretty much wrecked it.

#30

You have a good chance that no one has tried the ‘plunge to’. Why did you use it?
I set Z0, raise to safe height, exit the Z menu and start the cut.

#31

Its possible that the “plunge” to is a hard-coded button that doesnt factor in changes made in the config settings page. I’ll try to get to the next step and report if i still have the same issue

1 Like
#32

You are familiar with creating an Issue on GitHub?

#33

Sure - i can post on the Ground Control Github page

1 Like
#34

adding the GitHub page for reference. The issue is now closed.

1 Like