Maslow Home Maslow Community Garden Newsletter

Sled moving around without much cutting; cut image on wood sideways

First time posting. Your intro states “silly” questions don’t exist. Hoping this is true!
I have two problems:

  1. the sled moves around without much cutting, and
  2. the image on the wood is distorted (tilted about 30° to the right and squished top-to-bottom).
    This is what I have and what I’ve done so far.
    -I have the M2
    -I built everything using “Maker Made M2-Assembly-Guide-v1_8”
    -computer: HP Zbook laptop, i7 core, 16GB, Win 10 Pro 64-bit
    -Using Easel free account
    -Using CNCjs 1.9.22
    -I set my router bit “home” (0,0,0) to the bottom left corner
    ***I moved the nails that hold the chains toward the motors 2 inches as the sled wouldn’t reach the corners of the plywood (it ran out of slack chain, and the sprocket would have pulled the nail out). Is this in error?
    -I set up Easel according to Easel for Maslow Basics: From SVG to GCode except for setting Machine > Advanced Settings > Spindle Control to “Automatic” (this M2 has Z-axis control)
    -I downloaded a .SVG file (shape of a house) and generated gcode (with “Automatic” Spindle Control)
    -I imported the gcode into CNCjs
    -I began the cut.
  1. The sled wanders around the wood (3/8" birch ply) and only cuts certain parts of the design.
    Eventually, the sled worked its way to the bottom, and the bricks sat on the floor, chains slack, until moving upward again. I interrupted the cut.
  2. The design on the wood is far from what it should be. Only parts of it are cut, leaving blank most of the wood.
    Hoping for some insight. I know this is a “do it yourself” project, but doing it myself isn’t workout well so far.
    Thank you for any comments.
2 Likes

Welcome to the Forum @allansplace!
Just to confirm, the M2 kit came with the arduino Due and you are running with the firmware that is pre-installed on it?
You are talking about using

Are you running that, or Makerverse that is based on CNCjs?

Yes, the M2 came with “Due”. I haven’t done any firmware upgrade - it is ‘as-is’ from the box.
According to the CNCjs software, it is https://github.com/cncjs/cncjs/releases/tag/v1.9.22. I also have Makerverse installed on this computer, but I haven’t used it yet. Being a newbie, I wasn’t sure what I was doing and installed both. Now I see they do (pretty much) the same thing.

2 Likes

I’m surprised that CNCjs runs at all. Makerverse has Maslow as a machine to choose. What machine did you choose on CNCjs?
I’m not very solid on either of both, but others like @Orob will join in to help.
What do the messages in black console in Makerverse look like?
How did the calibration go?
I can offer to look at the g-code, to exclude that the issue comes from that side.
As a new user, after a few likes, mentions and replies, you should be able to upload a file.

Welcome @allansplace! It sounds like Gero has gottent started. I’ll mention what I think stands out from the information you posted and suggest a couple avenues

  1. the moving without cutting sounds like gcode (traveling salesman issue - not much you can do with that unless you switch gcode generators)
  2. I experienced the same sort of distorted image one time. I set the machine home in dead center of the work space for calibration and then tried to move the work home but ended up setting the machine home again over on the left of center. the machine home must be the absolute center of the work piece. The work home is the origin of the drawing you are cutting. If you accidentally move the machine home to the lower left, then the cuts will be distorted and very strange because the system thinks the chains are the same length, so a vertical move won’t be vertical. The fix:
  • go back to absolute center and home the machine with the “reset chains” button.
  • move the sled to the desired work origin position and then click on the x and y axis buttons indicated by the arrows to zero the work position x and y axis. This should show your drawing in the correct location to cut
    The picture below is from makerverse:

maybe try a smaller simple cut to see if it works before doing something ornate to make sure it is working. With the newer versions of makerverse, you should be able to also verify accuracy with the new calibration routine that should give some confidence your system is pretty close if you don’t want to cut without some verification. I use estlecam and carbide create for gcode generation. Those are local programs on the pc, so you can try them for free if you want to see if the gcode generation is better.

1 Like

Thank you, Orob. Your help is really appreciated.
I was using “Home” in CNCjs to “center” the sled. My bad. I see now that, as you explained, center should always be center and that any job starting at a different place is the “Work Position”. It seems obvious now, but I really didn’t know.
I don’t see a “reset chains” button, but I see the “Set Home”. Is this the same thing?
In my first job, it was a simple house 6" x 8". But … CNCjs stated that it would take two-and-a-half hours. I think there must be something I’m doing wrong in that area, too.
I’ve switched to Makerverse. I’m not entirely sure what the difference is. You mention a calibration routine, but I cannot find this. Is it part of Settings in Makerverse? I searched online but cannot find much on this aside from cutting something and measuring the results. How to calibrate it even after seeing from cuts that it is out some, I have no idea.
I’ll find estlecam and carbide and play with them as well.
Thank you again!

Glad you sorted out the distortion. To get the new calibration routine, you must check the beta box in the general settings.

EDIT: yes, reset chains and set home are the same thing, just different label to help distinguish between machine home and work home. reset chains becomes the machine home and work home becomes the drawing origin that can move

Thanks! That changed button name might have saved me from cutting weird angles the first few times. Live and learn.