Sled not keeping up / sled stutters


i just made a video of my sled when it started to studer and shortly after this i got “sled not keeping” up. Never happend before, seems to happen when load goes over to the left motor. This motors axis is a bit loose and a couple of days ago a coworker did led the sled fall about 1m into center position when changing the material :frowning: I did try to continue the cut but again, nearly at the same position the machine stopped again with alarm and “sled doesnt keep up”. Feedrate had been 700mm per minute.Cut depth 3.2mm with 6.35 / 1/4 downcut bit.

After the accident with the sled falling (with router) i did cut more than 1 1/2 plywood sheets without problems. The motor test is ok. (Do i need to recalibrate after motor test?).

Then, both lamps on the motor controller are on. On the arduino i can see an orange led blinking. Any tips how to debug and where to order good replacement motors? Preferably via Banggood / Alibaba and maybe Ebay directly from Asia where i live?

Video of the “studering”

Stopped here 2 times with “sled not keeping up”:


1 Like

The good news is that I don’t think you need a new shield. It looks like things are mostly moving smoothly.

The “The sled can’t keep up” error means exactly that. The sled is being told to move more quickly than it can physically. When it falls too far behind you get an error message.

There are a couple reasons that can happen. It could be that at that part of the machine moving in that direction the motors just can’t quite keep up. Moving side to side near the top of the machine is where the motors have to spin the fastest to move the sled at a particular speed, so that would make sense.

I’ve also seen this issue when someone’s power supply wasn’t plugged in all the way so the machine was getting enough power most of the time, but not under full load. Maybe the drop could have jostled the power plug?

I’d check the plug and try cutting that part a little slower before buying anything :grinning:

Please do make a new thread, having a different topic within the thread will just confuse things.

1 Like

cutting along the top is where the motors have to work the hardest (not necessarily move the fastest, but they have the most tension on them)

if the left motor is loose, try to tighten it up (you may have to open it up to tighten some screws).

It is possible that the drop yanked the gearbox in a way that damaged a gear, opening it up would let you look them over (make sure you have grease in there when you reassemble it)

700 while cutting across the top is around the limits of the machine, so if there is anything causing additional friction or less power from the power supply, that is where it would fail.

I am currently using the stock maslow shield and will replace it with the metal maslow shield which should be able to supply more power to the motors and retest. Is there a way to transfer the part of the setup/configuration which is saved in the arduino to a new one?

The studdering could be a sign of the motors being underpowered, right? A mechanical defect should look different? Any ideas?

Then, can i mix motors as long as they have the same specs or must i use a pair of exactly the same motor?

a mechanical defect could add to the load, causing the motors to draw more

David Lang

Yes, thats very possible.

I did cut the same shape again but the cut which doesnt go as high. Can be seen in video and photo left to the cut where i did get sled error. I did reduce speed to 600 and the cut completed. But when cutting downwards the sled is studering. The motors stop for like 1/2 a second. This does not happen with horizontal cuts and it does not happen when cutting upwards. Which is strange because motor load is more when pulling the sled upwards.

No part of the machine (motors, shield, router) is more than handwarm. I did touch both motors and “couldnt feel anything” when they had been studering. What could make the controler stopping the motors for 1/2 a second?

On the FB maslow group someone had the same problem and another one answered it would be a failing motor… argh


The part of the motor which can fail is the gears, you can open the motor and take a look at the gears in there to see if any of them seem damaged.

It also might be an option to swap the motors from left to right to see if one motor is different from the other.

I’m still not 100% convinced that this is something broken and not a software setting. We could still get lucky and you might not need to buy anything new.

I will order a new set, probably from metal maslow and after replacing the motors check them to see if the are repairable…

1 Like

I did do small small cuts today, tuned cut depth down to 2mm and cut speed to 300mm/min. The stuttering is still there, always at the same locations. In this case on all four “ears” of this cut. Arcs had been disabled within my CamBam CAM software. I did verify logfiles, no “generating arc” messages from the controler. Cutting location rel. close to center of board, a bit left. So there should be no stress on the motors?


How likely u thinks thats its the motors? Very, right?

I just wanted to order new motors but they had been removed from the metal maslow shop, argh. Anyone knows where i can buy good replacement motors… ?

Are the makermade comparable to the metal maslow ones? They do look identical.

can you please post the gcode?

being slow in the corners could mean that there are lots of tiny moves there,
and the maslow is limited in the number of lines/sec it can process, so if there
are lots of tiny moves, it may seem like the sled is pausing.

David Lang

Sure, but if i remove all arcs from the drawing and surpess the post processors ability to generate arcs there must be a lot of small movements?! (24.4 KB)

I need to re-cut anyway, will leave arcs in, and report back. Is there a compatibel arduino with more CPU power?

1 Like

Carbide Create is free and easy to use. Maybe try this and generate gcode to see if cambam is responsible for the problem.