Running a cut and got error "Sled not keeping up..." Now motors unresponsive

I tried running Test Motors/Encoders and get a fail…

G21
B04
Testing L motor
Direction 1 - Fail
Direction 2 - Fail
Testing R motor:
Direction 1 - Fail
Direction 2 - Fail
Z fails as well

PCB v1.2
Grbl v1.00
Ground Control 1.13
Firmware Version 1.13

If I remember right, the “Sled not keeping up…” alarm requires that you click on the “Stop” button to regain control. Quitting GC would do it as well.

The alarm message reads:
“The sled is not keeping up with its expected position - make a note of the line number. Then click the ‘Stop’ button to clear the alarm.”

I hit stop restarted GC and then tried running the test motor/encoders and got the fail. Could it be the shield went bad? I only ran test haven’t really cut anything yet just got it calibrated.

1 Like

It could be that the error was because of an issue with the shield but it’s pretty rare for all the chips to die at the same time. Usually only one motor will stop working at a time. Having them all stop at once sounds more like a power supply issue to me.

Does the blue light on the power supply light up? What about the green one on the Arduino shield next to where the power supply plugs in?

2 Likes

Bar you are a genius I am but a fool. In my old age, I have discovered I tend to over complicate the problem when as a younger man I use to start from the basics and move from there. The power supply cable was loose. I was tempted to delete the post to save myself the embarrassment but I think leaving it up will help others who might run into the same situation. Thank you for your quick response.

7 Likes

That’s the best possible answer! :+1:

I only knew to guess that because I’ve been there before…more times than I want to admit.

4 Likes