Maslow Home Maslow Community Garden Newsletter

Software for Older Makesmith

I bought one of the small Makesmith machines from a guy on Ebay. He told me to use Ground Control so I downloaded the latest version and soon found that it wouldn’t talk to the older hardware. This has been confirmed on this site which also suggested scrolling down to the “Last Makesmith” version (.60). But unfortunately, the downloads are no longer available for this and older versions. Can anyone tell me where or how to download UI software that will work with my new/old machine? Sorry to be such a turnip, but I’m a newbie. Any help will be appreciated. Thanks! Gordon

Oh man! That goes all the way back to 2015. Let’s see what we can figure out.

The good news is that the files you want are in there, they’re just a little bit hidden. You want to download this zip file here:

Then when you extract it in the “build” folder you will find installers for each OS. If you are on Windows you probably want the .exe one.

You might get some security warnings and such, but I was able to install and run that one. Good luck!

Thanks Bar. I fumbled around and got v. 0.59 to load and run, but I think my board (Arduino knock off) seems to be defective. It tries to connect but fails and then scrolls weird Chinese characters endlessly. I ordered a new Arduino board and will try again when it gets here. Thanks again for the advice.
GA

That could also be the COM port. Were you able to install the firmware successfully?

that sounds like a communication speed issue. was the firmware baud rate different? You can change that number and try again.

Thanks Orob. I set the baud rate at 57600. I read that somewhere. Can you tell me if that’s correct? Thanks!

Hey Bar,
Yes, I was able to load the firmware successfully…well, I think I did anyhow. Thanks for the advice guys.

57600 is the current mega communication speed, but I do not know if that is the speed used for the version you have. If you see garbage in the communication, then you can change it until you get readable characters and it works. Sounds like it is working, so great job!

Sorry to bother you all again, but I’m still stymied again and need your help!
I finally bought a new Arduino board, a 2560 Mega. I hooked it up and loaded the firmware for v. .59 using Arduino software.


Everything looked good at first. I shut down Arduino and started the v. .59 Makesmith. I opened the diagnostics utility under the run command and ran the test motor, test encoders and test both. The cnc machine responded with a very short X, Y and Z commands in both directions. The Makesmith readout reported all tests normal. I then did a encoder calibration which likewise seemed to work normally.
That’s when the joy ended, unfortunately. When I attempted to drive the motors manually, I got weird responses from the machine. Usually two positioner motors running simultaneously in various directions.
This pic shows the Makesmith awaiting a command:

This photo shows what happens when I attempt to drive the motors manually from the UI:

It eventually clears the com lost alarm on its own.
It shows up in my device manager and I guess all that looks normal. I’ve messed with the baud rate a bunch. It seems to work the best at 57,600.
Any help you can provide would be greatly appreciated. Thanks guys.
Gordon

I neglected to mention that I’ve tried to load and run a simple g-code and the results are the same as when I try to drive the motors with the buttons. I goes into an alarm state and counts down over and over again.
My head hurts.
Thanks gain.
GA

Oh man it has been so long since I touched one of these. It’s sounds to me like you are doing everything correctly. Is there any chance you could try on a different computer? I can’t see why the USB connection would be dropping like that, but that seems to be what is going on.

Thanks Bar. Yes, I tried it on my older laptop with the same results. I’m suspecting the software, but not sure how to deal with it. Odd that it runs the diagnostic okay but chokes on the jog controls.
I’m wondering if I could use a more elaborate control software like Universal Gcode Sender?
GA

Darn…I was hoping that would fix it.

The only thing I can think is that maybe it’s a power issue? The jog requires more power to drive the motors so if the power supply isn’t keeping up maybe it is drawing too much power when it tries to move and resetting the Arduino.

Thanks again Bar. I’ll check the power supply.

1 Like

I’m continuing to think on it, although my memories are all hazy :grimacing: