Which Port do I select?

In the assembly instructions it says: 6: Select The Serial Port
Select the correct port to connect to by clicking Tools -> Port -> Your Port. On Windows this will be something like COM3, on Mac and Linux computers it will be something like dev/tty/. You can find the right one by plugging and unplugging your Arduino compatible board and checking which option disappears.

I am unplugging and plugging the usb and nothing seems to change in my options (I do hear a ringie dingie each time [sorry if my jargon is too technical]. I went with the only choice that is there whether or not it is plugged in. yet I still get an error message when I try to upload the firmware.

Check if the green light lit on the Maslow shield.
Try a different USB port.
Try a different USB cable.

I get a green light, a sound, and have tried the two ports I have.

The “whether or not it is plugged in” part bothers me. It should disappear when you unplug. Here are some other questions, though I think someone with more knowledge about connection issues may need to take it from here

Is ground control running? I think it’s possible it could be hogging the port, making it unavailable.
What operating system are you using?
What is the error message when you try to upload the firmware?

It sounds like we’re troubleshooting the process of getting the firmware loaded using the Arduino IDE. I’m not sure which instructions you’re following, but these have pretty good pictures of the menu choices that need to be made in the process. You’re probably at step 4, but Windows users sometimes run up against a snag. Windows doesn’t extract the .zip file when the user opens it unless the user explicitly says to. Make sure you’ve extracted the contents of the .zip file and are opening the .ino file from there (this should be step 3.5W maybe?).
Step 6 should list the serial port to use, but plugging and unplugging the cable while the menu is showing might not show the connection/disconnection. Might even need to quit Arduino and start it again for it to recognize the change.

1 Like

What Operating system is on the PC you are connecting with please?

Thank you

This points out something that I think is a problem. There are a variety of instructions on different platforms. It’s hard to know which instructions a user is working from and if those instructions are up-to-date.

2 Likes

I agree, having more than one source makes keeping instructions up to date much harder.

1 Like

unless they are all embedded from one source

I have issues with the git wiki to find something that i know is there. This is trying to help someone.
A branch structured menu is the key to where ever it is hosted. My dream would target a ‘3 click there’

2 Likes

I learned that even though I had restarted upon obtaining the latest version of arduino, I hadn’t restarted after downloading the firmware. I have made it past this problem (thanks for your help) but there are a couple more things that concern me: 1. Why did I have to get the latest version of arduino when the firmware has an earlier version running on it? as far as I can tell, the latest version I downloaded hasn’t needed to interact with the shield. 2. When I went to “Actions” on Ground Control to select the correct port… I selected the port and it gave me this message:

Notification: Unable to find valid position for chain lengths 0.00, 0.00 Please set the chains to a known length (Actions-> Set chain lengths)

1 Like

I have been using the Assembly instructions from the Maslow site.

1 Like

With every (not always) new version bugs found in the older one are fixed and enhancements added.
It is recommended to have the latest Firmware and GroundControl with matching numbers. (currently 1.18 and new every 2 weeks)

Windows

That sounds like it is connected. On the right bottom of GC, do you see a ‘connected’ and the report of the FW/GC version?

Windows 10?

No, I do not see ‘connected’. also to be fair, you all just informed me that I could be learning from any number of sources, which explains a lot about the gaps my brain has had to fill in :slight_smile:. I don’t even have experience to know about what to ask next so thank you for your patience. I suppose I am supposed to know what length my chains even means first.

2 Likes

Feel free to ask anything any time.
I would not expect that you see the message from GroundControl without being connected, so you cracked the first hurdle I guess. Keep asking and you will be making woodchips soon.

2 Likes

For windows 10 you want to open “Device Manager”, under Ports and LPT you should see comports listed.

https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware-winpc/com-and-lpt-ports-in-win10/ad9d9f10-87e9-440c-acfb-49409a5467b9

Can you tell us what is listed there on your PC?

Thank you

Going further Windows may need additional drivers to properly see the Arduino Mega. After the drivers it is a matter of identifying the correct Comport in Device Manger then plugging that into the Arduino IDE. It’s a Chicken and Egg situation.

https://www.mathworks.com/help/supportpkg/arduinoio/ug/find-arduino-port-on-windows-mac-and-linux.html

I hope that helps

Thank you

Good to hear we’re making progress!

In addition to @Gero’s point about improvements to the ArduinoIDE, it helps ensure that the screens, menus and selections match our online documentation. It helps us provide support as well - ‘all on the same sheet of music’ sort of thing.

Well, that’s a victory, in a way… when GC makes successful contact with the firmware, the firmware reports current status to GC. The firmware keeps track of where it thinks the router bit is by storing the amount of chain it has extended on the two motors, and a similar value for the z axis if that is present. This information will be preserved through power cycles and firmware updates. When it isn’t present, the dialog you saw comes up. In practice, that would only happen when the machine hasn’t been calibrated, when the EEPROM has been wiped as a troubleshooting step, or when the Arduino Mega has been replaced. Once you’ve been through the calibration steps, the firmware will have valid values for the chain lengths and you’ll not see that message again…
So, the message means that GC is using the correct port and that the firmware is present and running on the Arduino Mega. Now on to the calibration, and you’ll be making wood chips very soon. Keep us posted and bring up suggestions for ways to polish the process. :+1:t2:

1 Like