Spindle on (M3-4) no signal on D17 with shield v1.4b

I am trying to connect the wiring so the M3 or M4 will turn on the spindle. I have had the Maslow running flawlessly for over a month after working out some of the rf noise problems with USB signals. After getting that figured out, I attempted to work on the spindle on/off.

I have the v1.4b shield, for which I can’t find any documentation for Aux1-4. Every image/diagram I find is one which already has the labeled aux port through holes on the pcb. Mine has none, nor any markings. Through research, I’ve determined (assumed) that the arduino uses D17 for that signal.

I am running 1.26 of the software/firmware.
I have the Relay_High set for the spindle automation setting
When I check the voltage on pin 17 after the spindle is turned on, it floats about 600mV (same as before “spindle on” is issued). Originally I put an LED (with resistor) between pin 17 and ground hoping the led would light when the spindle was to be on. It never came on.

I have tried 2 different mega boards in case the was the problem. Both acted the same way.

I hope the solution is obvious to someone. If 17 isn’t the correct pin, please let me know. I also want to use D14 for the Z zero function, but that doesn’t work either. I’m assuming I did something silly because the wiring instructions are fairly clear, and I thought, easy to follow.

I’m resisting buying a new shield just to get the stenciled ports. I’ve attached the mega image with my pin 17 marked with a blue arrow so you can tell if I’ve assumed the incorrect pin.

Any suggestions appreciated!


Can you post a picture of your shied? The system.cpp in the Firmware identifies board until 1.3 and that is a TLE with AUX1 on pin 40 (line 218).

    //AUX pins
    aux1 = 40;

Kind regards, Gero

Edit: For refference

/Firmware-1.26/cnc_ctrl_v1/System.cpp:255: SpindlePowerControlPin = aux1; // output for controlling spindle power

1 Like

Thanks for the quick response. The CNC is about 50 miles from me so I will get you the info as soon as I can. I may get out there today.

1 Like

I have a TLE shield and its labelled 1.4
I think that was a glitch in early production.
GroundControl reports the shield found at start. Bet it will tell 1.3, so pin 40 is the better bet.

On a not minor side note, Welcome to the Forum!

Kind regards, Gero

1 Like

Thanks! Great forum. My shield is marked 1.4b. I will check pin 40 when I get out there and let you know if that works. I’ll send the other requested info if not. I’ll also check the source, and response on connect. I didn’t think to look at what rev is reported.

1 Like

Welcome to the forum!

Would you be so kind as to detail your experiences with this (troubleshooting, verification of the issue, solutions etc) in a new topic? Noise has come up a few times before, related to different parts of the machine, but I don’t know that it has a specific topic that details the process you might have went through. I’m more than happy to help with that as well.

1 Like

@WoodCutter4 I can give it a try.

1 Like

It appears it’s reporting the wrong version! Great catch.

[Edit: This was an incorrect assumption on my part. Please read further down for an explanation of the shield versioning by @2cents ]



If it is a TLE it’s not wrong.

Spindle power is on 40 after seeing this.

1 Like

I must be confused by the different shields. I saw the Rev on the board at 1.4b and assumed it was not a 1.3. At the time I bought it was advertised as the latest 1.4 shield. I guess I need to read a bit more on the topic. I appreciate your thoughts.

The TLE2506 originally designed by @blurfl started its life as v1.4 however, when support for this shield was merged to the official firmware, it identifies it as “PCB v1.3 TLE5206 Detected” in GC.
This decision was made to keep consecutive numbers on the board versions.

When we decided to produce this board we did a research and found that aux ports were not widely used, since we were focusing on safety upgrades, we decided not to include them for liability concerns.

At the time you bought it (January) we were the only ones selling the TLE2506 which was indeed the latest shield version compared to the old v1.2

Although our shields now include aux ports due to user’s request, unfortunately your board does not.




NOTE there is not v1.4c and v1.4d (these where prototypes that never make it to production but we kept the sequence going for internal reference).

I’m very sorry for the confusion, hope you understand.
@gero is right, spindle is on Digital pin 40

Please let me know if it’s anything i can help.


note that there is nothing on the boards that’s needed for the aux pins, it’s
just a way to connect to the arduino pins.

There’s someone else who ran into the same problem recently who extended the
pins from beteween the two boards so they could connect to them.

David Lang

1 Like

Thanks for that information. I have verified the pin 40 does go hi and low with M3/M5 so now I can add my relay. I appreciate the help and clarification.


I will add here a note. Each and every connection you make with anything conductive can introduce RF noise or EMI and make something that worked without problems act erratic. This is basic electronics and not specific to the Maslow in any way.

There is no easy test to “see” this or know what environment will have the issue. There are a number of factors including humidity and grounding.

Thank you

As documented here:

1 Like

@dlang , I did notice that nearly none of those header pins come through the shield. Luckily I had purchased a screw terminal shield which I place between the Mega and the shield which gives me access to all pins without having to solder. I was able to connect the terminal for pin 40 for testing. Worked as expected.

It is great to have such quick, helpful responses on the forum. I’ve been stumped by (and ignorant of) this for a few months and just didn’t really have the time to spend on it. The forum has been very helpful. I should have written earlier!