Maslow Home Maslow Community Garden Newsletter

Sprockets turn 360 degrees even when clicking 0.1, 1, or 10

My sled crashed into my computer the other day causing the USB to become disconnected during a cut. I followed the directions to set the sprockets back to the chain marks, but when I tried to adjust the sprockets to vertical they will only turn 360 deg no matter what I input. I tried getting it close and pressing forward anyway, with no success. I am also getting the sled not keeping up error since the crash, during every move. I tried using the control pad to move it up 0.125" and that also causes both motors to make full rotations. I’ve tried reinstalling everything and searching the forums extensively, to no avail. I’m at quite a loss. Any help would be greatly appreciated.

I’m running webcontrol installed on my laptop directly plugged in, firmware 1.26, PCB v1.3 TLE5206, Grbl v1.00.

Thank you!

That is strange, I haven’t seen that behavior before.

I’m wondering if maybe pressing the button which says they are at 12:00 o’clock might fix it. Maybe they just don’t know where they are now?

I tried clicking"Define Zero", with no change.

The motors do turn the wrong way when I click to rotate them after they sit for a while, then they’ll go the intended direction on the second click; the motors also make a weird sound when they spin the wrong way that initial time.

I’ve had something similar happen but instead of 360º every time it would turn like 5º no matter what I inputted. (I’d press the 1º button and it would turn much more than 1º)

-I just unplugged all connections and restarted ground-control

Edit: Forgot that you restarted everything… did you unplug all connections? (power to Arduino, connection from Arduino to the motors, etc)

1 Like

Thank you!

I hadn’t unplugged and replugged in all of the connections, as I did so I found that the bridge was about to come completely unplugged!

I’m back to work now, thank you very much for all your help!

2 Likes

No problem, glad that I could help!

1 Like