Maslow Home Maslow Community Garden

Strange Ground Control Issue


#1

I am running ground control 1.25 on a windows 10 tablet, matching firmware on the arduino. I have to run the connection through a USB hub so i can connect to the tablet with a USB mini and have a mouse connected (temporarily) too. That said 1.18 was working fine in this configuration, but when i upgraded to 1.25 I started getting a continuous string of this:

when looking at the DOS window. GC GUI seems to load fine, but i have seen some strange things happen since this started. Any help would be appreciated.


#2

Hmmm that looks to me like the ground control is trying to load a line of code beyond what is in the file. For example if it were to try to execute line 500 in a file with only 200 lines you would see that error.

My advice is to press stop and open a new file and see if it goes away.


#3

This is happening even before it loads the GUI. An ALT/TAB shows it continues after the GUI loads too.

After posting this, I tried running a program. It wanted to raise the z beyond its setting and capabilities then hung. After 3 restarts like this the scrolling error didn’t arise and the program is running cleanly. But this has all happened before…


#4

My first instinct is that maybe it was trying to read a file that didn’t exist. It feels like an issue with a particular file to me so I’m optimistic that it might not come back. Keep an eye on it and let me know if it happens again? Fingers crossed :crossed_fingers: it was a one time thing.


#5

@Bar It was still doing it for the longest time, and about every 4th or 5th time it would open normally. Today, because the cheap tablet was acting up for charging, I plugged the power into the normal outlet rather than trying to charge it from the same USB hub i was connecting through and it didnt happen. i tried 3 times and no issues. I think it must have been feedback from the hub for the charging? Anyway, fingers crossed it goes away permanently now.