Stuck... I upgraded from Windows 10 from Windows 7 and now I am getting an OpenGL 2.0 Kivy Fatal Error

I’m not at my computer, so I’m doing this from memory. First thing is to do actions->quick configure. Then actions->set sprockets vertical and extend the chains and connect the sled. After, you can either do the old triangular calibration using the stock controller firmware or (and I suggest you do) upgrade to holey calibration firmware (actions->upgrade holey firmware) and when it’s done, run holey calibration a couple of times… each time you run it, the calibration will improve… until you get to a point of diminishing returns.

I really wish someone that is photogenic would do a video of going through the process :slight_smile:

ok, you talked me into ti.

1 Like

I appreciate all the help and responses

Thank you Madgrizzle

Did you get a chance to make the video Orob?

I had planned to do it yesterday but was unable to, sorry.

The plan:
-set the gears to 0 and reset the chains
-connect the sled
-upgrade my system to holey calibration

I’m working on it now and expect to hopefully get some decent footage and likely post later today.

Awesome

ok, I videoed the quick setup, the triangular calibration, the holey upgrade, and the holey calibration. I managed to do everything wrong and recorded most of it. It will take some masterful editing to make me not look like a complete idiot. I borrowed my daughter’s ipad to take the video because our camcorder disappeared and I can’t use my phone to calibrate and record at the same time. I sure hope this is useful. Extending the chains, I dropped one and had to do it 3x. If you don’t use a release version of webcontrol to upgrade holey, it will try for like 20 minutes until you cancel because the failure message dialog is actually behind the “please wait” dialog to upgrade the firmware. The development versions don’t have the firmware attached. Once it does upgrade, it automatically goes into fake servo and if you move the sled to start the cuts, realize it is in fake servo because the reticle is moving, but the sled is not like I did, then stop it and disable fake servo without moving the fake servo sled home first you get to reset the chains yet again. So this was a fun exercise in calibration frustration to hopefully be able to share some empathy with all who are doing this for the first time. It can be super frustrating regardless of how experienced or inexperienced the user. Take a deep breath, have some birthday cake or whatever you have to calm down and trudge through this step by step. It will work eventually, but the user must be meticulous.

What do you mean by "release version "?

@orob runs it from source code… the release version are the ones you download. I’ll look at the holey firmware to see if I can figure out why the firmware defaults to fake_servo on.

Ok, now I am really confused. Is Holey a different program altogether? Firmware, calibration…

Thank you

Jeff

“holey” is basically an alternate way to calibrate your machine. It’s in contrast to “stock/triangular”. To use holey calibration method, you need a specific firmware loaded on the Arduino. Webcontrol has this baked in by going to Actions->Upgrade Holey Firmware. Once you do that, Actions->Holey Calibration will be enabled and Actions->Triangular Calibration will be disabled (have to use stock firmware to do triangular calibration). Many people believe holey calibration and the changes made to the firmware results in more accuracy in cuts. But there never has been a head-to-head comparison.

I’ve looked at this in the past and looked at it again and still don’t know why it would start up in fake_servo mode. Only possibility I can find is that by chance the “standard/uninitialized” eeprom value at 4095 on an Arduino mega equals to 42. Maybe it really is the answer to life, the universe, and everything.

thanks for checking. I wouldn’t have mattered if I hadn’t moved the sled before I turned it off and had to reset the chains for the 4th time today. But that is ok because I just did a cut and had to reset them a 5th. It has been a busy day. I show regular calibration as well as holey calibration in the videos. I just have to clip them and make them less boring, so I’m working on that now.

1 Like

most of the videos are up now. They are linked from the maslow manual wiki page here. the chain extension one is rendering now and will upload. Thanks for your patience with the editing quality and lack of bling. This was a quick production effort in a very short amount of time to help out. Feel free to provide suggested improvements.

Thank you

I really hope they are useful. I learned a lot and I’m not photogenic, but whatever. After making all of the newbie mistakes again, I can appreciate the frustrations of getting things going. Hang in there!

Orob,
I am having trouble yet again. This time now I can’t connect to the web control. I am getting a new error message localhost5000 refused to connect message. I tried disabling my firewall and still the same thing. I went in and looked at the proxy server, and didn’t see anything there to check or uncheck.

Recap: You are running webcontrol from a Windows 10 machine. You are loading the web page from that same machine.

When webcontrol starts, it will open a browser window for you when it loads. This is what I see when the server is off:


It sounds like webcontrol has stopped. Can you verify that webcontrol is running?
This is what I see when it is running:

are there any error messages on that screen?
Iif you reboot, you will need to restart webcontrol because it doesn’t run as a service in the background, it runs in a window.

I hope that is helpful. any additional information you can provide regarding the status of webcontrol would help.

I uninstalled and get it working, but i can’t get it to communicate with each other now.