Maslow Home Maslow Community Garden

Tabs in makercam


#21

I figured that part out, but something still just doesn’t seem right with how the frame looks when I load it up in Easel vs. Makercam, and I’m not sure how to determine what’s wrong.

Here’s the sled in MakerCam with a 1/4" bit, Outside cut:

And here it is in Easel. Definitely doesn’t look right:

Maybe I’m getting hung up on the wrong thing, just hoping to get Easel work vs. MakerCam.


#22

The holes in the sled need to be cut ‘inside’ in Easel.Take a look to see if that is better…


#23

Hmm, still not looking right to me, but I’m very new to this. Are the holes in the sled supposed to be an outer hole for countersink that doesn’t go all the way through and then the inner hole goes all the way for the bolt to pass through? Here’s a quick video:


#24

Yes, that’s correct. It looks like select the outer circle you have set to cut through. Select the inner circle and set it to cut through, then select the outermost circle and set it to the depth of your countersink. You have it “black” at cutting through, it should be a light gray to only cut down so far. The inner circle should also be a cut, inside cut. And the outer circle should be set to fill, for the carve out of the countersink area.
Does that make sense? :+1:t2:


#25

You will do each one seperate, or hold shift and select all of the smallest holes to cut through. Then select the next surrounding hole and set to say .2 inch depth. See how that looks.


#26

If you do a group select will it cut the holes one at a time before doing anything else, like the screw head pockets? That adds a lot of move time.

I haven’t used Easel, is it smart enough to optimize router travel?


#27

Easel lets you set the cut order by changing the order ‘front’ to ‘back’. The edit menu will let you ‘select by cut type’ so it’s easy to work with just the pocket cuts (they call them ‘fill’).


#28

Yes! Makes total sense, but brings up a second question: Why don’t I also have to do this in MakerCam? The assembly guide instructions for the Maslow don’t say anything about setting inside vs. outside cuts for the sled. So how does MakerCAM know how to do it correctly from the SVG?


#29

Well good catch then. Unless it is already set to be an inside or outside path cut. Cutting on the inside will get rid of all inside your measurement accounting for our bit width. Cutting outside will get rid of all including your line plus the bit width. Cutting on line will get rid of line and radius of the bit.
In Makercam like Easel You set the parameters in the path settings, inside, outside, on path, or pocket/fill. Set the depth. If it’s through the piece or only part way. You still have to set and create code in makercam.


#30

looks like this turned into a thread for easel. i looked at it and may use it in the future, but has anyone figured out why makercam doesn’t add tabs consistently? ive gotten it to work on some test cuts but im still trying to build the frame and cant get the tabs on makercam.

also, has anyone noticed that the inside cuts, such as the numbers on the frame pieces, dont get calculated sometimes as well? any suggestions would help with one of numerous frustrating things with this side project.


#31

What specific issue are you having with tabs? Are they not showing up, coming up too small, too many, too few?


#32

They are not showing up. I had to step away because I was getting frustrated. I’m gonna try again today. I have been able to get makercam to put them in before on other svg files I’ve made. It’s prolly a simple thing I’m overlooking or not entering in correctly.


#33

Sometimes that happens to me. I normally unselect all and the reselect the toolpath line. Also, make sure the spacing is appropriate. If something has a perimeter of 15 inches and you tell it to put tabs in every 20 inches, I don’t think you’ll get any. Also, if the scale is wrong (i.e., you think something is 18x18 but is actually 2x2 in makercam). Their aren’t rulers in makercam, unfortunately.


#34

Thanks for the suggestions. After messing around with it more, I have found a way to get the tabs added in makercam consistently, at least with the svg files I’m working with.

So spacing wasn’t the issue. I tried setting the tabs at different distances, different heights, and different widths, still not being seeing them added on the cut path. I went back to each tool path and messed around with those values and found that if I changed the target depth from -1 to -1.00, then I was able to add the tabs in. I don’t know if that was the fix or if that made the difference. I also work on different computers with different operating systems, so going back and forth might be causing issues.

the take away is that if makercam is not adding tabs, it isn’t that the function is broken or anything. It’s not adding tabs because for whatever values I have been putting in, the calculations don’t add up somehow. Just gotta play around with it, as frustrating as it can be. Oh and your suggestion of selecting one toolpath at a time to add tabs helped. I haven’t figured out how to add tabs to multiple toolpaths. Thanks!


#35

I know this is an older thread but I never saw a simple help that I learned. @czimm74 seemed to leave the tabs at .25 x .25… This width will be consumed by the diameter of the end mill if it is .25 because this function in maker cam cuts on the center of the designated width leaving half of your bit diameter or .125 on either side cut away. .125 + .125= .25 TAB GONE. You must call it .5 in MakerCAM if you desire a quarter inch tab.
ALSO: @AM3GA is right. I believe adding the .00 after the round value makes a positive difference.


#36

My lessons learned/ troubleshooting tips so far:

  • Ensure the tabs are more than twice as wide as the cutting tool (I never had a problem with this because I saw the tip before my first go with MakerCAM).

  • Delete all (aka: reload page) and draw, create a profile, and Tab something simple .
    If that works, then trying again with the same SVG as before might work now.

  • Ensure the input values are entered to 2 significant digits as @AM3GA described - that fixed an issue for me once.

  • Try spacing out the tabs; I fixed an extended fight with MakerCAM using this one… 5" spacing failed, but 7" created 3 nice tabs and 6" created another 4, then I just deleted some and slid them around to get the 5" spacing.

  • Toggle the two check-boxen in the top-right corner; sometimes they make the Tabs appear.

  • @madgrizzle says unselecting all and the reselecting the toolpath line might make the tabs appear.

  • simply start over and repeat the steps; I’ve had some success doing the exact same thing on my 4th or 5th try (global variable in MakerCAD ?).

  • I’ve not tried this yet, but have read that MakerCAD is much more consistent if it is copied to your computer and run locally rather than online.

  • If you are coming from an SVG created by LibreCAD, the scale will be wrong. An SVG created as 2 feet in LibreCAD will retain the correct size when viewed in FreeCAD or InkScape, but MakerCAD opens it as several hundred feet. Re-saving it with the other CAD or Drawing software did not fix it - I needed to scale it to 0.032 original size in LibreCAD, then export the tiny SVG to get the correct size in MakerCAM,

  • I suspect you could check the scale of your svg in MakerCAM by counting the grid-squares it shows in both cm and inches and doing some math… but I’ve not yet figured out how it picks the grid size… that’s another post.


#37

not good with computers, can you explain how to copy makercam to your computer.
thank you.


#38

Makercam works fine. Set the tab length at 0.5-0.75 and be sure to set the tab height you want plus any over run you have in your cut values. IOW if your substrate is 0.5 but your cut depth is -0.55 and your want the tab height of 0.125, you need to set your tab height in makercam at 0.130.


#39

Go to the makercam.com website. In your web browsers menu select file, then save page as. Save the file to a folder you create on you hard drive.

After you save it, you should see these files in the folder you created.

To access your downloaded makercam, in your web browser, select file>Open file, and navigate to the folder you created to select the file: (www.makercam.com.html). That should be it, you may need to tell your browser to allow flash to run (if so a dialogue should appear when you open the file).


#40

Thank you, I’ll give it a try