MakerCAM Frustrations

Without getting into the ramifications of using a Flash (a bug and security hole infested source of bouncing dancing ads) based product these days (it wasn’t even installed in my copy of Firefox) I’m unable to get Makercam to function. It worked once but zooming scrambled (the sled turned into a barely visible dot) so I restarted the browser. Now I get the grid, but none of the menu options (like File), checkboxes, etc. respond.

I found a spare afternoon to work on the Maslow, and was going to cut the round sled, but can’t get this to work. I’m not all that interested in installing flash in the browser collection until finding something that works.

It’s an i5-5200U notebook, Win10 IP 16257, Firefox 56.0b3, the one I use for all my 3DP and CNC work, Flash is installed as activate to enable, which it was for, further proof that the grid, etc. appears. Right clicking the window gets the usual flash stuff, too.

On a positve note, I did get the mini-cyclone and little shopvac connected to the router.

Some progress; switched to Chrome, and it’s now working. Made a brief sidetrack first to jscut, then read it’s docs which said to use Laserweb (which I’ve been following for my K40 controller upgrade project). Poorly documented (hate time wasting video tutorials, even worse with loud unnecessary background music), and metric bigots. Did the whole sled, but decided it wasn’t worth trying to cut so tried MakerCAM with chrome.

Issues. There doesn’t seem to be any way to change the defaults (CAM/batch modify looked hopeful, but didn’t stick), so every operation required modifying essentially all parameters. From one of the early bit recommendations I bought a couple freud 3/16 carbide bits, Not the apparently unalterable default. Trying to cut and pocket each screwhole individually rather than cut all then pocket all. No apparent way to do that without 16 repeats of change all the defaults. Probably going to waste more time doing each hole/pocket together than just going in circles. Did I mention that tabbing through fields does not select the whole field, so changing them is even more annoying. Having an odd issue where operations seem to get randomly moved and cuts appear off to the side. Delete and redo and they’re where their supposed to be.

I know Ed Ford (saw him mentioned as reviving MakerCAM) from his ShakeOKO 1/Makerslide days where we shared Paul Jones spindles; he must have an awful lot of patience to have kept using MC.

Bout time to bite the bullet and learn how to use Fusion360 and not dink around in the cheap seats. Will give cutting a shot when I get all these toolpaths in.

I typically save gcode on something other than “C”, but ground control gets to the root on C (this is under Windows) and doesn’t appear to be able to select another drive. Is there a way to supply a path (like D:\gcode\ , for example)?

Have also had issues with makercam, but successes as well. Recently used jscut with some success. Agreed that individual settings in makercam a pita. Many fusion 360 fans on this forum, have not tried it myself.

1 Like

I second your choice to go with Fusion 360. I’m not really comfortable in it yet, but it does get the job done. Let me know if you need any video tutorials and I’ll point you in the right direction.


Thanks! Cut it, came out 17 1/4 x around 24. Back to recalibration, but I might make a sled with a compass and sabersaw first.

This is with the latest firmware and GC, so it should be pretty solid on the next recalibration pass. I’m losing the shop space to the floor breaker/removers (it’s badly broken up from frost heaves and bad 1920’s concrete) in a few days so the Maslow’s going to get hung from the wall while they and the contractor are working.

Try editing the file path in the Settings window.

Keep in mind that Makercam was written in 2010, when Flash was still very much the default for this type of UI work in a browser. It hasn’t been touched in some time and I don’t expect it to be.

Be prepared for browser/OS technology to leave Flash (and by extension, Makercam) behind… keeping an old workstation around is an option (or a VM) or find a new tool set to avoid frustrations.

Exactly my point…

Just wanted to whip out some quick gcode to cut a new sled, not an all afternoon frustration fest. I spent many hours with the Zenbot Mini before moving to 3D printers about 5 years ago. Between lack of use, and things moving on, all those skills withered away. What was easy is no longer, and the lack of info (or bad search-fu) didn’t help.

Did get MakerCAM kinda whipped into shape, make the screw holes and pocketed them OK, if a bit too deep. Missed one pocket, couldn’t figure out how to reorder the paths so it ended up at the end. Cut considerably faster than the gear, although the pockets did a full retract and reposition which might have been from playing with rough/final cut. Mini shop vac which worked great in closed loop blow and suck in the ZB enclosure didn’t have enough grunt for the Ridgid. Cyclone caught the dust that didn’t escape at the router.

New firmware and GC seem to be working much better, wonder if the way-off Y was related to the old firmware bug.

A nail, string, pencil, and saber saw is the new approach. Maybe a printer and glue stick thrown in to get the holes right. Save the recalibration for the NoCAM sled. Even negative results are progress :slight_smile:

1 Like

take a look at onshape (with kiri:moto to create the g-code) as well as

Went to print the sled on paper to get the hole spacing right. sled.svg (and only sled.svg) will not display in the latest Inkscape (0.92.2). It’ll display in Chrome but the scaling is off and it only prints the two leftmost pages. MakerCAM and jscut both like it. In Inkscape there’s something there, with the right objects, but no amount of fiddling with stroke and color seems to make it become visible and printable. Interestingly, the sled svg source is very small, must be all circles.

The other svg files display OK, but it’s the sled I want to print on paper and make the old-school way before running through the complete calibration process again. I spent the morning mounting arms to the wall and lifting the Maslow up onto them since the floor is about to undergo it’s sledgehammer transformation (old barn, besides gutters etc it’s badly cracked and heaved, and the few bigger pieces break apart easily with a few good whacks) followed by a wood (like product) floor on risers. Seemed like a good time to cut out a new sled, but the force just is not with me. Swamp rats again.


There’s definitely something going on with sled.svg. I downloaded Inkscape 0.91 portable, and it won’t render the sled either, so it’s not something related to 0.92.2.

Doesn’t display in FreeCAD, or in the online svg-edit. It’s definitely busted. Wonder how it was created? Odd how MakerCAM, jscut, and chrome see it, but none of the svg editors I found. Wonder what happens if I open it in Chrome and then try saving it. NG, same results. Download from github again? NG, same results.

Guess there’s no way to print sled.svg on paper. Doubt that Bar’s implemented a strange copy protect but there’s an odd problem with the file.

Try to open that svg in inkscape again, hit Ctrl+A on the keyboard then Zoom->zoom to selection.

Could it be a scaling issue?

Tried that, no joy, plus selecting individual paths and zooming, changing the stroke width and color, converting to Black and White, and pretty much everything in the keys that looked like it might help. Took a quick look at the XML editor and didn’t see anything strange, although I didn’t dig out the svg spec and compare.

SVG’s made in illustrator are in a different DPI then Inkscape.
I can’t remember exactly where that setting is hidden in Inkscape but I managed to change it for another project several months ago.

I beleive Illustrator’s default is 72DPI and Inkscape uses 90DPI or 92DPI as default.

It’s stuff like this that messes with many peoples minds. And keep in mind that there are also differences between Apple and Windows that could complicate even more.

And for me there is on top of that the Imperial / Metric headache.
In a way I hope that Maslow will get a firmware option to work in metric and have a hardware switch to change this mode so that you can always cut any gcode you throw at it without having to mess around to convert files that where 100% accurate in metric to get all kinds of inaccuracy crap once converted to imperial (or the other way around)

Lets not make war over Imperial Metric stuff, just make 2 modes so that all people can use it.
I know, easier said than done but this will make it a real universal tool. When only limited to one option then there will be always a discussion about the format.

O my, I went a bit off topic there. But this is very much related…

But it does - I use both flavors all the time. If I remember correctly, you can use the arrow and move the z in either system, regardless of the gcode file. The ‘mm’/‘inches’ button is a toggle.
For translating a file between the two, I’ve noticed that Easel will import gcode, and I’ve switched designs back and forth using it.
Am I missing something?

Hmm if you use Easel to translate files then there is only one format that you send to the machine or not?

I never have worked with easel, Where can I find it? Is easel cross platform or Apple Windows Linux only?
In the past i have translated lasercut files from metric to imperial and that was always a big mess. Just having a machine that can do both would make all the difference.

the maslow firmware supports both metric and imperial, it converts imperial
g-code to metric that it uses internally

I haven’t ever run into a machine that didn’t do both, there is a gcode that
sets what system you are using.

@dlang Ok that clarifies a lot.
Thank you.

@blurfl I just found Easel, turns out to be an online tool. If i cannot use it offline then it will not really be an option for me. Ultimately I would like to be able to set up a machine in the wild somewhere and work offline. I’m far from there yet. :slight_smile: But I will keep that goal in mind.

1 Like