Maslow Home Maslow Community Garden Newsletter

Trouble calibrating Sled won't stop and runs off workspace

Hi there, everything was going well, until i tried to set the scale settings because my measurements were off 1/4". when I did that my machine went nuts. the sled ran off the board and ripped the nail completely out of the top beam. when I reattached everything. my sled will home in the Y direction but when I go to set the X direction after I “homed” everything and try to jog the sled the X direction goes and goes and does not stop… I have to unplug the unit to keep it from crashing. Also I notice my Scaling on my X direction says 25? There is nothing I can do to change that number. even when I put in expected distance and actual distance the same. anyone know whats going on? Thanks. Oh I’m using Makerverse. with the M2

UPDATE So I looked at the Gcode and it had $85=25. I changed that to $85=0. things are working better. Before I begin to try and scale again could anyone tell me from what point on the chain/sprocket I should be measuring the chain from. Even post/ web comment I see people are saying different things. Som say to measure from center of axis on motor, others are saying 8:00 o’clock and 4:00 position on the end of the actual teeth on the gear, and on and on. what is the real answer? Thanks

Glad I came across this post. Machine was running fine last couple uses, and all sudden today I fired up the machine, went to jog the sled and wouldn’t stop unless I set Home position to where it was at. I narrowed it down to program issue, but wasn’t sure what was off, and now after reading your post I do recall the Gcode $85 not being set to 0.
Your chain measurement will vary depending on setup. Originally I went with under the sprocket setup per included instructions with spring joining the two chains in middle, but I had issues getting things calibrated right. I read about others using counter weights, so I switched to the ‘over the sprocket’ with counter weight, which has worked much better, calibrated easily and have cuts and engravings accurate within 1/16". With one tooth on the motor sprockets at 12 o’clock, measure from sled to the 12 o’clock position. Distance between motors should be from outside to outside of sprockets. I did all this and everything worked out as should. After that, I used a v-bit, manually lowered it just enough to make a mark at 0, jogged it 10mm on the x axis, then 10mm on y axis and measured them. If different than your command enter that into Makerverse Calibration and recheck. Same with Z axis, except 0 to backboard, raise 5-10mm and check measurement and enter difference if any. Should be good to go after that. I used the attachment below (hopefully uploads properly) from Github with all the initial GRBL specs for Maslow and was helpful in setting it up properly.
GRBL Specs for Maslow.pdf (1.1 MB)

$85 is the x correction factor… should be closer to 1?