Maslow Home Maslow Community Garden Newsletter

Turned on machine / it promptly went straight up jammed itself and destroyed frame

I very frustrated, just finished assembling M2 machine, had an unbelievably hard time with internet connection modem problems that prevented Makerverse from launching, had to go buy new modem at Comcast. That solved one problem. The wifi on Windows 10 computer I am using for this M2 machine wasn’t connecting to wifi very well so went and bought a 50’ ethernet cord and direct connected to modem, that solved that problem. Makerverse STILL wasn’t launching so frustratedly spent 2 hours trying to undo update 1.13 back to 1.12 once I figured out the new update was the problem…FINALLY was able to turn on the M2 machine and the set-up menus are now different than what the Makermade videos show, so that was confusing…got the machine turned on and then the M2 sled went straight up into my unistrut cross bar and destroyed the blue steel sled frame where it connects to the chains.

extremely discouraged, frankly I’m very angry. This is a stock 4’x8’ machine configuration machine with 10’ crossbar set 18" above the work area corners

PROBLEMS I WANT TO RESOLVE:

#1: the half circle blue steel frame on sled where the chain rollers attach is mangled and destroyed, how do I get replacement frame?

#2: what caused the machine to go insane and jam itself into the crossbar and destroy itself? Previously, I had successfully calibrated machine but because of unbelievable problems today ended up “un-installing” makerverse and re-installing…I am guessing the default settings when I re-installed makerverse are something other than stock configuration of chains UNDER AROUND & OVER the sprocket to the sled…guys, there needs to be a setup process that matches a video and pdf assembly guide PLEASE…there is always differences between what I see on the screen to what I see on the videos and in assembly guide…and the 1.13 update made makerverse not launch so there’s that problem.

#3: PLEASE PLEASE PLEASE PLEASE where is the EMERGENCY STOP for the M2 sled? I could not stop the sled from jamming itself into the crossbar and destroying itself…all motor and cable connections previously worked fine so I doubt anything came loose. But WHERE & HOW do you turn off the sled in an emergency???

Unbelievably discouraged and upset. I have faithfully followed directions every step of the way buying and building this but this latest 1.13 update now suddenly the makerverse screen looks different than before doesn’t match any videos or assembly guide I have that came with this M2

Don’t lose heart - It can be insanely frustrating, but the end results are worth it.
I feel your pain, having just gone through a similar process myself.
For what it’s worth:
#1 - contact MakerMade.com, should carry the spare parts you need. Or you may be able to dismantle and straighten the ring yourself - pay particular attention to keeping the ‘inside edge’ nice and smooth so the rollers run true.
#2 - if you had some command “stored”, when the power comes on, it will try and execute it. Watch out for the “dimension” currently selected in the Makerverse machine control menu before you click a move - the Z Axis is particularly dangerous for this, with large values from X and Y Axes that will exceed the physical possibilities.
Turning on Software Limits in the Settings Menu can help, but isn’t a perfect solution, especially for new machines.
#3 - There isn’t any Emergency Stop built in - at the least, if things wild, Pull The Plug. Or better, build your own ES into the extension lead that powers the Blue Box. You might want to consider your router as well, but that’s not so critical for runaway controllers - the router will stop where it is, and spin until you get to it.

That’s my 5 cents worth, and there are much more qualified Forum Members than me!

1 Like

I already emailed makermade to order replacement blue steel frame for the sled…no response as yet. that isn’t making me feel any better to be honest.

The blue steel frame work is destroyed, mangled badly, it pulled the screws out of the sled so now I have to fill all those stripped out holes.

I did not have any command stored when I turned on machine, it was a fresh re-installation of makerverse after a few hours of extremely frustrating problems where makerverse wouldn’t launch because of internet connectivity issues and 1.13 software update problems…only when I replaced my modem, hard connected the computer to the modem, and manually un-installed makerverse…we even had to manually find the 1.13 software update patch and delete it from computer, only then were we able to launch makerverse…of course launching makerverse was when the sled went insane and drove itself directly upward into the unistrut crossbeam and mangled the blue steel frame tearing out the screws, causing unbelievable damage.

All I was trying to do was verify calibration and do a test run with the router off…out of the box this software is troublesome and my biggest complaint is that the setup of the software leaves out all of the important details of getting started…for instance, how was I supposed to know that I was having internet connectivity problems which were creating OTHER software problems…why do the makermade videos on youtube show different makerverse setup screens with different screen layouts than what I am seeing? And why did that 1.13 update cause makerverse not to function anymore?

You can tell I am deeply discouraged and frustrated, I spent an unbelievable amount of money on all of this and the documentation to get it up and running is lacking in many ways…the lack of emergency sled shutdown is a major problem in my opinion…I could have prevented the damage had their been an emergency shut down

Sorry man. That stinks. There are lots of stories of this happening to folks. It has to be super frustrating and expensive and time consuming. I feel for you. Makermade is pretty good about making it right, so get in touch with them and they can help you out with how to get functional again.

In Makerverse, the first thing is to always set home/reset chains (depending on the version) before attempting any movement on any axis the very first power up after programming the system or clearing the system memory. You should only need to do that one time. Keep your controller accessible and yank the power cable to the controller and the motors will stop. We could probably figure out a power stop button pigtail that could be put between the power supply and the controller. I wired my system with light switches to dedicated outlets on the frame to turn off the router, the vacuum and the electronics should anything go sideways. You might consider that.

The software is continually under development and the kit supplier you purchased from doesn’t make the software, so what they give you may not be the latest and the screens change and improve with successive versions. This is an open source project, so the documentation gets done by whoever volunteers to do it. I didn’t like what I found and spent a great deal of time over the last year trying to update it, but it is time for a refresh for those who have the time.

1 Like

For my own saga, I couldn’t get the supplied USB cable to work at all - I don’t know whether it was its length (which is getting out there for USB…), or just a crook cable. MakerMade quickly replaced it when I asked, but I’ve been running a shorter version I hacked up with success.
When I tried the Precision Calibration (drilling the little holes in the corners), the steppers happily tore the nails that hold the ends of the chains completely out of the frame! Spectacular failure with bits and springs flying/falling everywhere! And a complete surprise because I was watching the sled.
I checked my measurements twice (all spec) and the geometry is impossible. So now I’ve moved the nails closer to the steppers by 200mm - dead reckoning thinks that will be OK, but others should be warned when doing that calibration (or maybe my chains are “short” - I didn’t measure them!)
Hang in there, @bikeshelters.org - I reckon you’ve earned a medal for perseverance!

I really appreciate the encouraging words from all of you. I have still not heard back about ordering replacement blue steel frame for the M2 sled.

I am still frustrated that the included PDF assembly instructions are for makerverse 1.06 but I have 1.12 on the included thumb drive and the videos online nothing matches. I am not familiar with Github or Easel or anyother programs so much of the instructions assume a baseline of knowledge that I lack.

the setup instructions all skip crucial basic first steps…I am happy to contribute to the community if I could get past these first steps and get the machine up and running. I am frustrated that even getting to STEP #1 seems so impossible because of the profound lack of documentation and instructions that match what I purchased / assembled.

Have you cruised the forum wiki how-to step by step instructions for makerverse? I wrote several and even did a few videos on how to run it. That may help. GitHub took a little time to figure out, but it is mostly intuitive and very useful. Keep at it.

When doing precision calibration, space the hole several inches from the sides rather than one inch, but if you try to cut in the lower corners, the chain end placement will matter.

thank you for the encouragement, I really mean that.

Here is a chance to ask a question:

is Github the same as makerverse? Or is it a program that helps makerverse function? Could you define what Github is and what it’s purpose is? that would help immensely

GitHub is a ‘forum’ where developers can host software / firmware.
“Millions of developers and companies build, ship, and maintain their software on GitHub…” says the webpage.
Makerverse has a page on GItHub that it uses for its firmware.
It seems that everything I own, now has firmware that needs regularly updating from GitHub - of course, the good news is, it’s free! And you get new capabilities/enhancements for your machine without having to buy a new one.

Think of it like PlayStore or iTunes for your mobile, except free.

github is a company that hosts source code for many projects/companies using the
git version control system and protocols.

it’s one of a handful of places that community based projects can host the
source code for everyone to use and work with.

Bar created the Maslow and the software to run it, and started hosting it on
github. Makerverse took a copy of the code (‘forked the code’ on github) and
modified it to work with their variation of the Maslow machine.

does this help?

David Lang

thank you both, so GITHUB is merely the location on the internet where I can get the various makerverse software versions and commentary about using / installing them. Additionally, GITHUB is a library for many other softwares. Is this correct? Do I understand?

1 Like

exactly.

1 Like

this is very helpful and I appreciate all of you explaining this.

May I ask another question?

When I first open makerverse, it asks if I want to “connect to a new machine”…does “new” mean an actual NEW machine that does not yet exist OR does it mean simply “connect to a machine” ? This may seem like a dumb question but it has me confused…before my M2 sled self destruct yesterday, I had previously successfully accomplished setup and basic calibration but then I had a long term work project that took me away for 2 months and when I returned, I had forgotten which icon on the left side menu was the machine I had setup and calibrated but then all the sudden I had problems launching makerverse which I determined was bad internet connectivity from a poorly operating Comcast modem router (which I replaced yesterday prior to the M2 sled self destruct)…but after I resolved the bad internet connectivity problem (which was VERY frustrating and time consuming) then I still could not get makerverse to open up…I had updated makerverse the day before to version 1.13 because of the pop up warnings but now I was unable to launch makerverse…so…then I had to uninstall and re-install makerverse from the thumbdrive that came with the M2 machine which was version 1.12…THEN, I had to manually delete the 1.13 update since the makerverse STILL wouldn’t open up…after all this I was finally able to launch makerverse 1.12 but because it had been 2 months since I had worked with the software, I had forgotten what everything looked like, the instructions that came on thumbdrive are for makerverse 1.06 though and they do not appear the same as the 1.12 software that is on the thumbdrive…then I got machine to turn on and I got excited and tried to follow instructions but they didn’t match and then got the sled to move and next thing I knew it had rammed itself into the top unistrut crossbeam and destroyed mangled the blue steel M2 sled frame :frowning:

for most of you the various versions of software instructions having variations is no big deal but for me it was massively confusing and caused panic and frustration.

I just want to install a functional version of software to make this machine work, I don’t care what version it is! But clearly I need some sort of step by step instructions that match the software that I can just follow. So my question is what version of makerverse has step by step instructions that I can follow that shows the correct baud rate, the correct settings at the beginning set up screens, the correct COM Port #, everything…I literally need everything spelled out and defined if possible

I could care less if I use makerverse or groundcontrol or something else, I just want something that works and has step by step instructions…I am using a Windows 10 computer

thank you in advance if someone has an answer

Makerverse was actually forked from cncjs and customized to run on the newer Due controller found in the M2. Makerverse was later made compatible with the mega controllers that Bar pioneered and can be used instead of groundcontrol/webcontrol.

1 Like

I concur. I also am a noob to all this also and I share your frustration. I’ve had my sled do exactly as you describe twice. Both times, I had to rebuild the sled by replacing those little screws that hold the ring supports with flat head 6-32 machine screws from the bottom after I drilled out the holes through the sled. I contacted makermade asking if I could buy a new ring through their webpage contact form and never got a reply. My machine has sat untouched for 21 months because I am so frustrated. I have never turned on the router, because I have never gotten through the calibration phase of setup without the sled running out of control straight up into the crossbar. A lot of time and money(Canadian dollars) spent on nothing I can use.

A ring is not the only way to make the maslow work. you can also make it work
with linkages. There are two designs that we have worked out, one is referred to
as a 45 degree approach and is something you could make yourself with access to
a drill press (or very careful manual work). The other is referred to as a top
pantograph kit and requies getting it laser cut in metal (I have made a few of
these kits and have them available to buy, $40 in the US including shipping)

David Lang

1 Like

I downloaded 1.13 software and have successfully rebuilt the damaged sled and have successfully connected the machine to my windows 10 computer but am stuck at this very first screen unsure how to proceed. I’m going through the windows maker verse 1.13 software setup and this very first screen is asking for numeric values. I do not see this screen anywhere on the video you link I received from Joel at makermade (thank you Joel !) gave me Makerverse Calibration - YouTube

Could you tell me what I’m supposed to input on this first screen? The video begins AFTER this screen and in the video the user is installing software for Raspberry Pi machine…I am using Windows 10 computer FYI

Thank you in advance, I’m sure that the November 2020 setup video that was suggested by Joel at makermade will take over and be useful to me after I get past this first screen :slight_smile:

and can someone advise if the following will be alright?

I located the chain endpoints to 6" inward + 2" downward from center of motor sprockets

My top bar crossbeam is 10’ / 120" unistrut and center-to-center distance between motor sprockets is 119.75" (I tried to get it right at 120" this was as close as I could get)

I have the 4’x8’ melamine waste board (actually 49" x 97") that is 3/4" thick with 12" surrounding skirt so inputting the distance between center of motor sprockets and upper corners of work surface / waste board is really a moot point although I have marked the edges in red marker where 18" inward + 18" downward from center of motor sprockets. I have marked the waste board center point with red dot on the center line 18" below chain motor sprocket center line + 24" to middle of waste board

I’ve had many challenges in getting this M2 CNC assembled and get up and running so looking for some input from those of you more experienced than me on these above noted items as I proceed forward through calibration and setup

Thank you in advance!

UPDATE: Joel at Makermade told me that data input screen shown above showing X axis and Y axis and various numbers was nothing I needed to do anything with only to give machine a name and choose background color and move past that screen altogether…so I followed his advice and moved onward connecting to COM 4 port at 34600 baud rate using default M2 sled dimensions and got the machine to “turn on” and communicate with makerverse and was able to get into the calibration screens, removed sled and connected chains together to begin chain calibration measurement, so I made it that far…but then machine + computer suddenly stopped responding to chain movement commands and I checked and COM 4 port was no longer visible or connected…so I am dead in the water again…all cables seem snug and properly connected…ay yay yay…not sure what problem is now

COM 4 has disappeared from my choice of options and now I cannot get any of the motors to move in the calibration menus. I have checked ALL motor wire connections and they seem snug. What happened? More importantly, how do I get back on track and get COM 4 to show up?

I think part of the reason you aren’t really getting the help here that you need is that we’re not all that experienced with that we’re not all that experienced with the Maker Made software. MakeMade built their own software which isn’t really based on ours so many of us haven’t actually used it.

MakerMade participates in these forums sometimes, but then we won’t see them for a while. Have you tried their facebook group or contacting them directly?