Turned on machine / it promptly went straight up jammed itself and destroyed frame

thank you, do you suggest I move to another USB connection on this Windows computer until I get a match up to a working port

we calibrated the M2 machine using another laptop and successfully calibrated the machine. In the process, I learned that the “soft limit” error messages were what causes the Makerverse calibration process to crash / stall out. I didn’t know that previously! Sooooo, that means that each time the calibration menus crash / stall out I need to fully exit the Makerverse calibration menus and “X” out of the soft limit error messages THEN go back into Makerverse calibration menus and pick up where I left off…I am thinking somebody out there will be very happy I am writing this.

Also, Joel at Makermade said to click the red CLOSE session button on Makerverse BEFORE “X” -ing out of Makerverse which matches what othere here have said, this is what was causing the Windows 10 operating system to not display COM4 port when I logged back into the Makerverse software which someone here mentioned. Again, this will be very helpful to somebody I am guessing

Lastly, because we accomplished calibration of the M2 machine using another Windows 10 laptop, I have not yet re-connected the Windows 10 desktop computer I was using previously, I will do this tomorrow and report back my experiences. I expect COM port connection problems but because the machine is now calibrated and ready to have a file loaded, I believe once I get connected to a COM port that I should be able to do a test program. I have never used Easel software before so i am watching all those videos this evening so I can install it tomorrow and run a simple test project with router turned OFF and see if the M2 sled goes through the motions without destroying itself.

I discovered through all of this that it was the calibration process not understanding where “HOME” was located was the reason the sled ran up into the chains and upper crossbar and destroyed itself…the calibration process is massively confusing for first timers because the icons and words used on Makerverse software do not always make sense but I expect there will be better newer videos of setting up these newer M2 machines on Windows 10 systems

1 Like

Easel software does not want to connect to the M2 Machine…I entered in default values in the machine set up and the M2 control board turns on (I hear the high pitched whine although it is intermitten OFF / ON) but the Easel software pop up message says “connecting” and that message never goes away. I tell ya…it is so many mysterious and downright frustrating obstacles in getting this M2 CNC machine up and running :frowning:

I will search this forum for Easel connectivity and set up issues

I am trying to run a test file with router turned OFF and I cannot seem to figure that out with the instructions included on thumbdrive. what is the process?

The Maslow and M2 do not connect directly to the Easel software. Easel was created by the company Inventables which makes the X-Carve line of CNC machines, and will only connect to that line for direct control for cutting projects. They have created a Maslow Post Processor (which turns your project and how you have set up your cuts into GCode the Maslow/M2 understands). I know there is a post on the forums here that does give specific instructions, but I want to say you go to the advance machine settings and select the option to download the GCode. From there, you open that GCode file in Makerverse and control and start the cut from there. MAKERVERSE is your control software, so which ever design and setup software you use (often called CAD/CAM software) you will always need that to create GCode files that you will load into Makerverse to tell the machine what it needs to do to cut out your design. I have very much simplified the process, but that is it in a nut shell. I know there are numerous posts on here on using Easel (and other software packages) to create GCode and start cutting.

I am thankful you took the time to write!

I am quickly learning that the M2 version CNC is extremely different than the previous versions and that none of the setup or software(s) and set up instructions carry over

what I am truly missing here is instructions for the M2 CNC machine. The included thumbdrive instructions that came with the M2 CNC kit are an older (much older) 1.06 version of Makerverse and the videos and written instructions do not match the latest 1.12 version of Makerverse. And this is my biggest problem. I am relying on watching the various Youtube Maslow and M2 videos but nothing matches up because everyone is either using a different computer (Apple or Raspberry Pi) or is using the older Maslow or Maslow upgrade kits which used Groundcontrol and Easel…the M2 as I am now understanding ONLY functions properly with Makerverse…

So here is my 1st question:

#1: where are the instructions for importing a drawing file into Makerverse so I can do a test run with router turned OFF?

#2: do I need to generate GCode using Easel software for EVERY project drawing file I want to cut out on the M2 CNC machine? Is that what I will need to use Easel software for?

#3: my lack of knowledge and experience shows greatly BUT I have overcome every obstacle to get to the point where machine is calibrated and ready for it’s test runs so I have faithfully read and followed all the instructions and advice from all of you and Joel at Makermade thus far (thank you!) and I understand the M2 is a new machine and that set up documentation and videos just aren’t created yet but will be. But what exactly does Makerverse do and not do in regards to the M2 machine? Do I need any other 3rd party software or is Makerverse enough to cut out vector format drawing files on the M2 CNC machine? I am having a tough time understanding what exactly the software is supposed to do. Could someone clarify? I know this entire thread will be very helpful to other people including myself which is why I ask :slight_smile:

I am very thankful for your response and everyone’s response! Thank you sincerely!

#1. I don’t know that there are instructions for that, just don’t turn on the router and make sure your bit won’t drag if the router is off. You could pull out the router and put in a marker instead…
#2 yes. maslow runs on gcode, so you have to generate gcode for it to move.
#3 you are getting there. Makerverse is a gcode sender program. it takes a gcode file and sends line by line to your maslow M2. If you want to make gcode, you need a CAM program that takes a drawing file and converts it to gcode. If you want to make a drawing, you need a drawing program that takes mouse input to make a drawing. There is a wiki entry call the maslow manual that attempts to explain this also, and provides a limited list of links for some of the various options.

#2 yes. maslow runs on gcode, so you have to generate gcode for it to move.”

so, the purpose of Easel software is merely and only to convert vector drawn file into G-Code / CNC machine tool cutting pathway instructions which is then downloaded and saved to my computer so that Makerverse can take over (upload that G-Code file into Makerverse) and help the Makermade M2 CNC machine to begin cutting the project?

yes, though it could be a metalmaslow cnc machine or an eastbay cnc machine or some contraption you built out of your own parts that runs a maslow controller as well. I think you get it. I generate gcode with estlcam.

@bikeshelters.org As @Orob has said, you are getting there! I will provide the following link:

The OP there was also very confused with all the software that was out there and what it did. It has a lot of good info for what CAM (Machining - assigning the toolpaths and how they will be cut to create the GCode) can be used, and what CAD (drawing and creating the vector drawings needed for CAM) programs are out there. From here, there are many options out there that you as the individual can use based on how simple and cost effective you want to be. You are not relegated to just Easel. It is a good place to start, but if you are using the free version, you will be very limited, and the Pro version can be costly (the last time I checked).

I have used EstlCAM (to create GCode) and InkScape (creating vector graphics), but I am currently trying out Carbide Create (which is very similar to Easel, but has a free version with much more capability than Easel does in their “free” version. In this aspect, it is really a personal decision and figure out what works best for you (and your wallet)!!

Thanks for asking all the questions, it took me a bit to figure it all out and what worked best for me and my Maslow, and I am still always looking to improve and find more efficient ways to do things. I got there, and you will too!!

= TRUTH!

The Makermade M2 CNC kit requires a baseline knowledge of many pieces of software and technology that (to be honest) are not articulated / spelled out specifically during the original purchase process. Even though I am crash course learning everything now and would have purchased the M2 Kit no matter what, I am somewhat discouraged that I was not aware that I needed to learn how to use Makerverse and Easel (or equivalent GCODE creating program). I could saved months of frustration had I known what software(s) I would be using so I could learn those softwares…the setup assembly guide that comes with M2 Kit was outdated and contained Makerverse 1.0.6 which does not look like 1.1.3 during setup and calibration so all of the Youtube videos, Forum instructions, and pictures + instructions in the thumbdrive PDF assembly guide do not match up which causes unbelievable frustration and confusion. I do not blame anyone for this but I can confidently say THIS is easily the biggest problem in setting this M2 machine up

Currently, I have learned how to upload my vector drawn logo into Easel and create a 3D appearance of what it and the tool path will look like

so that is progress! Now currently, I am trying to figure out how to upload / import this SVG GCODE file created by Easel into Makerverse and because there are no instructions or videos anywhere so I am struggling once again…how do I get this file into Makerverse so I can start the M2 machine (with router turned OFF) and see if the test run goes properly?

To be perfectly honest, I would have gladly paid another $1000 in the beginning to have all these confusing and complicated technology / software issues just dealt with and up and running. Building the M2 Kit and frame is EASY compared to getting the software and technology up and running…this is the achilles heel of this M2 kit, there are simply too many options of software and too many variations of people’s setups out there and a profound lack of written / video documentation on how to setup and calibrate + do first test cut…again, in hindsight, I would easily and gladly paid $1000 to skip all of these last 4 months of frustration and confusion and seeing my hard work destroy itself because the software wasn’t set up properly. If Makermade offered a $1000 option somehow to skip all this extremely difficult and hair pulling setup and calibration at least I for one would have purchased it…perhaps that $1000 option for software setup and calibration could be done through 3rd party vendor contractors such as people like some of you? either way, the software varieties and setup difficulties are the worst part of this whole adventure and may anyone who reads this strongly consider learning the Makerverse and Easel or similar software BEFORE they assemble their M2 Kit and better yet, perhaps prospective purchasers might consider hiring someone like some of you to be setup consultants to handle the software setup and calibration?

Anyhow, as I mentioned, I am now trying to get Makerverse to upload / import my Easel GCODE SVG file so i can do test run with router turned OFF and thus far I am not having success…are there videos that show this step of the process that I can refer to?

thank you sincerely to everyone here, greatly appreciated! I look forward to becoming a CONTRIBUTOR to new users once I reach baseline experience and competence with the M2

this will likely be VERY HELPFUL to other new users so I am posting it here —> once you successfully import / upload your vector drawing file into Easel software, the next critical step is to turn that drawing file into GCODE that makerverse will understand and be able to do something with… here is what I learned trial and error by watching a ton of videos (most of which did not show or explain this critical step)

in Easel software after you have successfully imported / uploaded your drawing file and clicked “SIMULATE” in lower right hand corner to show tool cutting path, the next CRITICAL step is to tell Easel to convert this drawing file into GCODE…now everyone says to do this but none of the forums I could find SHOW how this is actually done in Easel so here is the process which I think will help many others and save some hair pulling confusion and frustration —> click on the MACHINE menu tab at the top of Easel software and fill in the items as shown above THEN click “Advanced >>” in the lower right hand of this pop-up menu

This NEW pop-up menu appears with the option to “Export G-Code” as shown here and THIS is the step that nobody else has shown or detailed that I could find…clicking this creates a “.NC” file that Makerverse knows what to do with that can be imported and shown on the Makerverse screen…

These may be steps that are obvious to many of you but I could not find videos or pictorial documentation of this process…this video about Makerverse 1.0.3 did help but there were many areas that do not match up with what Makerverse 1.1.3 looks like Makerverse Intro Video - YouTube

Now, I am able to upload the GCODE file of my logo but I am stuck at the next step which is “why can’t I hit the Makerverse PLAY button” and have the M2 Machine start moving through test pattern? every step forward encounters more obstacles but I will keep posting progress…please if anyone has any comments feel free to reply below

I feel your frustration. I went through the same as I was not aware of the work-flow through all the various software packages. I go mine back in 2019 (I think, maybe 2019), and I am just getting to the point where I feel comfortable providing info to others here, and understand it is mostly what I have learned from reading a lot on this forum, as well as my own trial and error.

Unfortunately, I do not have or use Makerverse, so I can’t say how to get it to open your GCode and get your testing done. I just did a search on the YouTubes, and found this video: Makerverse 1.1.4 Beta Review - YouTube

I know you are using 1.1.3, and that is a review for 1.1.4, but from it I was able to derive that you 1st need to create a workspace (if you haven’t already), and then it seems as if you click on “Upload Program” at the top of that workspace and then go from there.?. Again, I don’t use it, so I am just guessing from what I saw in that video. I am going to tag @MakerMadeCNC here to see if they can provide you any help with the use of their software.

Stay strong…you’ll get there!

yes sir! And thank you for your generous kind responses!

I am committed to “getting there” but wow WOW the obstacles of understanding these software “work flows” is maddeningly frustrating and confusing. Again, I do not blame anyone for how absolutely difficult the process is for getting these M2 CNC machines up and running but it is my sincere hope that the step-by-step documentation greatly improves…way too many things are “assumed” in the existing documentation and worse yet, most if not all the existing step-by-step documentation is for outdated versions of software or for older machines like the original Maslow which use TOTALLY DIFFERENT software (like GroundControl which is not compatible with the new M2 CNC machine) so that creates unbelievable confusion and chaos…

If @Makermade is reading this particular forum, I strongly urge them to create a website page for the M2 CNC machine that is DEDICATED to software download links and written and video instructions SPECIFIC to the M2…I have had to learn the “hard way” that nearly all the videos and forum advice out there is for older Maslow CNC machines which use different software and have radically different setup and calibration processes…now I understand that creating step-by-step written and video documentation about set-up and calibration is extremely time consuming but this is where EVERYONE grows angry / discouraged / frustrated / gives up so it makes sense from a sales & marketing perspective that more M2 Kits will be sold if the reputation of the M2 Kit being “easy” to be assembled and get up and running with step-by-step documentation existed

I watched the Makerverse beta 1.1.4 video and it does not answer my question as to how to properly import GCODE file and be able to hit “PLAY” in Makerverse to get the M2 CNC sled to start moving (with router turned OFF since I have never operated this machine before)

now I am just getting frustrated and angry…I am trying to doublecheck Z axis calibration before proceeding to test run using the MakerMade M2 Z-Axis Calibration - YouTube video and right off the bat the Z axis went berserk and I kept hitting RESET RESET RESET on Makerverse but it did nothing and the Z axis unscrewed itself and I had to unplug the power supply to the M2 control board…that is ridiculous! Previously I had this running and behaving itself and how I go back to doublecheck calibration and it’s running wild again…not happy! I patiently tried to re-connect the Z axis belt to both sprockets and get the router re-installed but all this is not cool at all…I properly closed out of Makerverse according to Makermade Joel’s instructions and then “X” 'd out of Makerverse after that after turning off power to control board now I keep getting “soft limit error messages” and my Z axis won’t move at all…this is beyond ridiculous that it is one error after another one obstacle after another (rant rant rant I know but I am hoping others will learn from my experience, victories, defeats, trials, and tribulations in attempting M2 CNC setup using Makerverse 1.1.3)

why didn’t the RESET button work? Why didn’t the CLOSE button work? Why did I end up having to unplug the M2 control board power cord? I am starting to understand why some people install a big red STOP kill switch on their M2 CNC machines

deep breath…what do I need to do to get the Z axis moving so I can calibrate it according to the video? What on earth is causing all these errors and obstacles? Nobody else seems to have these insane obstacles one after another where sometimes the machine runs wild and destroys itself or nothing functions or responds to commands through Makerverse as advertised…very unhappy right now. what is the problem?

If I “CLOSE” out of calibration pop-up menu and then hit RESET and UNLOCK at top of Makerverse page I can then continue sometimes but not everytime…I just want to calibrate this machine and get to test run…why is that so difficult to get that milestone? The calibration process is insanely difficult and filled with errors and obstacles. I look forward to overcoming all of this!! Oh my word this is beyond frustrating!

As mentioned earlier, if Makermade or anyone offered a $1000 we will do your calibration then I would have paid it…this process is insanely confusing and hard to accomplish.

EDIT UPDATE: 2 Tankards uploaded a Youtube video of the newest 2021 M2 with blue steel Z axis router tower and he shows the newest Makermade M2 step-by-step instructions so this has been done for all those folks who buy the newest 2021 M2 CNC kit…I bought my M2 in early 2021 so actually it is a 2020 model with aluminum Z axis router tower which came with older version of instructions and Makerverse software. Good work Makermade! Bummer for me who bought one of the last 2020 models of M2 though because man I have had so many obstacles and problems especially with the older version Makerverse instructions that don’t match up with newest 1.1.3 version of Makerverse…anyhow, that’s that

I was able to overcome all the soft limit error messages in the Z axis calibration process and per 2 Tankards excellent Youtube video I went to Harbor Freight and bought a digital micrometer that reads in MM and inches and followed 2 Tankards excellent video and accomplished Z axis calibration…for those who have an M2 CNC from 2020 or 2021 do yourself a favor and watch ALL of 2 Tankards Youtube videos of measuring and calibration of the M2 and save yourself a lot of time and hassle:

just subscribe to this guy’s channel, he is on most of the weekly Makermade group zoom chats that are uploaded to Youtube as well and clearly he knows what he is talking about

…I next doublechecked chain calibration going through the steps and finished that…so now next up I will try to do first test run with router turned OFF

UPDATE: I was able to successfully create a GCODE version of the logo in Easel with randomly chosen cut depth of .25" and randomly chosen “cut within the lines” setting and I then followed the steps up above and exported the GCODE / “Untitled.NC” file to my Windows 10 computer and then was able to UPLOAD / IMPORT that .NC file into Makerverse successfully and hit the PLAY button…I have router OFF and I removed the router bit so sled is not dragging around the work surface…so now for first time ever, the M2 CNC Machine is going through it’s first “test run”

I do not have my workshop 4" dust collection system connected to the M2 sled obviously and I am not totally convinced my overhead wiring to M2 sled is going to be permanent but I will keep testing and see how it all functions…but below is picture and to be honest I feel an ENORMOUS sense of exhaustion to have reached this “first test run” milestone…so many obstacles I have had to endure and overcome but I made it to this milestone and I feel physically exhausted,I purchased this M2 kit back and the materials to build frame in April many months ago using my US Government $1400 stimulus check (thank you Uncle Sam)…frame has 3/4" MDF work surface and I used same material for a 12" surrounding skirt so I can run the sled to the edges of work surface and cut reliably without sled tipping over / binding up…this is NOT YET tested but I hope it works well and will report how it goes

I bumped the blue braided wiring harness that connects to Z Axis motor so that went berserk and unscrewed itself (these are not very reliable or solid motor cable connections @Makermade and if you offered some sort of higher grade screw on / screw off cable connection option I would gladly pay extra for that!) so after this first test dry run I will have to re-do Z-Axis calibration AGAIN after re-setting the belt and going through all of that…sigh, I have made great progress but these infuriating small obstacles continue. Other brand new users should be VERY AWARE to make sure their blue braided wiring harness connections are solidly connected to each X,Y,Z axis motor or you can expect gigantic problems…learn from my mistakes if you can :slight_smile:

I will re-build / re-install the Z-axis belt and sprockets and re-calibrate the Z-axis after this first test run and update progress then…I hope to do actual first test cut into 4mm coroplast (which is material I plan to be cutting / milling most often) before the end of this day is over and post a picture of how it comes out

UPDATE:

I have successfully calibrated, doublechecked, and re-calibrated X,Y,Z axis and am on my second test run with dust collection hoses connected (with router turned OFF / no router bit) and so far so good. and each time I encountered that sled was off less and less and returned to HOME at same point after a few calibrations…i did have to modify my cable management system at the sled because cables bound up at lower right hand corner (I may end up just relocating the power supply and M2 control board to BELOW the frame assembly so all the cords drag on ground but stay out of the way as sled moves around…I will see how testing goes and decide afterwards)

I opened up Easel and imported my logo and this time around I made it much larger 36" wide by 24" tall, set the cutting depth (guesstimated) and then exported the .NC / GCODE file to my Windows 10 computer…I successfully opened Makerverse but the machine didn’t “see” COM4 port so I had to restart my whole Windows 10 computer because this M2 CNC simply will not connect through any other COM port except 4 (why?? I don’t know?) but after that confusing delay / obstacle the Windows 10 computer restarted, I opened up Makerverse 1.1.3 and successfully imported the drawing file I just did in Easel and hit “PLAY” on Makerverse and everything seems to be running fine

1 Like

Congrats!! I’m glad you got it working! Happy Day! Now time to start getting it dirty!!

thank you sincerely, I am going to put some sheets of coroplast on the frame work surface here shortly and install the router bit and hit “PLAY” and report back

this has been a very very very difficult project to get up and running but I woke up today feeling as though I have reached a plateau milestone. I have had to calibrate so many times now that I am getting quick at it. I don’t think I measured and calibrated the chains with sprocket teeth in alignment because I am still “off” about a centimeter over the 4’ x 8’ work surface and the sled returns to HOME center but sometimes is “off” center about 1/2 to a full centimeter…so I think the problem was not making sure the X & Y motor sprockets were aligned with each other when I measured and calibrated chains…I will dig into that maybe later but it is time to get that first test cut achieved and see how it comes out

I attached a piece of coroplast to CNC frame work surface with screws and washers tightened flat and turned on machine but Makerverse cannot find COM4 port arrgggg! So I am fully restarting Windows 10 computer (again)…why do we have these COM port connection issues? Makerverse refuses to run on any other COM port except 4…why? I don’t know…ay yay yay…

I am already noticing that this small piece of coroplast causes the M2 sled to tilt and the router bit not to touch the coroplast…so I am attached another piece of coroplast of same thickness below the piece I want to test cut so the sled is level with router bit in contact…attached the second piece with packaging tape

Now I am trying to get Makerverse to connect to COM4 port of this Windows 10 computer