Calibration troubles

I’m getting a little frustrated and need any help the community can offer.

I can cut a almost perfect square in the middle and I move up 14 inches and cut the same square it is really bad.

I’m currently running GroundControl 1.0 as it sounds like there maybe issues with 1.02. I rebuilt my frame with Unistrut so I don’t think I have any issues with frame tweaking. I ran the calibration and all the numbers came out close to what I measure. I ran the test cut three times during calibration and it came out right on the money. I deleted my ini file and tried everything again and the same results. The chain movement is smooth and I don’t hear any chain slip.

For some reason I was having trouble attaching photos so I put a link to a Google Drive folder.

Attached are my GroundControl ini file, gcode file for square and the log file zipped up.

<a class=“attaclog.txt.tar.gz (76.0 KB)
hment” href="/uploads/maslowcnc/original/2X/a/a2b02b0e99d935c1b70516845f6d762af8cf50ff.ini">groundcontrol.ini (847 Bytes) (428 Bytes)

link to pictures and video of the frame and square cuts.

I find it interesting in the video that as the sled moves from right to left and finishes the top cut, it jogs up a little. I find that’s very odd and maybe telling (telling what, not sure… but telling…)

Regardless, if I understand triangular kinematics correctly, you can get pretty good cuts in the middle and be out of calibration. When you move away from the middle, it will start to go wonky.

I noticed the little jog too.

The calibration routine seemed to go fine. I’m not sure what’s going on.

try running the calibration test posted in the thread for

that branch also includes chain sag correction and there is a new calibration routine that is FAR more accurate.

It would be great if you could do the same tests that @bar is doing, so we can see the difference between his wood frame (that we now know has flex issues) and your unistrut frame

Thanks dlang,
I will give it a shot first thing tomorrow.


I figured it out, I was running at 40 inches/min in my G code and it turns out Maslow cannot move that fast and when cutting the left motor couldn’t keep up. I ran the same file at 25 inches/min and it cut fine.

At 40 inches/Minute Gcode setting, it actually moved 90 inches in 2 minutes and 20 seconds. The max speed is around 38 inches/Minute.

1 Like