Maslow Home Maslow Community Garden

Update Firmware Instructions


#1

Is there somewhere where it explains step by step on how to update firmware and Ground Control versions? Wiki?


#2

Yes!

I always just reference the assembly guide when I need that information:

http://www.maslowcnc.com/assemblyguide

But it links to wiki pages


#3

So updating is the same as installing it the first time? You don’t need to wipe anything clean? You just install the firmware again using the initial steps?

For ground control, do you need to delete the settings file in the user directory? I’m referring to windows portable version.


#4

Yes. I can see how this isn’t totally clear. Installing the new firmware will overwrite the old firmware, but it won’t overwrite your settings so the machine will still remember it’s position and no calibration is needed.

You do not need to delete the settings file, and in fact it’s really nice to have your settings preserved between updates. That way getting the new version won’t result in any loss of settings, it just adds the improvements of the new version.


#5

Great, that’s good to know. Thanks. In the case of the next update where there might be chain pitch changes, would a full recalibration be needed? How would users know that they need to do a full recal with a specific update?

Aside from the quick notes under each version on the download page, is there something that alerts users once upgraded that, “hey, there is a new feature that improves accuracy, do this to take advantage of it” or is it just on the user to stay up with each version and what it offers?


#6

If there is an update which requires a re-calibration to work we would post a notification that it needs to be done. If a re-calibration will improve accuracy but isn’t required we will mention it in the newsletter and release notes for that update.

We do often show a popup the first time a new update is installed which mentions improvements. For example 1.12 which comes out this week increases the maximum feed rate and a popup will tell you that the first time you launch it


#7

These happen every 2 weeks, correct? I will be counting the days for 1.13!

Thanks for your efforts here!


#8

Yep! Every other week we do a release. You can always grab the development version here:

If you don’t want to wait :grinning:

Edit: But it might not be stable


#9

Hi,

I seem to be having some weird behavior when trying to upgrade from version 1.11.
At some point I was having a problem with a motor not keeping up with the intended position (turned out to be defective) and I kept version 1.11 to avoid the " not keeping up…" messages.
Last week I tried to use version 1.15 and some problems occurred like GC not knowing the position and asking to measure the chains. I went back to version 1.11 as I was eager to cut parts and everything worked well again.

Today I tried version 1.16 and even weirder things happened:
I got the " … not keeping up…" error.
I adjusted the respective parameter to 100 to avoid the error.
I tried moving the sled 100 mm down and it kept going down and down without stopping. I had to disconnect the power to avoid damage.
I closed GC and opened again and it didn’t move but it had lost it’s references and was asking for chain measurement.
Now when I tried to align the sprockets , 1CCW, 1CW, 0,1 CCW, 0,1CW, 5CCW and 5CW buttons make the sprockets turn apparently a full turn. So it was impossible to make the chain measurements.

Back to 1.11 because again I was eager to cut parts, and everything works fine.

Can someone help me with this?
Is it possibly because I’m jumping too many versions or a specific version?
Is a full calibration needed?

Nevertheless I’m successfully cutting my first project and it’s looking good.
I’m very happy with the machine. :slight_smile:

By the way, where is one supposed to post the projects?


#10

Hmmmm this is a tricky one! My instinct is that we’re looking at a loose cable which would explain a lot of the behavior you are seeing, but the fact that going back to 1.11 fixes it seems like a software thing.

Are you updating both Ground Control and the firmware at the same time? A version mismatch could cause some strange behavior.

As for where to post projects I’ve got a more clear answer for that :grin:

http://maslowcommunitygarden.org/ if you want to share the files or here in the forums in the projects area https://forums.maslowcnc.com/c/projects to just share pictures


#11

Yes, I always double check.

I will try again next Saturday. The Maslow is in a garage away from my place. So I only go there on weekends, which makes it difficult to sort things out.

Any hints for troubleshooting are welcome. :slight_smile:


#12

I’m keeping my fingers crossed for a loose cable. The Actions -> Test Motors / Encoders function could help to track down that kind of issue, but if it’s only happening intermittently that still might not tell us what we need to know.


#13

Hi,

I made some tests today. This is not a loose cable. It’s clearly software and a very strange bug.

This is what I saw today with V1.16:

Arrow button to move up 100 mm moves down a distance different than 100 mm.
Arrow button to move down 100 mm moves down but not 100 mm.
Home button doesn’t work.
Pointers (red and white) never move synchronized.
5 mm on Z axis makes a movement on y axis (whatever distance).
After this home button makes a -y movement away from home.
Test motors works and all pass.

1CCW, 1CW, 0,1 CCW, 0,1CW, 5CCW and 5CW buttons always make a rotation of about the same angle. With these commands motors always turn ccw regardless of CCW,CW button.
Extend puts the motor running in the retract direction. Not the correct distance.
Retract works in the correct direction but not the correct distance.

Changing back to 1.11 everything is OK again. I just need to remeasure chain lengths.

I initially tested V1.16 but then tried also V1.12. Same weird stuff happens. So there must be some big change from 1.11 to 1.12 that is causing this behavior.

Didn’t anyone else report something similar?


#14

The white pointer is the expected movement calculated by GC from the gcodes, the red pointer is gets its location from the data sent by the encoders. I think I remember that your motors and sprockets are different from the stock ones, yes? It might be that the values in the settings file need to be checked.

Not sure whether you’re referring to v1.12 of the firmware or GC. In the firmware, v1.12 had these changes:

Merged #438 Added some debug output for motor steps a day ago
Merged #439 Added support for active low spindle automation. a day ago
Merged #434 Use pullups to check board version, use #defines for version 5 days ago
Merged #433 Test motors needs to be exempt from position error limit 6 days ago
Merged #432 Apply the system setting, get rid of the testing constant 8 days ago
Merged #430 Replace G2/G3 line with equivalent G1 line 8 days ago
Merged #429 Add a system setting for positionErrorLimit, stop cutting if reached 9 days ago
Merged #428 Add an alarm for gcode calculation error 12 days ago
Merged #427 remove function that was replaced in PR #389 12 days ago

There have been big changes between v1.2 and v1.12, though. Large jumps between versions can cause many odd issues. The changes have been enough that it might be a good idea to at least use Actions/Advanced/WipeEEPROM. You might not need to get rid of the settings file for that, just wipe the EEPROM then quit GC, and then start GC again. You might want to re-calibrate with the each time you make a large jump between versions, just to be sure - certainly when seeing the odd reactions to the arrows you’ve seen.


#15

I’m so sorry, there was a typo.
What I meant was:
I initially tried V1.16 and then V1.12.
So all the weird stuff happens when I install version 1.12 or 1.16 (possibly all others in between) and disappears when I go back to 1.11.

So it’s not a big jump from 1.11 to 1.12

I will have to try erasing the EEPROM.


#16

I tried wiping the eeprom but it didn’t fix the problem. Just when I erased the settings file it started working properly. I’ll just have to reconfigure now parameters manually.
Possibly there is some difference in the structure of the settings file that mixes parameters. I don’t know. It’s not my area of knowledge.


#17

That’s progress, good news!