USB connect lost, no machines running

So this is happening after about 20 mins of routing. Attempted to recalibrate and move sled around to re-start with no other machines running and after around 15 mins USB connection lost again, so it cannot be RFI noise. This is happening consistently and I am struggling to complete and projects.

The electronics are in metal case and all cables have chokes on them. The mains supply is on a filter. The PC is HP Elite running Win7.

Can you say if the USB cable provided is shielded?

I am stuck at the mo, any suggestions?

Are all screen-saver and power saving options turned off?
On windows level AND in the BIOS of the PC?

Yep, all obvious power savers off as per community Qs and As. However I have discovered a USB ‘selective suspend setting’ that I did not know about, it was set to off after 20 mins! Hopefully that sorts it. Thanks for the pointer. Cheers, Mike.


Thank for sharing this. I don’t have a win-pc to test, but this could be useful for many others.
Please report back if it worked.
Searching for USB ‘selective suspend setting’ arduino, the first post has some additional info:

Kind regards, Gero


The issue of USB power save kicking in seems to be fixed now, kit has been running for about 45 mins.

I have gone to some lengths to shield the electronics but do still have some residual issues which others might find useful to know about.

With the router and vac running all is well now.

If I switch the vac on / off it crashes the USB interface. Solution, don’t do it.

If I run my sawbench it crashes the USB interface. I need to silence the RF noise or run off a separate ring main or improve on the filters I am using.

Switching on lights (fluorescent tubes) also just crashed the USB interface! Still thinking how to fix that as I don’t work so well in the dark. The electronics box is high up on the rig near the light so maybe move it away.

Maybe worth beefing up the USB cable with improved shielding.

Any other suggestions?

It is going to be a long night cutting slots in radiator cover grills!

That’s all for now.

1 Like

This is as far as you can take it i guess

Are all of your outlets on the same circuit (same fuse or circuit breaker)? If you can add another circuit (I know, not exactly an easy ask), or otherwise plug into another circuit, it might help you.

1 Like

Update: Moving things to different 240 volt outlets did help.
The biggest win was the changing the laptop power supply to be on a different circuit to that of my workshop (even with mains RF filters and chokes). With the laptop connected to the workshop supply, switching on machines and lights often killed the USB link. With the laptop on a different supply everything appears to be rock solid. So this was nothing to do do with Maker Made kit, it was simply 240v mains borne noise entering the electronics via my laptop charger into USB link and destabilising it. Just wanted to make that point clear.


I am just cutting and boom the usb connection lost message and the project is ruined, I am not turning on other things or anything. I wish I knew more about the electronics to improve reliability. I basically can’t cut anything, it’s way too unreliable. It’s a bummer because this is such a good idea.

From time to time, in spite of using noise filters etc on the 240 volt mains supply, I still get this USB drop out which is so frustrating, it has ruined projects for me too. For me it comes from mains noise generated from my dust extractor and router and appliances switching in and out around the house. It seems to build up and causes a run to fail after 20mins or so and then the USB interface fails. My fix is to run the windows 7 laptop on battery only so with no mains noise coming into the laptop / USB affecting the controller board it is then 100% reliable. I may have to pause a job to re-charge the batteries but I can cope with that.

It would be good if MM could come up with a comprehensive supply noise filtering method that sorts all of this. The USB noise matter seems to be where the system is most vulnerable. In my experience, putting the controller into a metal case and earth screening all cables worked ok but this did not fix this USB vulnerability.

It’s true that a switching power supply tends to be noisier than a linear one, however in this Maslow setup it only powers the shield and motors NOT the Arduino. If it is noise present it more likely comes from the motors when they change directions in the form of EMF and will probably affect the encoder’s wires running alongside the motor power wires but not the USB.
Laptops and their power supplies are usually very well built to cope with this mains noise and are rarely affected by it, also USB cables are shielded to prevent noise.

I would look into software related problems, like power saving settings, sleep modes… also a shorter USB cable might help a lot.

some USB cables are shielded, many are not.but a shorter USB always helps. I
think it’s unlikely that noise on the encoder wires cause USB dropouts.

I may sound like a broken record here, but the ‘right’ answer is to put
webcontrol on a pi and use a very short USB cable :slight_smile:

David Lang

1 Like

To be clear on this point, I have no issues with the Maker Made supplied mains motor power unit or cable shielding on that unit, that is all solid.

What I do have an issue with is the mains supply feeding mains born noise into my laptop then feeding noise onto the USB line and locking up the Maker Made controller unit. Cable shielding wont help here, I have tried this and used ferrite cores on all cables. It is simply that running my laptop on battery gives 100% stability during a cut but with the 240v mains connected to the laptop stability drops to a point where project get ruined, entirely due to USB lockups.

Interesting, have you tried a power backup/surge protection like this…
It “should” fix the surge produced by turning on large appliances in your home.

Thanks for that link I might venture down that route at some point but I can get around 2 hours of use on my laptop battery so things ok at the mo.
Note, if anyone thinks of using their laptop on battery for long periods ensure that USB auto off is disabled in settings!!