USB device not recognized!

Not really required, to get it up and running.

But in the long run it can expand (and will expand when more people start using it)
and then you want stability.

From that point of view i was looking at it. Then you want a ‘known good’ / well supported foundation.
And this is wherethe *buntu’s stand out.

When a new users search for ubuntu answers they tend to find usable answers.
But with Arch they tend to find questions and suggestions. Not a bad thing, but comming from an OS like windows where all is hidden, and anwers are only for people wiho are microsoft certified. Then the Arch way is just overwhelming. :slight_smile:

Ubuntu managed to bridge that gap in more welcoming manner.

Once you know the basics and are geeky enough to dive deeper then Arch is exellent.

Now think woodworking: Most woodworkers just want to work with wood and add a little technology.
Then they find Maslow
And they want something that ‘just works’ Now that should be a little challenge, to get them familiar with the underlying stuff. But when everything is more challenging then ‘basic’ then people can and will get lost.
Some enjoy that challenge, others just want to build their woodwork.
The last group are the ones that will make the difference. Eventhough they will not be the most technical people when it comes to electronics. Since Wood is their tech.

This is why i want to find the most friendly solution. That has a stable future.

And Ubuntu may for some even be too much. When all you have ever worked with is Windows and then you build a machine, manage to upload firmware to an arduino. and actually manage to make the motors move. Thats a challenge in itself when you are new to this. Let alone start to work with an entire new OS.

The beauty of Linux is that the kernel has all driver crap covered. and just works (in most cases) And the rest can be configured. That are the two things that are still very hard to achieve with a windows OS.
Windows still manages to be difficult with basic hardware. And the closed nature of the beast does not allow to configure simple things.

Great for ‘stupid politicians’ who you don’t even want to tinker with a config. (think how corrupt some of them are) But when you need to teach a PC new tricks, then you really need a OS that is capable of doing more then just paperwork.

I rambled on a bit, but this mainly to complete the picture a little better.

Still things should also work on windows if possible. And a linux tool that can bypass all windows oddities will be a great tool to troubleshoot those oddities. But, and here is the thing, it should be easy enough for a person who is new to this to just use without having to tinker with an OS they never used before.

Ok here i stop my ramble. :slight_smile:

Again i apologise to ramble this slightly off topic stuff in this tread. I don’t want to put off any windows users, just hope to find a way that makes everyones life a little more fun.


No need to send a cable, I have a bunch. Thanks for the help.


Finally got some time tomplay withnthe cnc on the weekwnd and also got the unrecognized USB and USB device not functioning errors on surface pro. Tried different cable, tried different computer, same errors. Part of the underside of the mega board too hot to touch so figured something was wrong on the board.
Local jaycar store had this on shelf
Seemed to look just like the mega, and $50 later plugged it in and worked a charm. Has anyone else had their mega board die? Hardly been used.

I’ve had that happen when I had the 12V cable plugged into the Arduino instead of the Maslow board, and plug/unplugged the USB cable while the 12V was on. :anguished: I looked into repairing it, but did as you have and replaced it.

It was how i left it using it from using it for the last few months, power cord was not changed to mega board

1 Like