USB device not recognized!

When I plug in my Arduino to my windows computer i get “USB device not recognized”. This obviously prevents me from uploading the firmware. Any Ideas?

Woah I have not seen that one before.

I would try uninstalling the Arduino IDE which comes with the USB drivers and installing it again.

Has anyone else seen an Arduino not be recognized by windows?

What OS version are you running?

1 Like

That’s the best suggestion. The Arduino IDE installs the proper drivers when freshly installed. Probably leave the Arduino disconnected during the uninstall/install process as well.

1 Like

How old is the machine? What version of windows? Do other USB devices work? - You might want to reach out to the Machines manufacture. It is possible for the the USB setup in Windows to become corrupted. First do you have a second machine you can test to see if you get the same message? 2nd do you have another USB cable possibly from a pinter you can test with? If it is not repeatable, the way you reset the base USB setup is to delete the root hub from device manager. If everything is alright with the machine rebooting will force the base setup to be reset. Be cautioned if there is a deeper hardware issue you may need to take the computer to the manufacture or professional repair station. Preceded at your own risk, no warranty implied, removing the wrong thing can also disable the machine. You should have a ISO of your OS burned to a CD or memory card incase it is requested when you reboot. For this again you might need to reach out to the manufacture.

Thank you

1 Like

Welcome @Abard123. From which batch of the Maslow Kit did you purchase your Mega?

Thanks for all the suggestions. This computer is 3 years old with windows 8. I tried reinstalling and restarting and I am seeing the same note. It is saying the USB device malfunctioned. I can try a newer mac this afternoon, but other USB devices work fine.

Also, i received this Maslow about 2 weeks ago.

1 Like

The Mac is a great way to test. If you can’t get it to recognize there I will send you a new Mega and we can test if there is something wrong with the Mega itself.

One more thing to check is that the 12V power cable plugs into the Maslow board and not into the Arduino Mega.


Thanks, Ill check back once i can test with the mac.

Thanks for thinking of testing it on the Mac! Sorry for the trouble!


Thank you for the updated information. Make sure you plug the Arduino in before opening the Software on the Mac. The IDE usually won’t see new hardware after it has opened on the Mac.

If you see no error on the mac you can check the list of USB devices in the system information list.
Apple Logo upper left corner of the screen -> About this Mac -> System Report-> USB in the list on the left.

If you don’t already have the Arduino software on the Mac these might help -

Let us know what you see on the mac.

Thank you

1 Like

It almost makes sense to have a pre-cofigured USB image with all the basic tools installed to be able to test everything.

Now, that would be a bit too much to ask for… Rolling out an entire OS is a huge job in itself.

But in a case like this Linux could be a big help to troubleshoot this. As the kernel has all the ‘drivers’ on board for this basic stuff.

Does anyone know if a minimal CNC minded Debian/Ubuntu OS already exists?
Hmmm this is kinda off-topic… Should i make a new thread for this?

I’m considering making a docker image for this purpose.

1 Like


My apologies I didn’t answer the question -

Puppy was the first *nux I played with. It might be possible to roll GC & the Arduino IDE into this.

Thank you

I think it would be wise to see if there already is an existing distro or at least a bunch of people who are planning to go this route.

I have made a thread for this, so that we don’t hijack thisone.

1 Like

Unfortunately, The mac does not see anything.

Nevermind! It was the USB cord. The one that came with the Maslow actually does not work, i tried to use it with my printer. That was an easier fix then I expected. Thanks for all the suggestions!


I’m glad it’s sorted. I’m sorry for the trouble it caused. I can’t speak directly for Maslow but I’m sure it can be resolved quickly.

Thank you

Is not really required, for testing you can run a kubuntu or manjaro(arch linux) from the usb drive, install and test everything without installing anything on the the hard drive. LinuxCNC is no fun for GC as they are to far behind for Kivy.


Yay!! That is great to hear and I’m glad you thought to test the cable! I might have just sent you a new Mega and we wouldn’t have learned anything!

Do you want me to send you a new USB cable?