V 1.14 sled alert during calibration

Updated firmware and software to v1.14 and decided to do a full re-calibration. Proceeded to the measurement step. Set motors to zero after positioning tooth to 12 o’clock. Extended the chain 3100 mm. When clicking Pull chain Tight and Measure an Alarm Notification pops up saying that “The sled is not keeping up with its expected position and has halted. Click the ‘Stop’ button to clear the alarm…”

Will try a full restart and update with results.

Reset to defaults and had the same issue. Reset again, and manually retracted until close to tight, then ran the pull tight command and finally didn’t get an Alarm Notification.

Proceeded up to the point of setting my Z axis and got the same notification when raising my Z .1 mm. After some testing, determined that instead of moving the Z motor, the left motor was being engaged.

Tested. Found that both left and right motors were engaging (I assume to stabilize). Turns out I wasn’t seeing Z movement as I had managed to knock the connector loose while power cycling the arduino.

Darn, that alarm should be disabled during that step because we WANT the motor to stall. Let me take a look at that bit of code again and see if I can figure out what is going on.

Edit: I’ve created PR #732 to increase the threshold and hopefully make that warning go away. @Tyler_W_Cox what OS are you using? I can make you an early version to test


All testing was being done under Windows 10. (Same system that was
previously used for cutting, just a new folder for the new version of
Ground Control.)