Maslow Home Maslow Community Garden Newsletter

*Warning* Don't buy the Raspberry Pi4

So I ordered a Pi 4 - not 1 but 2, I got the big Mama expecting good things. Spoiler - This is the biggest Turd of PC I’ve recently experienced.

First I tried to download “Buster” the new OS - It only took 6 hours. I tried to download Noobs, the package is incomplete and won’t boot. That was only 4 hours to download. After trying 4k HDMI cables that work with my other video tools, No 4K screen, I must have tried 30 diffrent combinations. Finally I say F*ck it - I hull out a 22 inch 1080p monitor - Bingo it boots. I get a desktop and 3 seconds in the PI locks up. Basically it keeps overheating, I’m using the PI Foundation case and Power Brick. I took the top case off. I can keep it running if I blow on it. I’ve rebooted at least 35 times getting through a basic boot, config, browsing. I got to a config option to “enable 4k” not impressed, 4k is no go on a 40 inch 4k LG Computer Monitor, & a 50 inch Vizio TV even after Enabling 4K support.

It’s 80F degrees where I’m at. I’m totally disappointed, if I have to buy a $35 cooling solution for a $35 computer it’s a wash. I think they let this one out too soon. No doubt a better management profile will come out later, it will throttle back the “upgrades” to drop the heat. Every 2 minutes the USB bus froze my keyboard required a unplug and plug to gain a UI again.

I think I will try to return both of them and eat the $60 in shipping. Hardware has big problems, software is not ready. Don’t buy this.

Be ware currently USB booting is not available on the new hardware. Also the CPU will burn to the touch at idle usage the entire board gets hot.

All of the peripherals I’m using work with the Pi 3B+, The range on the keyboard dropped from 20 ft to 3 inches. There is some seriously bad interference coming off this board.

Take my review with a grain of salt. With a heat sink and fan it might work better, but a pig with lipstick isn’t a date.

Thank you

5 Likes

That’s disappointing. I have been waiting for the Pi 4 for a project. Now I think I’m going to wait and see what the Pi community finds.

Yes, it needs heatsinking. get yourself a decent heatsink and it will be faster than the pi 3. without one, it will throttle and be slower.

you should be able to use any old heatsink you have lying around, it doesn’t need to be anything special, but it does need to get the heat away from the lidded chip faster. really, they should come with a heatsink, but it shouldn’t cost more than $5-10 if you don’t already have one lying around.

2 Likes

But @Jatt if I take the heat sink off the Maslow shield the chip I took it off will run hot.

LOL

Thank you

OK - from pervious testing I had a 2 fan heatsink for the Pi in my junk pile. I put it on the new pi4 a $15 add on. Surely it will work better now right? The heat is still coming through the bottom of the board. It locked up after 3 minutes playing video in a window from CNN. Yea I use CNN for testing not Youtube. It just goes black on the screen and can stay down for more than half a minute. What an awesomely useless interface.

I wish I had picked up a second RCA tablet -

For $100 there is a full fledged os, screen, keyboard, pointing device, a real computer. And guess what, it doesn’t overheat.

Thank you

1 Like

too bad. I think I will wait half a year and hopefully some nice 3rd party cooling solutins will be available and the process of loading will be more stable.

yea - well still not impressed

1 Like

@Bee, But, does it run GroundControl, or is that not your intention?

I would think that the Pi4 now running OpenGL by default and the option of up 4 GB of ram would make a descent controller for the Maslow.

I was looking at it running embedded linux for more industrial uses. However I still would look at Ground Control on it under Ubuntu it is vanilla linux. It will take a bit for the Ubuntu to catch up to the new board.

It’s just disappointing when a project as mainstream as this will go to market without basic functionality working at all and ship, we’ll fix it later.

Remember this is a kids product to get kids involved with computers and engineering.

Thank you

1 Like

Well, you are certainly entitled to an opinion and you’re contributions to this forum are greatly appreciated. Maybe your post title seemed a tad harsh to me, considering you somehow got a hold of a limited first run production board that is running pre-lease OS. Ok, so, maybe it’s more bleeding edge than cutting edge kit, at the moment. With all respect I’d still like to see an objective test of it running GoundControl.

I think the Raspberry PI has evolved into more than just an educational product.

I’m open to complete criticism.

However I have not heard that the Pi foundation put out an adjustment to it’s Mission statement.

Try to buy 20 Pi Zero W computers. You will find restrictions. This is due to the mission of the Pi

I bought from the released product and express shipping from England. If I had been sent a prerelease for review I might have a diffrent opinion. I have a release product that can’t operate long enough to get the update downloaded that might help it.

I appreciate feedback and other opinions. As it stands there is no possibility of installing ground control as it will lock up before it can load the Prerequisites. If it gets significantly better I’ll report that too.

Thank you

1 Like

@Bee, Out of curiosity, what are using to power the pi 4?

This article points to a problem with using a shared pull down resistor on the usb-c connector for the board and requiring specific power supply. Strangely some cheaper phone charger type units would do better than a PS from a MacBook Pro.

https://www.scorpia.co.uk/2019/06/28/pi4-not-working-with-some-chargers-or-why-you-need-two-cc-resistors/

Currently, one of the most active discussions on Hacker News.

https://news.ycombinator.com/item?id=20361946

2 Likes

I bought a pair of the Pi foundation power supplies.

I’d love it is a power supply would solve the issue.

Thank you

1 Like

My inclination is to believe that the power supplies are fine and not the root of the problem, given the information you’ve posted above. For giggles have you checked the voltage on the power supplies to ensure you’re getting 5.1V?

If for some reason the voltage was low or unstable it may contribute to over heating problems.

Thanks for the post in general, I was going to pick one of these up to play with, but I’ll dig a little deeper and keep an eye on the heat issues and the resolutions you linked to above.

@hrzvlcty

Welcome to the forums. I have several Pi 3B+ Running Ubuntu and a remote desktop with Ground Control. They are very reliable. I was hoping the 4 would kick performance in to a new level but it didn’t turn out that way.

Thank you

The rPi4B uses more power than the Jetson Nano at close to 3A so you had better have a good power supply and power supply cable or you’ll get lock-ups.

As for the new firmware, that’s no surprise since there were issues already found which required updated firmware. I forget what it was.

And considering the rPi3B+ would throttle down without a heatsink, why would anyone expect the rPi4 to perform without a heatsink? ie if the rPi3B+ needed a 20mm heatsink to keep running at speed, how could the rPi4B not?

Also, welcome to the bleeding edge. Some of us still can’t even get the rPi4B…

@JWoody18 FYI in case you haven’t seen this thread yet. I wanted to tag you in it after reading your good contributions to bar’s thoughts on designing a new controller topic.

Edit: please don’t read this as disagreeing or disputing your comments from that thread, just wondering what your thought are on this thread and how we might able to move forward.

Thanks. I did see that and was anticipating it would be raised. It does indeed sound like a few teething problems with the launch of the pi4.

I did notice that there is a software update to reduce power and heat and they are working on getting all the software images rebuilt. I suspect this will get ironed out over the next 90 days or so. They are now the highest volume computer producer in history so this isn’t their first rodeo. I’m confident the negative experience reported in that thread will be a thing of the past long before a new maslow controller needs to ship and probably before any serious code work is done.

I am disappointed that the pi4 launch does seem to have been a bit rocky although a sample of one is not necessarily indicative of overall experience. However I am also aware of other complaints about power and heat, so something is suboptimal.

In the mean time, the 3B+ model also continues to be available and doesn’t have any of the reported issues and is pin compatible with the pi4 so there is a good migration path there. Since the base pi4 is the same price as the pi3b+ there is a built in upgrade in the wings and a solid path forward until then.

Having managed supply chain for this type of stuff and knowing the reputation of the Pi foundation I wouldn’t hesitate to design around the 3b+/4 and benefit from the vetting and optimization work that the massive Pi community will be doing in parallel with the maslow controller design. The value of that community effort and the foundation effort going on in parallel shouldn’t be dismissed. Always better to stand on the shoulders of giants when you can.

Jeff

1 Like

Pi 4 now much happier -

I had to clip off the POE header to install it.

I ran the updates for the OS

I got and installed the firmware update:

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=243500&p=1490467&hilit=vl805#p1490467

ref:

A new 4k Cable has 4k working:

This resolved many of the basic issues but once running What can you do on a new OS (Buster) not much.

  • You can not boot off of USB yet.

  • No Docker support

  • No CNCJS imge

  • No Ubuntu image yet

Many things are not supported.

Time will resolve a lot of the issues, booting from a SSD like the Samsung T5 is high on my list.

Still there is an incompatibility with one of the most popular small factor keyboards on the Pi. There are a new set of incompatibilities with the “fix” firmware for some other USB products as well.

A test of several 4k video sources resulted in choppy video. At the end of the day I now can keep the OS a float at ~48 - 54C, throttle is at 80c, but is still feels like I have a 4 wheeled car with 1 flat tire trying to win the Indianapolis 500.

You can check your temperature with this command:

/opt/vc/bin/vcgencmd measure_temp

Ref:

Docker work around -

Someone want to test Web Control?

Thank you

1 Like

I found this interesting -

Thank you

1 Like