WebControl for Windows Beta

Another slight update to allow you to shutdown WebControl from the browser by going to Actions->Shutdown WebControl. It’s better than having to go to the console window and hitting Ctrl-C multiple times or closing the console window.

2 Likes

Well done! On Windows 10 it is automatically blocked when first run. When the warning window comes up hit Advanced-> Run Anyway. Tell Windows Firewall prompt to allow by clicking Allow. From there all is awesome sauce!

Thank you

2 Likes

Any little chance that you compile WebControl also for 32bit devices?

FWW - 64 Bit became a standard in 2003. This is Madgrizzles call but my opinion is 32 Bit is a dead architecture. I would have to dig but the framework may not support it.

My 2 Cents

Thank you

Thank you for your feedback.

I’m aware of that fact. Since such controllers do not need that much power, I tend to use fairly old netbooks which run on 32 Bit. If the system supports it and it’s only a couple of clicks away, then why not.

But I’m not a coder and I don’t have a clue… :wink:

I’m not exactly sure how to do it. Have you tried running it on 32 bit machine?

Yes, I did. It says something like “This app cannot be executed on this device”.

After I posted, I did a little googling and it seems to build a 32-bit version, I have to build using a 32-bit machine, which I do not have setup. I’m looking at an option to move entirely to pyinstaller builds and see what options are available for building for different platforms (maybe using a bunch of virtual machines).

3 Likes

Over the weekend I worked with we control for windows and noticed the following:

  • when I wanted to reset the chains the pop up menu was truncated on my phone as opposed to the options presented on my laptop. I could not find a way to access the menu items not shown on my phone’s display.
  • In my previous ground control setup I used the holey triangular files and firmware. When I migrated to webcontrol the menu for holey triangular calibration is not available. Did I lose my calibration even though I provided a path to the ground control.ini file.
    Thanks

Are you able to scroll down on the phone display?

TL;DR: Update the firmware using Actions->Upgrade Holey Firmware. I think your calibration is fine.

WebControl thinks you are running stock firmware because the holey calibration firmware you are running doesn’t do anything to indicate that it’s holey calibration. It reports back the same version number as a stock firmware. This isn’t a problem when you are running a version of ground control that’s only compatible with holey calibration. However, webcontrol is intended to support multiple firmwares, so each firmware needs to report what it is. In order to do so, I modified the ‘stock’ holey calibration firmware to report a different version number (basically, added 50 to the stock version number). Since the version number being reported is 1.27 or so, webcontrol thinks its the regular stock maslow cnc firmware and therefore disables the holey calibration functions. If you upgrade the firmware using webcontrol, the version number will be set appropriately (51.27 or so) and webcontrol will recognize it. You may need to reimport groundcontrol.ini, but I think you’re fine as it is. Note: if you go back to using ground control, you will likely get a version mismatch error… just reload the original holey firmware and you’re back in business.

1 Like

The actual version works very well. :slight_smile:

I do not want to put pressure on you, but is the 32 bit version for Windows still an option for you? :wink: I don’t need a release date, I’m just asking.

I think it depends on how easy it is to get a 32-bit version of Windows running in a VM of some sense on my Win10 64 bit machine. After I complete the migration to pyinstaller, I’ll take a look and see what can be done.

Thank for your feedback. Let me know if I can do something for you. I could “lend” you my 32 Bit machine. :wink:

I really need it as a virtual box vm…

I’ve posted a new “test” release for WebControl that includes the ability to update itself. This version doesn’t add any new features beyond the updating capability. If you are inclined to help out and test whether/how it works, please feel free and report issues either here or on github. Please read about the release when you go there… there’s some important things you need to know.

1 Like

I had a Windows tablet running Ground Control, but it died on me earlier this year. I finally got it replaced, and I now see that WebControl is the new standard. It’s not as straightforward to me to setup though.

How do I run WebControl on my Windows device and make sure I have the newest version? I’m a newbie to Github and clearly do not know my way around code. Am I better off getting a Raspberry Pi? Thanks.

written details here. and here..

The first link has a video of what you desire at the top of the page. You need to go to the github release page and download the single folder version and unzip and run it. No compiling from code, just use the prepared release version from github. If you can get your groundcontrol.ini file that will help otherwise do the menu-> actions-> quick configure and enter the information and you should be off and running.

It’s not as easy to find releases on github as it used to be (for some reason)

Download either the singlefile (simplest) or singledirectory (fastest) for your Windows 10 release. If using singledirectory, make a directory somewhere to extract the files into and then create a shortcut on your desktop to run webcontrol.exe. The singlefile version can just be copied directly to your desktop to make it easy to run. The singlefile version decompresses itself into a temporary directory when you run it so it takes a little more time to startup vs. the singledirectory version.

2 Likes

I am wondering if there is a version that will run on a Mac?

webcontrol is written in python, so the core software is OS independent. The
issue is going to be installing the libraries that it needs (or getting someone
who knows macs to package it with those libraries). I know just enough to expect
that the brew package manager will be what you need to install it.

The most common install of webcontrol is on the Raspberry Pi (on Linux) because
it’s cheap to dedicate one to running the system.

David Lang