Gcode stops working after 300 lines

I’m having trouble with the gcode stop working in groundcontrol after about 300 lines. The code was generated with Easel. The file is for the final sled. I removed some of the cuts and redid the gcode but it still stops working after 300 lines. I had no issue with the setup or celebration and everything seems to be working fine when generating the gcode. Thank you for any help.


If you’re OK with sharing the GCode I’ll take a look at it.
You can also try submitting it online to a GCode viewer, such as NC Viewer and see if it shows up anything


Thank you, I’m including all 3 version each with a different tool path.

Well apparently i cannot upload because I’m a new user :thinking: any idea how I can get this to you? Ed.


After enough likes you can attach

1 Like



So if we are a new user, we can’t get help until we get more likes?


most assistance doesn’t require attachments, and it’s a good defense against
spammers (not an admin here, just explaining their logic)

usually this clears up within a few posts.

David Lang

I think also doing the various “welcome to…” training exercises also helps with that

I had a similar problem when I fist started. Everything stopped when the computer when they to sleep.

Hello Steve, thanks for the reply. I have my sleep mode turned off plus tried a totally different code and the same thing happened. I’m using ground control 1.26 and firmware version 1.26 on an iMac.

would webcontrol be a good option over groundcontrol? can it be used with a mac?

well found my answer about webcontrol, it does not work on a mac. so I’m back to my original problem of not getting past 300 lines of code. with groundcontrol. Does anyone have any suggestions? Thank you.

Does a Mac have a automatic USB power down/off like windows 10? Some ppl had issues with connection due to this being on in windows?

Hey Tim, not that I’m aware of.

trying to figure out if my problem is with GroundControl, Firmware, or the code. So the first thing I did was try another code. It worked fine until line 307 then stopped. Then thinking maybe the problem was the software I was using “Easel”, So I downloaded the gcode for the Maslow Logo and ran it. I made it to line 134 before it stopped. the last line displayed was "<idle,MPos:10.13,8.83,-0.20,WPos:0.000,0.000,0.000> "
Does anyone have any ideas or suggestions or a different direction to go?
Thank you,

Does ground control have a sending buffer option like webcontrol? If so, maybe try and turn it off.

"<idle,MPos:10.13,8.83,-0.20,WPos:0.000,0.000,0.000> "

Is a periodic position message giving the current machine position in both machine and work coordinates. We work in workspace coordinates, the firmware keeps track of the difference, and we rarely need to be concerned about the MCS numbers. This one says that the spindle is positioned at workspace 0,0,0.

The last 25 or 30 lines of the log would be very interesting, to see the last few gcode lines processed and any status or error messages.

1 Like

Is there a log feature that i can retrieve?

Here is a screen shot of the progress. The last few lines are when i stopped the program.

So i turned off all energy saving including harddrive sleep on my mac plus i set the buffer gcode in GC to off. Rebooted and started new. The first run made it 16.8% and line 184, the 2nd run was 14.4% and line 161. All ending with the same MPos as above. Just ran it a 3rd time made it to 68.1% and 760. :thinking: