Maslow Home Maslow Community Garden Newsletter

Multiple Issues Recalibrating Machine

Good evening,

So I’ll start at the beginning. Ive had a few instances where when I dont use the maslow for long periods and come back to it, I lose my machine home position. Im not sure if i am supposed to keep power to the machine while im not using it (let me know, but this isnt my current issue, just what got me here). In the past I would just start over fresh, recalibrate as if it were a new machine and I was good to go (a bit of a pain but it got the job done). However, this past time it didnt recalibrate.

Currently, the X and Y axis are calibrated and working properly. My Z axis is not. When I try to raise or lower it, it doesn’t move. I hear noise from both the X and Y axis stepper motors but they dont move. I get no noise from the Z axis stepper motor. I disconnected the Z axis motor from the coupling and tried (thought maybe it was bound up) and still nothing. I am not sure what I should try next or what I can do to further try and diagnose what is causing my issue.

Any and all help is greatly appreciated.

-Andy

if you are using the orange Ridgid r22002 router then the orange plastic piece inside the lead screw might be broken?
nevermind you said it is not even moving
what happens when you run a motor test in ground control

I just ran the test. L Motor Pass Pass. R Motor Pass Pass. Z Motor Fail Fail. It did make noise like it was getting a signal, just not moving.

gear issues on the pork chop express?

1 Like

Welcome to the Forum @BigTroubleLittleCNC!

Kind regards, Gero

I think all 3 companies that sell the maslow kits have a one year warranty. contact the company you bought it from and they can probabaly help

Can you try unplugging it and plugging it back in on each end? It could just be a loose connector.

If that doesn’t do it the next thing I would check would be for an issue with the mechanism being jammed which is preventing the motor from rotating.

Unfortunately this is more than a year old.

I disconnected and reconnected both ends of the z axis motor. I also disconnected the stepper motor from the leadscrew on the z axis mechanism. I ran a motor test and had the same result, made a noise but no movement.

The Z axis mechanism moves smoothly moving it by hand.

-Windows 10
-Arduino Mega
-TLE5206 v1.4
-Ground Control 1.26/ Firmware 1.26 (not sure if thats the information you needed here. let me know if you need something else)

Thanks for the help

1 Like

No, you calibration settings are stored in the groundcontrol.ini file in your user{name}-folder and in the eeprom of the Mega and should stay constant after powering off.

With the amps that the TLE takes i don’t think the Z-chip is burned out.

Are not known to me to make Z-Axis problem.
The Arduino Mega however, in some rare cases more related to older FW versions, could sometimes fall into a mental unstable state. The solution for that was to wipe the eeprom and re-flash the firmware.
Don’t think this is the solution to what you see, but if a computer is nearby, it can’t harm and exclude one link in the chain of possible reasons.

I agree with that an issue like that has been seen with a wire break, a lose soldering point and not sitting plug.

Can you confirm that in GC in the settings that Z-Axis is on and the pitch has somthing + or - 0?

That sounds like a bad gear or encoder in the z axis motor assembly. Can you swap the cable with the left or right motor and see if it still fails? This will narrow the suspect from cable to motor.

1 Like

Yes. Z-Axis in on position and pitch set to 3.17.

Is there a procedure to do a full wipe and make sure I starting completely fresh? Im not sure if I am possibly keeping something from previous installs that could be causing an issue.

I did this and it passed while attached to the other motor. I have the Z axis motor off the machine and am going to try taking it apart and see if i can find anything obviously unusual.

In GC under -> Aktions -> Advanced, there is the -> Wipe Eeprom.
Then you close GC and flash the firmware new to the Mega.

Your settings should be read from the groundcontrol.ini file.
If you want a complete fresh start, rename that to keep a copy if the Maslow was good calibrated.
Good settings can be copied from that file.
GC will create a new groundcontrol.ini at first start with default values.

Z motor and the other cable? The z channel is ok because another cable and motor work. Put z motor on left or right cable and test. Likely the same but will rule out a broken wire.

It is fixed!

The sheet metal housing on the Z motor, where it attaches to the gear box was bent. Im guessing it must have gotten bumped while I was reconfiguring my frame (mounting it from hinges off the wall of the garage so I can get my car in the garage when the Maslow isn’t being used. I used my gentle persuasion instrument to get it back flat and the motor was able to rotate freely. Got everything put back together and recalibrated without further issue. I feel a bit dumb for not checking the motor more closely to start with.

I want to thank everyone who spent their time responding and helping me figure this out. It was really encouraging to see how active this forum is (I dont participate in any, so I waited longer than I should have to sign up) . I now know that if I have an issue I have a lot of helpful people who are willing to help. I may try to post my Z axis mechanism and convertible frame on here really soon, hopefully you guys like them.

Thanks Again

-Andy

4 Likes

picture please :grin:

Glad you found and fixed it! Give webcontrol a try and you shouldn’t need to recalibrate each time you dust it off to use it again. Once you extend the chains, mark the chain link on the 12:00 sprocket tooth and then you just reset the chains when you set it up, or you could move it to the extended chain position before storing it and just line up the chains if they came off before you are off and running again.

Shes not much, but it gets the job done.

3 Likes