Z axis & Motor Calibration

Hello, I’ve finally managed to build and mount everything, including my z-axis, a little machining done to make a nice fine accuracy for the z.
I’m experiencing a calibration or controller ‘problem’, this is the scenario, and I’ve spent a day and a half going around in circles.
Scenario:
- Mega mounted on 'wall mounting 2x4 (4x2 locally ;-)), noting this is an older CCA although CCA does contain copper and chromium, it shouldn’t have any Extra Low Voltage, nor low Voltage conductivity issues (LV <= 1000V) e.g. It’s an insulator, just like wood.
- PWM module mounted on the Mega, L&R Motors on MP1,MP3 with Z on MP2, e.g. Z and LHS motor sharing the same PWM.

Calibration observation:
- Calibrated ok, until the final ‘chain length’ where it wanted the chain feed mounted ‘upside down’, e.g. mounted on the top of the cog from the RHS feeding over the LHS, this is a mirror of how my motors need to work.

Code latest firmware and ground control v1.13 (NB should set the version comment in the ino)

Problem:
- Test motors all seems ok forward, reverse, little movement on the Z all happy.
- manually move Z all motors move!

There may be something simple, I checked the zip (speed) ties holding the motor board down, now the new glue has fused the heatsink theres no distortion or too much pressure.

Any steps or suggestions welcome, I will get some nylon spacers and longer screws to put some air between the mega and the CCA, however I’m extremely suspicious that will have any impact.

Happy to provide any tips, photos, config etc.

Cheers,

Guy

This sounds like an issue with the choice for feeding the chains from the top vs feeding the chains from the bottom. If that setting does not match your machine setup the motors will behave exactly as you are describing. That is where I would look first

you can set the machine either way, so if it’s not going the way you want, you
need to switch it to match what you are building.

Hi everyone,

Nope, the chain selection is right, the length of chain calibration works, its just the extension of chains to the ‘set’ length step, I’m wondering if the default firmware settings are maybe ‘fried’ I ran out of time on the weekend to troubleshoot, given the test motor function ‘worked’ my problem is z axis controls activates ALL motors, so something is not right.

The test motor function goes through all the motors, however trying the z axis on the gui and the motors go all at once so something is confused…

Maybe time to crawl through registers and the code / firmware reset. ;-( So close once done I can cut my holes and the ‘vent’ lines for my vacuum table, or cut my sled one of the two, the sled’s looking pretty good cut by hand…

Guy

… Then ubuntu Matte on Pi for headless… Just like my 3d printer.

All of the motors will power up and down together, but when moving the z-axis the left and right motors should be position holding. They will buzz but they should not move.

Hmmm I still think this sounds like a chain selection issue, but if the setting is right it could be a bug in how the setting is being communicated to the machine.

In the “bottom feeding” configuration the chain will extend in one direction when doing the length of chain calibration step and then go the other direction when doing the “set length” step.

You can wipe all of your machine settings by clicking Actions -> Advanced -> Wipe EEPROM

When you have a chance would you confirm that the changing the chain feed direction setting switches which way the sprockets rotate during the set chain lengths step?

That will help me track down where the bug is.

The setting to change is this one here:

image

1 Like

Ok started clean, found one ‘suspicious’ item the usb plug case was distorted and close to some surface mounts! That may or may not have been some contribution. ‘adjusted’

Reset flash, burned eprom, cleaned everything up set usb cable / strain reliefs.

The motor calibrate is still backwards for the LHS motor on setting chain length, on left motor with chain feed over top chain should start from left not right mirror your photo, photo correct for RHS not LHS then rotate clockwise not CCW! The reverse on the other one, logic bug! :wink: worked measured, then ‘added’ a couple links lifted, and set to sled from moto.

SO the use case your to the 'set chain length step, chosen the photo for over the top, RHS motor, perfect, LHS starts wrong side, correct for photo but does it CCW rather than CW, so what you do is feed it out, roll the chain over, take to sled.

I think the Z motor is now running on its own, so may have been bum flash or short!

Now manual chain control great for left right up down, z-axis :frowning: !!! Gcodes for Z? it’s well past the yard arm, so beer o’clock! and dig some of the steel shards out of my thumb!

I’ve lost one of the ‘sprockets’ do you have what those cogs are called, and their spec, the chain load is too light, I think I’ll be to milk bottles filled with water as well, however very good mechanics, and so close to cut!

On the chain load, our friend newton, F=m*a (g=9.8m/s, 32.2ft/s) so if we have a 10lb / 5kg sled, connected by 2 cables and 2 cables holding on a u like a pulley, you have:

LHS | Drive motor | RHS

LHS 2 x chain (fixed point, sprocket on drive motor, and ‘load sprocket’

RHS 1 ‘rope’ chain to to the ‘sled’

To keep in balance, LHS load needs to equal RHS.

Take the total sled weigh, throw on a scale with the bricks, divide by two, fill your milk bottle that much!

1l water = 1kg, 1 cup of water = 10oz = 0.625lb, your choice of systems :slight_smile: NB Imperial measures (CDN by birth, Oz home now)

Temporary fix for lost sprocket, 2 washer or a bobbin.


1 Like

Fantastic, a couple touches with the Tig torch will be sweet!!!

Guy
Z-Control a Gcodes??? :fleur_de_lis:

Is Z set enabled?
image

:wink: yes turned on, want to move the motor to get it zeroed, and the ‘attachment’ to drive screw secure. :wink: The Z on the ground control interface don’t seem to do - values, although maybe I need to manually screw it down?

1 Like

It should work by using the buttons :thinking:. If not, something is wromg.

Homer Simpson award! I was using the buttons below the Play, Pause, Stop! Done ready for tomorrow. tyvm! When this works back to making the machine headless.

1 Like

The buttons below let you jump to last or next Z in the gcode and in the lines of the gcode.

Ok final test, v1.13, test motor control moves all the motors well. The Z axis seems to select one or both the other motors.

This unit was one of the originals (kickstarter), so I’m not sure if there are any version or revisions, I can see the section of the code so i’ll dig into it further tomorrow.

Success, ok Z all happy, I’ll add a few to enhancement requests.

Tyvm, all the help was really appreciated, almost to the calibration cuts.

I must’ve done something not quite right on the calibration, and I do note that I need to move the motors up a bit, probably another 300-400 mm, will wait until its on the wall, can alway flip the wood over in the short time!

Also noted going to add another nylon bush or bobbin assemble to the slack / chain tensioner, a few ‘cog’ creeps on the chain looping over bush kept all happy. If it did not require a water table I’d hook up the plasma torch or mig head to her! Vacuum helps keep the sled stable as well.

Manual entry for the ‘home’ position and chain length would be great, time to troll the G-Codes. To test cuts then Headless!!!

2 Likes

however, the tension on the two chains can be massively different. When you are
cutting in the bottom corners, almost all the weight on on the near motor, the
far motor has very low tension.

LHS = RHS only happens along the center line of the workpiece.

True on LHS-RHS in middle, however as a base and you will never get to cos(0), e.g. no tension on one cable, the load tension will be distributed based on the relative angle.

The balance will be close, you could go as a range of low from 1/2 - 2, the 1/2 being in perfect balance, and the 2 being the limit never hit. I think we’re trying to avoid ‘lash’ / backlash as the motor changes direction (from pull to feed to pull), correct?

On my system one item is the ‘chain guide’ e.g. from the tensioner system to the cog the centre of the chain is not aligning to the centre of the cog, this results in it climbing on the cog the dropping into position, that transmits down the ‘cable’ to the cutting head. Theres a simple feed mechanism used on bicycle chains… a couple touches with the tig and the chain will guide nicely.

Last day of work tomorrow, then back to the garage / shop.

Guy

actually, as the angle gets to 10 degrees from vertical on one chain, it is
holding ~90% of the weight, so you only have 10% available to tension the other
chain (am I doing the math wrong here? it’s very possible)

David Lang

I have been thinking about geometry and forces a little, so I decided to create a spreadsheet to figure it out. Assuming 116 inches between sprockets, sprockets 18 inches above work area, and a 20 lb sled, I get the following:

Locations tensionLeft tensionRight
lbf lbf
Center 17.1 17.1
Top Center 33.7 33.7
Top Right 10.3 20.9
Middle Right 4.7 18.8
Bottom Right 3.3 18.5
Bottom Center 13.3 13.3
Bottom Left 18.5 3.3
Middle Left 18.8 4.7
Top Left 20.9 10.3

Here’s the spreadsheet if anyone wants to see details.

3 Likes

10 posts were merged into an existing topic: Maslow Chain Geometry Spreadsheet