Maslow Home Maslow Community Garden Newsletter

Z axis movement without gcode instruction

my z axis is moving without there being instructions in the program for that. it isn’t router wobble either its the actual motor moving. anyone know why this is happening and how to fix it?

Is this happening while running a cut or just while the machine is sitting still?

While cutting. It also raises about a 1/4 inch when I define 0

Does it raise slowly and steadily the whole time, or rise only at particular times?

Only at particular times and in different places each time. It also moves up and down not just in one direction

If you run the same file will it move up and down at the same places each time?

No. Different places and diffrent amounts.

My hunch is a loose connector on the z-axis motor cable. I would try pulling out the connector on both ends and re-seating them. If the signal from the encoder is intermittent I could see this behavior coming up.

Actually. That’s what I just tried a minute ago and that worked lol. I’ll see if there’s any more trouble with it. Thanks!

1 Like

Excellent deduction! I’m glad to hear you caught it :grinning: